When shutting down, the VM is stuck in the state "Stopping" and Hyper-V Management Service (vmms) must be terminated

Asked by Markus S. on 2018-07-28

To increase my chance of receiving an answer I decided to translate my question into English. Original German text below.
My problem is, that my Hyper-V Guest (Ubuntu Server 18.04.1) is stuck at the state "Stopping" when I shut down the guest. When this happens I am not capable of doing any actions regarding this guest. The only solution is to shutdown the other guests and kill the vmms.exe.

I recognized this behaviour in version 18.04 before and decided to wait a bit for the software to mature. Unfortunately this error also occurs in this version 18.04.1.
It seems that the system is shutting down fine (reboot or shutdown) and when the moment comes where it powers off the image is fading but it hangs/stucks at this faded image and it does not turn off the machine. Last time I initiated a shutdown via ssh and was not connected directly through the Hyper-V manager to the console. When I saw the "Stopping" state I tried to connect to the console and I recognized that the Hyper-V connection manager constantly flapping with connecting to the VM until an error message is shown which reports an problem with connecting to the VM. It looks like it is stuck between the last step of shutting down and the "ACPI power off".

The Hyper-V host is a Windows Server 2012 R2 Server Core. The Hyper-V guest is a generation 2 machine with 16 GiB hard disk, 1024 MiB RAM and three NICs.; 2 CPUs assigned. The previous released Ubuntu LTSB didn't show this erroneous behaviour. The machine was designed to run as router and mail relay.

####
Old text:
Ich habe das Problem, dass, wenn ich meinen Ubuntu Server 18.04.1 runterfahre oder neu starte, die VM "aufhängt". Die VM bleibt im Status "Beenden" hängen. Dabei hängt die VM so, dass ich alle anderen VMs runterfahren muss (diese reagieren noch) und den Dienst hart killen muss. Er lässt sich nicht mehr beenden. Wie soll ich am besten sagen? Der Dienst hängt zwar nicht, aber im Bezug auf die VM ist keine Kontrolle mehr möglich.

Das Verhalten hatte ich bereits bei 18.04 beobachtet und hatte mich entschieden, einfach noch ein wenig die Reife abzuwarten. Leider tauchte das Problem bei der neuen 18.04.1 wieder auf.
Das System scheint sauber runterzufahren, dann "wird das Bild blass" und es bleibt bei diesem Bild. Es sieht wie ein verblassen (fade im Englisch) zwischen der letzten Aktion und dem "ACPI Abschalten" (Strom aus). Der Status ist dann also nicht mehr auf "Herunterfahren".

Der Hyper-V Host ist ein Windows Server 2012 R2 Server Core. Die VM eine Generation 2 Maschine mit 16 GiB Festplatte und 1024 MiB RAM, sowie drei Netzwerkkarten; 2 CPUs zugeordnet. Bei dem früheren LTSB Release hatte ich keine Schwierigkeiten. Das System sollte als Router und Mail Relay fungieren.

Question information

Markus S. (schuhmam) said : #1

Unfortunately, no body replied yet.

I took a screenshot. Nothing - except that it stays at this point - looks wrong from outside. But I am a Windows administrator and not a Linux administrator, therefor I am not familiar dealing with those kind of problems.

https://1drv.ms/u/s!AoEuCh4Zdmlpg5MF81-oczJ8CfWeGg

henry devid (henrydevid) said : #2

Hey, I read it and that is very helpful for all. But for that issue Hyper-V Management Service just reset the whole software after that you will use it then you will see the problem will be solved. For more about it just browse it

https://uaewebsitedevelopment.com/apps-development/

Can you help with this problem?

Provide an answer of your own, or ask Markus S. for more information if necessary.

To post a message you must log in.