Missing kernel driver/module fnic

Asked by Dennis Grandt on 2018-04-04

Hello together,

i've installed Ubuntu 16.04 on a Cisco UCS Blade, that does not contain any local storage.
The storage is connected via fibre chanel over ethernet.

With the default kernel , shipped with Ubuntu 16.04, everything works as designed.
But we have to use Ceph blockstorage on these systems. The kernel in version 4.4 does not support the needed features so we have to upgrade at least to the kernel version 4.13, delivered by the package: linux-image-4.13.0-38-generic

The problem is, this kernel image does not contain the needed driver called fnic.
Why does the generic kernel image 4.4 contain fnic and the generic kernel image 4.13 does not?

Is there any supported way to get this driver loaded to the 4.13 kernel, besides building my own custom kernel?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-04-05
Last query:
2018-04-05
Last reply:
2018-04-05
Dennis Grandt (dgrandt) said : #2

Thanks for your reply, but that is not the answer to my question.
I can install "linux-image-4.14.0-1003-azure-edge" from the ubuntu repository but this kernel image also does not contain the needed kernel driver/module fnic.

Then I suggest you report a bug and/or roll your own kernel module.

Best Manfred Hampl (m-hampl) said : #4

The fnic.ko kernel driver is contained in the linux-image-extra-<version> packages, e.g. linux-image-extra-4.13.0-38-generic.
You have to install that package in addition to linux-image-4.13.0-38-generic.

Dennis Grandt (dgrandt) said : #5

Guys, you are awesome ;-)

I don't know that this package exist.... but if i had used the existing tools...
Maybe it could save some time for other people searching for a specific file:

apt-file search fnic.ko

that will output a list of packages which contain the file.

Dennis Grandt (dgrandt) said : #6

Thanks Manfred Hampl, that solved my question.