USB2&3 in Ubuntu 14.04 64bit gone missing after reboot when running from within a VM

Asked by Mhatz on 2015-11-16


I ve got a XenServer running on one of my servers and I ve install Ubuntu 14.04 64bit with kernel 3.13.0-24-generic

On the first boot of the XenServer, the VM is not started. I use the USB passthrough to pass a USB device to the guest VM and when I boot Ubuntu, the USB device can be seen (enumerated). When I reboot the VM (without rebooting XenServer) the USB cannot be seen. It's only visible when I reboot the whole XenServer.

I ve tried a few stuff but I am not sure if it's a XenServer issue or an Ubuntu one (under a VM).

FWIW, I ve got in the same machine a Windows 8.1 32bit VM which doesn't have the same issue. In fact, if I reboot the XenServer and boot in Windows, the USB device can be seen ok. Then no matter how many times I reboot the Windows VM, the USB is still there. If I shutdown Windows and boot to Linux, the USB can be seen. It's only when I reboot from Ubuntu that the USB is somehow gone.

So I am wondering whether Ubuntu is handling the shutdown of the USB subsystem in a weird way from within the VM.

Any help will be greatly appreciated.


Question information

English Edit question
Ubuntu linux Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Mhatz (hatzimiltos) said : #1

This turned out to be a Xen issue.