ETPS/2 touchpad not working on Fujitsu Lifebook E544

Asked by bwallum on 2015-04-15

The ETPS/2 Elantech touchpad does not work at all on a new Fujitsu Lifebook E544 laptop running Ubuntu 64bit 14.10

Using xinput list I can see that the system is aware of the touchpad:-

lcf@lcf-LIFEBOOK-E544:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PixArt USB Optical Mouse id=11 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Fujitsu FUJ02E3 id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Fujitsu FUJ02B1 id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ Sleep Button id=10 [slave keyboard (3)]
    ↳ FJ Camera id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

I can then see the properties:-

lcf@lcf-LIFEBOOK-E544:~$ xinput list-props 14
Device 'ETPS/2 Elantech Touchpad':
 Device Enabled (136): 1
 Coordinate Transformation Matrix (138): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
 Device Accel Profile (266): 1
 Device Accel Constant Deceleration (267): 2.500000
 Device Accel Adaptive Deceleration (268): 1.000000
 Device Accel Velocity Scaling (269): 12.500000
 Synaptics Edges (292): 90, 2181, 70, 1234
 Synaptics Finger (293): 1, 1, 0
 Synaptics Tap Time (294): 180
 Synaptics Tap Move (295): 115
 Synaptics Tap Durations (296): 180, 180, 100
 Synaptics ClickPad (297): 0
 Synaptics Middle Button Timeout (298): 75
 Synaptics Two-Finger Pressure (299): 282
 Synaptics Two-Finger Width (300): 7
 Synaptics Scrolling Distance (301): -52, -52
 Synaptics Edge Scrolling (302): 0, 0, 0
 Synaptics Two-Finger Scrolling (303): 1, 1
 Synaptics Move Speed (304): 1.000000, 1.750000, 0.076394, 0.000000
 Synaptics Off (305): 2
 Synaptics Locked Drags (306): 0
 Synaptics Locked Drags Timeout (307): 5000
 Synaptics Tap Action (308): 2, 3, 0, 0, 1, 3, 0
 Synaptics Click Action (309): 1, 1, 0
 Synaptics Circular Scrolling (310): 0
 Synaptics Circular Scrolling Distance (311): 0.100000
 Synaptics Circular Scrolling Trigger (312): 0
 Synaptics Circular Pad (313): 0
 Synaptics Palm Detection (314): 0
 Synaptics Palm Dimensions (315): 10, 200
 Synaptics Coasting Speed (316): 20.000000, 50.000000
 Synaptics Pressure Motion (317): 30, 160
 Synaptics Pressure Motion Factor (318): 1.000000, 1.000000
 Synaptics Resolution Detect (319): 1
 Synaptics Grab Event Device (320): 0
 Synaptics Gestures (321): 1
 Synaptics Capabilities (322): 1, 0, 1, 1, 1, 1, 1
 Synaptics Pad Resolution (323): 32, 32
 Synaptics Area (324): 0, 0, 0, 0
 Synaptics Noise Cancellation (325): 13, 13
 Device Product ID (256): 2, 14
 Device Node (257): "/dev/input/event5

How do I get my touch pad to work please?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
bwallum
Solved:
2015-05-03
Last query:
2015-05-03
Last reply:
2015-04-16

If you have a shortcut or key combo to enable / disable the touch pad then press it.

bwallum (rbw2) said : #2

The shortcut key is FN + F4 and it does not toggle the touchpad as expected. Running Windows the touchpad works as expected. I removed the hard drive containing Windows and inserted a SSD then did a fresh install of Ubuntu.

If you boot to Windows then reboot to Ubuntu is it OK.

Ubuntu 14.10 is EOL in July this year. You may want to upgrade to Vivid. It may help.

bwallum (rbw2) said : #4

To reboot to windows I need to take out the SSD (with Ubuntu on) and insert the HDD with Windows.

Re upgrade to Vivid, I tried that and it has screwed up rendering the computer unusable. It runs so slow that nothing can be launched except for Update Manager and that utility cannot find the repositories. Lost a few hours there, now trying to re-install 14.10. The touchpad did not work in Vivid

Try:

echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/mousefix.conf > /dev/null

Reboot to test

Source:
http://ubuntuforums.org/showthread.php?t=2071125

May also benefit from:

echo "blacklist acer-wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf > /dev/null

as well.

bwallum (rbw2) said : #7

Moving up to Vivid fixes most problems. Kernel version 4 fixes all touchpad problems on a Fujitsu E544.