My Wifi is not working properly

Asked by sajid on 2015-02-16

I'm really struggling to have working wifi on my laptop lenovo G5070 2421. I googled about my network card using ubuntu, but nothing solved my problem.
First of all, I installed Ubuntu 14.04.1 LTS 64-bit. I could use wifi, but after few minutes it would turn off and I could not connect to wifi again. So I started googling.

in troubleshooting i found like this

description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: c0:38:96:3c:b9:4d
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=3.13.0-46-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 ioport:3000(size=256) memory:c0400000-c0403fff

Is there a way to get this realtek controller working? how?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-03-11
Last query:
2015-03-11
Last reply:
2015-02-17

Please run the following command in a Terminal:

echo "options rtl8723be fwlps=0 swlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Then reboot your PC and retest wireless.

If that does not help, please follow this procedure:

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable) and apply all updates.

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1

In the Ubuntu Terminal console , make sure that unlimited scrolling is enabled:

click on Edit > Profiles > "Default" profile > Scrolling. Choose "Unlimited" as scrolling option. Click Close and Close again.

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface (default graphical user interface in Ubuntu), use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:

Press CTRL-ALT-T key combination.

Dash > Search for Terminal

Dash > More Apps > 'See More Results' > Terminal

Dash > More Apps > Accessories > Terminal

Step 2

Please copy-paste the following diagnostic command from the

https://help.ubuntu.com/community/WirelessTroubleshootingProcedure

website using a web browser (like Google Chromium or Mozilla Firefox) into the Linux Terminal. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE diagnostic command below from the web browser into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the diagnostic command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install usbutils pciutils hwinfo grep rfkill; sudo lshw -C network; rfkill list; sudo iwlist scan | egrep -i 'chan|ssid'; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nnk | grep -iA2 net; lsusb; nmcli nm status; sudo lshw -short; uname -a; sudo updatedb; dmesg | egrep '02:00|80211|acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rror|rtl|RTL|rt2|RT2|rt3|RT3|rt5|RT5|rt6|RT6|rt7|RT7|usb|witch|wl';sudo dmidecode|egrep 'anufact|roduct|erial|elease'; iwconfig; cat /etc/modprobe.d/* | egrep '80211|acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'wpa|icd|etwork'; netstat -rn ; cat /etc/resolv.conf; ls -lia /boot; grep tmpfs /etc/fstab; ubuntu-support-status; sudo update-pciids; sudo update-usbids; sudo lsmod

Step 3

Please do NOT attempt to send any attachment(s). Please copy/paste the full terminal output at this location:

https://answers.launchpad.net/ubuntu/+source/linux/+question/262203

The troubleshooters at Launchpad need to see the full Terminal output from running the above diagnostic command.

Step 4

Please also specify the SSID name of the wireless access point that you are trying to connect to (not the model/make of your router).

Step 5

Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a Live CD session.

Source: https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/259556
Source 2: https://help.ubuntu.com/community/WirelessTroubleshootingProcedure

Try the below command and reboot to test :

echo "options rtl8723be fwlps=0 swlps=0" | sudo tee /etc/modprobe.d/rtl8723befix.conf > /dev/null

Actionparsnip: I already stole that idea from you. See post #1 :-p

sajid (sajid-ece479) said : #4

Dear @actionparsnip i got the following when tried the command

no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
options rtl8723be fwlps=0 swlps=0

Okay run:

sudo rm /etc/modprobe.d/rtl8723befix.conf

Reboot and then run Mark's huge command

sajid (sajid-ece479) said : #6

Getting this when i entered your command @actionparship

no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
rm: cannot remove ‘/etc/modprobe.d/rtl8723befix.conf’: No such file or directory

sajid (sajid-ece479) said : #7

Thanks actionparsnip, that solved my question.