Touch-pad dosen't work after installing Ubuntu 14.04 [Dual boot with Windows 8]

Asked by erkanp on 2014-10-01

Hi
I just bought a new Acer Aspire V 15 Nitro computer with a pre-installed Windows 8. I installed Ubuntu so I can run dual-boot. Everything works fine now except my touch-pad that isn't working in Ubuntu but works fine when i boot into Windows. And when i'm in Ubuntu my USB mouse works fine aswell.

 cat /proc/bus/input/devices

 cat /proc/bus/input/devices
This command does not show any SynPS/2 or anything.

When i run

    xinput --list
Under the Virtual core pointer there is only one

    Virtual core XTEST pointer
    Logitec USB-PS/2 Optical Mouse
and then there is a empty slot where I think my touch-pad should be.

In my system settings I can see the touch-pad and turn it on/off but nothing happens. I also installed Touch-pad indicator but nothing happens aswell.

When I run

    cat /var/log/Xorg.0.log | grep -i synaptics

    [ 4.362] (**) : Applying InputClass "enable synaptics SHMConfig"
    [ 4.362] (II) LoadModule: "synaptics"
    [ 4.362] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
    [ 4.362] (II) Module synaptics: vendor="X.Org Foundation"
    [ 4.362] (II) Using input driver 'synaptics' for ' '
    [ 4.388] (--) synaptics: : x-axis range 0 - 1236 (res 12)
    [ 4.388] (--) synaptics: : y-axis range 0 - 898 (res 12)
    [ 4.388] (II) synaptics: : device does not report pressure, will use touch data.
    [ 4.388] (II) synaptics: : device does not report finger width.
    [ 4.388] (--) synaptics: : buttons: left double triple
    [ 4.388] (--) synaptics: : Vendor 0x6cb Product 0x2970
    [ 4.388] (--) synaptics: : invalid pressure range. defaulting to 0 - 255
    [ 4.388] (--) synaptics: : invalid finger width range. defaulting to 0 - 15
    [ 4.388] (--) synaptics: : touchpad found
    [ 4.404] (**) synaptics: : (accel) MinSpeed is now constant deceleration 2.5
    [ 4.404] (**) synaptics: : (accel) MaxSpeed is now 1.75
    [ 4.404] (**) synaptics: : (accel) AccelFactor is now 0.131
    [ 4.404] (--) synaptics: : touchpad found

After running

     grep -i touchpad /var/log/Xorg.0.log
the output is

      [ 4.362] (**) : Applying InputClass "evdev touchpad catchall"
      [ 4.362] (**) : Applying InputClass "touchpad catchall"
      [ 4.388] (--) synaptics: : touchpad found
      [ 4.404] (II) XINPUT: Adding extended input device " " (type: TOUCHPAD, id 12)
      [ 4.404] (--) synaptics: : touchpad found
      [ 4.404] (**) : Ignoring device from InputClass "touchpad ignore duplicates"

but when i run

      xinput -list

there is nothing with id 12

      ⎡ Virtual core pointer id=2 [master pointer (3)]
      ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
      ⎜ ↳ Logitech USB-PS/2 Optical Mouse id=11 [slave pointer (2)]
      ⎜ ↳ id=12 [slave pointer (2)]

I'm running Ubuntu 14.04.1 LTS, Release: 14.04

From cat /proc/version_signature > version.log: Ubuntu 3.13.0-36.63-generic 3.13.11.6
---
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: eric 2183 F.... pulseaudio
 /dev/snd/controlC0: eric 2183 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-09-30 (0 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: Acer Aspire VN7-591G
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-36-generic root=UUID=b973e8ad-55d3-4d12-a642-9cbec54417db ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-36-generic N/A
 linux-backports-modules-3.13.0-36-generic N/A
 linux-firmware 1.127.7
StagingDrivers: rts5139
Tags: trusty staging
Uname: Linux 3.13.0-36-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/30/2014
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.05
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire VN7-591G
dmi.board.vendor: Acer
dmi.board.version: V1.05
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: V1.05
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.05:bd07/30/2014:svnAcer:pnAspireVN7-591G:pvrV1.05:rvnAcer:rnAspireVN7-591G:rvrV1.05:cvnChassisManufacturer:ct10:cvrV1.05:
dmi.product.name: Aspire VN7-591G
dmi.product.version: V1.05
dmi.sys.vendor: Acer

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
erkanp
Solved:
2014-10-07
Last query:
2014-10-07
Last reply:
2014-10-02
erkanp (hallstrom-eric) said : #1

I really don't know if this is a bug or a question, i'm new to Ubuntu so I can have failed on something somewhere but I need guidance.

Try the boot option:

i8024.reset

If thats no good try:

 i8024.nopnp

May help

erkanp (hallstrom-eric) said : #3

Hello Actionpartnership thanks for you answer.
Since I'm new to ubuntu I don't really know how to do this. Do you think you could guide me?

erkanp (hallstrom-eric) said : #4

Hmm

erkanp (hallstrom-eric) said : #5

This problem is solved.

cyhex (timor-l) said : #6

erkanp care to share how did you solve the problem ?

I have the same issue.... And maybe other users would also like to knoe the solution
Thanks!

erkanp (hallstrom-eric) said : #7

Hello Cyhex I have not personally solved the problem yet but our friend Kai who had the same problem did solve it. Kai replied to me: I solved the issue on my machine by updating the kernel to 3.16.0-031600-generic. Works like a charm now.

Hope that helps

cyhex (timor-l) said : #8

great news - thanks for info!

jatinpanchal (jatinpanchal) said : #9

Sir!
I have problem in my laptop
Acer V 15 not installed ubuntu in OS windows 10
Do not boot black screen and error
Please say
how to work in dual boot ?