Acer Aspire 5570Z won't start after upgrading to Lubuntu 14.xx

Asked by Roger Mendes on 2014-07-08

I recently upgraded my Lubuntu from 13.xx to 14.xx. The upgrade finished showing of some errors, which I don't recall, but the computer kept running. Then I tried to restart it, but it froze in a black screen with a bunch of stuff written (like a loading screen), then I switched it off and tried to restart again, but now it seem like the power button doesn't do anything.... no lights, no sounds, nothing at all.

This acer already had some starting problems previously to this. Sometimes it wouldn't start, but after a couple tries at the power button, and maybe removing the battery, it would turn on properly. But after the upgrade it seems like the power button doesn't exist anymore, it just does nothing.

I already tried removing the batteries, unplugging the cable, plugging the cable back on and holding the power button for a bunch of seconds, but nothing helped.

I also removed the ram sticks, sort of cleaned them and put them back on, still nothing.

Also my battery was just plain dead, it doesn't recharge anymore. When the computer was running and I removed the power cable then it would shut down immediately. I know it probably shouldn't, but maybe this has something to do with it.

I'm out of ideas, anyone could please light my way and help me get this fixed? I know this seems like a hardware failure, but why after an OS upgrade? What does it have to do with it? This is puzzling me.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2014-07-08
Last reply:
2014-07-08
Warren Hill (warren-hill) said : #1

Can you boot from a live CD or USB?

If you can then you should at least be able to backup your personal data.

I would then try a fresh install and restore your data from the backup.

If not and the power button really does nothing then it's hard to see how this can be anything other than an hardware failure. I had a similar problem with an ASUS laptop which turned out to be the battery.

Have you tested your RAM using Memtest86 from Grub?

I don't have anything too important in it, my idea was to fresh install it, but as I said, nothing happens at all when I press the power button. Just can't do nothing, and it was right after I upgraded the OS, no clue why.

actionparsnip, I have no way of testing my ram, as the computer won't power up.

Unplug the laptop and remove the battery. Hold the power button down for a good 10 - 15 seconds then reassemble. May help.

Didn't help either =(

Warren Hill (warren-hill) said : #7

No guarantees but a quick search shows not powering up is a common problem on Acer laptops

Some suggestions here:
http://tektype.wordpress.com/2011/09/21/my-acer-laptop-wont-turn-on-what-should-i-do/

Can you help with this problem?

Provide an answer of your own, or ask Roger Mendes for more information if necessary.

To post a message you must log in.