ASUS PCE-N15 low throughput in Ubuntu 12.04

Asked by Frank Pope on 2014-07-06

Right after reboot the download speed test reports 20 Mbps. Second time I try it drops to 2 Mbps. No such problem occurs when the same system is running W7. PCE-N15 has RealTek RTL8188CE and the driver module is rtl8192ce which appears to support this chip.

I've read enough to see this appears to be an ongoing issue and I've tried most all the "fixes" I've found to no avail.
I am wondering if the ieee80211 phy0: Selected rate control algorithm 'rtl_rc' (from dmesg) has anything to do with this as it seems like something is throttling back the throughput. Even web page video stutters and breaks up.

Is there a solution for this?

Any help is greatly appreciated!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2014-07-06
Last reply:
2014-07-06

This question was reopened

What is the output of:

sudo lshw -C network; lsb_release -a; uname -a

What Windkws does or doesn't do has zero bearing on the perfomance in Ubuntu. It is a completely different OS with completely different support.

Frank Pope (popef) said : #2

Here is the output:

  *-network
       description: Wireless interface
       product: RTL8188CE 802.11b/g/n WiFi Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan1
       version: 01
       serial: e0:3f:49:8c:0d:61
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.2.0-65-generic firmware=N/A ip=192.168.20.14 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 ioport:d000(size=256) memory:f7400000-f7403fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: 06
       serial: bc:ae:c5:76:aa:32
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:59 ioport:c000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise
Linux europa 3.2.0-65-generic #99-Ubuntu SMP Fri Jul 4 21:03:29 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I believe I've hit on the solution. The default country code from "iw reg get" was 00. After adding "iw reg set US" to rc.local and rebooting the issue seems to have gone away. I'm able to run the speed test multiple times with reasonable results. Sorry I hadn't seen this fix until after posting the question

The comment about W7 was just to show that the hardware interface was capable of maintaining high throughput, i.e. not a broken card.

Thanks for the quick reply!

Frank Pope (popef) said : #3

Well it seems I spoke to quickly. Changing the country code from 00 to US didn't fix the problem and the issue still persists. Speed test down loads have dropped from 20 Mbps to 2 Mbps.

It may be capable of high speed under Windows, but this doesn't have any bearing on Linux in any way. If it was ok under Fedora but not in Ubuntu then this is of value but Windows architecture is completely different to Linux's so tells us absolutely nothing at all.

Try:

echo "options rtl8192ce swenc=1" | sudo tee /etc/modprobe.d/rtl8192ce.conf

Reboot to test.

Frank Pope (popef) said : #5

I've tried the suggestion and tested it several times (about 20 minute time frame) and so far so good. I will let it cook for a few hours and let you know. Thanks

Frank Pope (popef) said : #6

The problem is still there. The throughput has dropped back down to the 2Mbps range

Frank Pope (popef) said : #7

I poked around a bit after my last comment and I noticed the file /etc/modprobe.d/rtl8192ce.conf never got created by the command you gave me to try. Is the "sudo" in the right place? Anyway I directly created the file with sudo gedit, added the option, rebooted and am now retesting.

Frank Pope (popef) said : #8

Still no difference. Throughput is down to 2 Mbps a few minutes after reboot.

I suggest you report a bug. Remove the file created.

Can you help with this problem?

Provide an answer of your own, or ask Frank Pope for more information if necessary.

To post a message you must log in.