No sound kernel 3.13 ALC887-VD but kernel 3.14 fixes it

Asked by ted chang on 2014-04-01

My sound hardware doesnt seem to be supported on the vanilla ubuntu 13.10 or 14.04. However, the fix seems to be updating the kernel to 3.14. This sound card is integrated in the motherboard and I am using the analog jack. I am not sure whether or not to report it as a bug or something.

http://www.gigabyte.us/products/product-page.aspx?pid=4716#sp

3.14.0-031400-generic

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci -v

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
 Subsystem: Gigabyte Technology Co., Ltd Device a002
 Flags: bus master, slow devsel, latency 32, IRQ 16
 Memory at feb60000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: snd_hda_intel

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-04-01
Last query:
2014-04-01
Last reply:
2014-04-01

What is the output of:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh --upload

Thanks

ted chang (monkeyboyted) said : #3

I reran the script under the current vanilla ubuntu kernel 3.13 so you can compare logs

http://www.alsa-project.org/db/?f=3219c41b19ff4b97586f2589895b461251e0baec

ted chang (monkeyboyted) said : #4

i should had clicked i'm providing more information button

I suggest you report a bug, state that the newer kernel resolves the issue

ted chang (monkeyboyted) said : #6

Thanks actionparsnip, that solved my question.

Raymond (superquad-vortex2) said : #8

--
00:14.2 0403: 1022:780d (rev 01)
 Subsystem: 1458:a002

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda/patch_realtek.c?id=b2c53e206967d01fd4fb6dd525f89ae738beb2e6

it seem that your giga byte with alc887vd have same PCI SSID as gigabytes with alc889

the patch disable jack detection of the headphone of the front audio panel