linux-image-3.5.0-30-generic is missing, how can I install it?

Asked by Daniel Brown on 2013-05-19

Total newby here. I am getting a system error that says linux-image... is missing. When I attempt to download Linux Kernel Image 3.5.0 on 64-bit x86 SMP, I get an error message that says 'The package system is broken
Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f. I don't know how to disable third-party repository (nor even where to find such). When I attempt to run the apt-get install from Terminal, I get an error message that says 'E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Obviously I am in way over my head. I believe all of this started when I attempted to download SAMBA4 application. ANy help you can offer would be much appreciated, and the more detailed and specific the better.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2013-05-19
Last reply:
2013-05-20

If you run command line package commands like apt-get when software centre is open you will get this. Is this the case. If not then run:

sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a

What is output?

Thanks

Daniel Brown (bamh1d) said : #2

Software Center was not open, but Update Manager was open. Here's the output:

Setting up samba4 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
/var/lib/dpkg/info/samba4.postinst: 14: /var/lib/dpkg/info/samba4.postinst: /usr/share/samba/setoption.pl: Permission denied
dpkg: error processing samba4 (--configure):
 subprocess installed post-installation script returned error exit status 126
dpkg: dependency problems prevent configuration of linux-signed-image-3.5.0-30-generic:
 linux-signed-image-3.5.0-30-generic depends on linux-image-3.5.0-30-generic (>= 3.5.0-30.51~precise1); however:
  Package linux-image-3.5.0-30-generic is not installed.
dpkg: error processing linux-signed-image-3.5.0-30-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-image-generic-lts-quantal:
 linux-signed-image-generic-lts-quantal depends on linux-signed-image-3.5.0-30-generic; however:
  Package linux-signed-image-3.5.0-30-generic is not configured yet.
dpkg: error processing linux-signed-image-generic-lts-quantal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic-lts-quantal:
 linux-image-generic-lts-quantal depends on linux-image-3.5.0-30-generic; however:
  Package linux-image-3.5.0-30-generic is not installed.
dpkg: error processing linux-image-generic-lts-quantal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-lts-quantal:
 linux-generic-lts-quantal depends on linux-image-generic-lts-quantal; however:
  Package linux-image-generic-lts-quantal is not configured yet.
dpkg: error processing linux-generic-lts-quantal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-generic-lts-quantal:
 linux-signed-generic-lts-quantal depends on linux-signed-image-generic-lts-quantal; however:
  Package linux-signed-image-generic-lts-quantal is not configured yet.
dpkg: error processing linux-signed-generic-lts-quantal (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 samba4
 linux-signed-image-3.5.0-30-generic
 linux-signed-image-generic-lts-quantal
 linux-image-generic-lts-quantal
 linux-generic-lts-quantal
 linux-signed-generic-lts-quantal

I don't understand the references to quantal. I am running Precise Pangolin with Unity GUI.

N1ck 7h0m4d4k15 (nicktux) said : #3

The references to quantal is the backported packages from quantal to raring. I'm pretty sure you are running Ubuntu 12.04.2 (not 12.04.1)

This is normal.

Try these commands and give back full results

    wget "http://ubuntuone.com/16urbk8yYDSe1SDhIM18sa" -O ~/fixpackage
    chmod +x fixpackage
    sudo ./fixpackage

Regards
 NikTh

Can you help with this problem?

Provide an answer of your own, or ask Daniel Brown for more information if necessary.

To post a message you must log in.