12.04.1 64-bit Freezing

Asked by Brian Spisak on 2012-12-22

There are so many bugs and cross-refs and such for "freeze" issues I can't make heads or tails of what is what. I'm hoping someone can help point me in the right direction with this. Should I file a bug? Is this already a bug? What else can I try?

I've had my system freeze up 3 times in the last 2 days since I installed 12.04.1-desktop-amd64 on my core i5 p8z77-v pro. Kernel is 3.2.0-35-generic and everything was brought up to date via update manager.

The system is totally frozen: I can't even ping it from my laptop and I've verified the correct IP from the my router and the mac address of the frozen system. I was able to ping it before. Perhaps even more interesting, when I hit the hard reset button, nothing immediately happens! I don't know how this is implemented, but in the past I've always got an immediate reset. I hit it 2 or 3 times, and it was perhaps 10 seconds later I got a reset. The last time it froze, I saw the same thing, but I didn't as long prior to trying the power button. A single press of the power button did nothing, and I had to hold it down to get the system to reset (as expected.)

I was previously running 12.04.1-desktop-i386 on the same machine with identical setup and did NOT see any problems in the same amount of time. Not a definitive finding, I know, as the time frame is quite short, but I perhaps spent more time on the 32-bit version than I have so far on the 64-bit.

The syslog doesn't show anything prior to the reboot, although it looked like cron would have just been running: the previous log was at 19:17:01 so the next hourly would have been 20:17:01 and and my reboot was started at 20:19:18. I was browsing the web with firefox 17.0.1 when it froze up. Nothing else going on that I can recall. The previous freeze, I can' t recall if I was browsing, but I was running filezilla to transfer a large directory from a local computer allowing 10 open sftp connetions. After rebooting, I did the same operation 3 or 4 times again without a problem. That was approximately 24 hours ago.

I've ran memtest86+ without any errors. I tried installing 3.4 mainline kernel, but without any drivers, I can't boot because I have a raid array from which I mount my /home. If someone can give me some instructions on how to try a new kernel, I can do so.

Not sure what else to look for. I don't really know my way around linux that well, so if someone wants me to look at something the next time this hangs (and I'm sure it will within another 24 hours or so) just let me know.


Question information

English Edit question
Ubuntu linux Edit question
No assignee Edit question
Last query:
Last reply:
jacob lastman (ndhlovo) said : #1

similar experiences with my 32 bit install of 12.04. See my 2 or three threads logged this last month.


Sam_ (and-sam) said : #2

Doesn't sound very healthy, a hard reset makes things worse, rather try magicSysRq.

If possible boot from a functional kernel, usually a former one, e.g. 3.2.0-35.55 or from live medium (CD or USB), in case backup important data and reinstall from scratch.

Since such an annoying issue isn't expected with a LTS rather file a bug if possible, system log files are in /var/log.

Seems to be a kernel issue.

rrich1974 (richardsdma) said : #3

for me, adding "pci=nomsi" in grub line solved the freezing.
you can also try this.

hankroth (hank-roth) said : #4

I've been following this problem for a long time and have been confronted with it on several different machines. I'm really getting frustrated. I'm undecided if I should switch to something else altogether or keep on waiting for the kernel fix? Anyone have anything new to add? There is nothing new in this thread that can help; that is different from what has already been posted here.


Can you help with this problem?

Provide an answer of your own, or ask Brian Spisak for more information if necessary.

To post a message you must log in.