12.04 LTS hangs if unattended

Asked by jacob lastman on 2012-12-10

Hello

i run the above on a DEll inspiron with 2G of memory. If i walkaway from the machine sometimes i come back and the system requires a hard boot to restart. I do use the suspend mode from time to time and also that does not restart from sleep on occasion.
Any ideas?

thanks

ps: it has nothing to do with SKype -that just appeared and uneditbale below

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-01-20
Last query:
2013-01-20
Last reply:
2012-12-12
jacob lastman (ndhlovo) said : #1

typically a terminal window, skype and a copy of chrome running when i suspend

What is the output of:

sudo dmidecode -t 1; lsb_release -a; uname -a

Thanks

jacob lastman (ndhlovo) said : #3

sudo dmidecode -t 1; lsb_release -a; uname -a
[sudo] password for phil:
# dmidecode 2.11
SMBIOS 2.3 present.

Handle 0x0100, DMI type 1, 25 bytes
System Information
 Manufacturer: Dell Inc.
 Product Name: Inspiron 6000
 Version: Not Specified
 Serial Number: H8X5B71
 UUID: 44454C4C-3800-1058-8035-C8C04F423731
 Wake-up Type: Power Switch

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux phil-Inspiron-6000 3.2.0-34-generic-pae #53-Ubuntu SMP Thu Nov 15 11:11:12 UTC 2012 i686 i686 i386 GNU/Linux

Ok and what is the output of:

sudo lshw -C display

Thanks

jacob lastman (ndhlovo) said : #5

[sudo] password for phil:
  *-display
       description: VGA compatible controller
       product: RV370 [Mobility Radeon X300]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:41 memory:d0000000-d7ffffff ioport:de00(size=256) memory:dfdf0000-dfdfffff memory:dfd00000-dfd1ffff

thanks

jacob lastman (ndhlovo) said : #7

many thanks. however i am just not power enough to understand

"...After going through all of the system logs, I noticed ‘Resume Failed’ after trying to load the ieee architecture with works with the ipw2200 wireless drivers. So I played around with the /etc/defaults/acpi-support file. I added ‘STOP_SERVICES=”network-manager 915resolution”. And nothing. So then I added ‘nm-applet’ to the STOP_SERVICES. Works like a charm. No more problems, suspends & hibernates...."

a little more help would be gratefully accepted

thanks again

Run:

gksudo gedit /etc/defaults/acpi-support

add the line:

STOP_SERVICES="network-manager 915resolution nm-applet"

Save the file, close gedit and reboot to test

jacob lastman (ndhlovo) said : #9

many thanks indeed. for taking the trouble

nb: the defaults folder in 12.04 has no 'S'

jacob lastman (ndhlovo) said : #10

Thank you particularly to Action Parsnip, who is so very helpful on these boards. Appreciated.

In summary i have had a raft of screen and lock issues since i started using 12.04 LTS on my Dell Inspiron.
I logged a few related but separate queries....however...for the benefit of others i have found not setting 'anything' ie: no sleep timers AT ALL in the POWER control interface appears to have reduced the problem. I am not knowledgeable enough, or time, to track and Log proper bugs. With this set up the direct 'suspend' from the Shut icon top left does still seem to work. Touch wood.

anyway. thanks all

jacob lastman (ndhlovo) said : #11

Thanks actionparsnip, that solved my question.