Busybox boot error

Asked by David S on 2012-05-04

I have a laptop with just Ubuntu on it. I have recieve the error message BusyBox v1.18.4 (Ubuntu 1:1.18.4-2ubuntu2) built-in shell (ash) then (initramfs). Looking online it seems I have some type of file system mixup and possilby can be fixed with using a live cd. I have the live CD and can get that to work. Could someone please explain to me what I need to do to hopefully fix this issue without loosing what is on my hard drive?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
David S
Solved:
2012-05-04
Last query:
2012-05-04
Last reply:
2012-05-04
Wyatt Smith (wyatt-smith) said : #1

One thing that can drop you into a busybox is a kernel panic error. I suggest the first step you be trying to boot using the most recent stable kernel, and then rebuild your initial ram filesystem image (initramfs). Please review the following guide and information be proceeding

http://manpages.ubuntu.com/manpages/lucid/man8/update-initramfs.8.html
http://ubuntugenius.wordpress.com/2010/05/24/fix-a-failed-initramfs-update-do-it-before-you-reboot/

Hope this helps

David S (theycallmefiddle) said : #2

-Wyatt thank you for this information. I tried previous kernals but all of them gave the same error message. Eventually I did find a website that suggested going into Gparted from the live cd and then right clicking on the partition and hitting Check. That is what did the trick and everything is working great again.