Ubuntu

Ubuntu slow after RAM increase

Asked by William Pabon on 2012-02-21

I increased the RAM on my pc from 1 Gig to 3 Gig and now everything is running very slow. The boot up process takes like 3 to 4 times longer, the applications load also slow compared to when I only had 1 Gig of RAM. Additionally, don't know why I get the message to download the Dropbox propietary daemon every time I boot up. there's a note saying that python-gpgme is not installed. Really (I swear), the only thing I did was to increase the RAM and everything I just described started to happen. Please, help.
wp

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
William Pabon
Solved:
2012-03-23
Last query:
2012-03-23
Last reply:
2012-03-09
William Pabon (williepabon) said : #1

Additional information:
This is happening with version 10.04 LTS. I just booted with the Ubuntu 10.10 (maverick) that I have on a flash drive(usb), and everything is nice and fast. Thanks.
wp

Chris (fabricator4) said : #2

You might need to install the pae kernel, or install the 64 bit release. To see which kernel you are currently running type:

uname -a

Also try a previous known working kernel. Maybe it's updated to the pae kernel and that's why it's booting slower?

The problem with dropbox is probably inconsequential and unrelated. Dropbox is not in the repository so it must be something you installed separately? If you don't use it then uninstall it - it sounds like it's stopped working in any case.

Chris

William Pabon (williepabon) said : #3

Chris:
My pc is old (assume 32 bit) and it was working perfect till this morning when I added the RAM. I ran the command suggested and this is the result:

williepabon@WP-WrkStation:~$ uname -a
Linux WP-WrkStation 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:13:04 UTC 2012 i686 GNU/Linux

I am not knowledgeable enough to deal with kernel files. Please, advise what steps I should do to correct the problem. Also, I completely removed Dropbox until this issue is corrected. Thanks for the help.
wp

Have you ran a ram tester? The new ram may be faulty...

William Pabon (williepabon) said : #5

Andrew:
I don't think that I have a RAM problem. I boot up with windows xp and my windows applications run faster now. I checked the memory with WinUtils (windows) and it indicates that's is OK. On the other hand (as I said on my second post), the problem occurs with Ubuntu 10.04, not with the other Ubuntu versions I have. For example, I'm writing this post on the same pc but running Ubuntu 10.10 from a flash drive, and it works fine. I also tested it with Ubuntu 11.10 (flash drive also) and it works OK. Hope this information helps to solve the problem. Ubuntu 10.04 is the OS that is installed on the hard drive and is the default OS of my machine.
wp

Running another OS is not a memory test. Windows may manage bad RAM and avoid it. RAM is also randomly accessed, so may avoid the badness again. The RAM test will test it all...

William Pabon (williepabon) said : #7

Andrew:
You are saying that Ubuntu 10.10 and 11.10 avoids bad RAM like windows but 10.04 doesn't? Would you suggest a RAM tester from the repositories? I know that memtest86+ is installed, but I don't know how's used.

William Pabon (williepabon) said : #8

I ran bootchart and have a report, but don't know how to interpret it. Please advise how to upload the png file, for you to analyze. Thanks.

You can use imageshack or similar.

William Pabon (williepabon) said : #10

Andrew:
I ran the DELL diagnostics and thoroughly checked the RAM chips, and they passed all ( six tests performed) the tests. Now, I assume that I need to check the hard drive / file system. Somebody suggested to use the e2fsck command, but after reading the man page, it looks like it is rather complex for my experience. Can you give ideas of Linux commands to check the hard drive and examples of usage? Thanks.
wp

Launchpad Janitor (janitor) said : #11

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

William Pabon (williepabon) said : #12

This issue has not been solved yet. The problem still exists.
wp

William Pabon (williepabon) said : #13

This issue is solved. See question #190306.