Huawei K4505 not being detected...

Asked by John Wornham on 2011-11-05

Hi there and thanks for taking a look at this issue...

I have recently upgraded my Ubuntu and now when I try to connect to the internet using my USB dongle I have to unplug it and then plug it back in for it to be detected.

With Ubuntu previously, when I booted up I could see the 'searching' icon spin and then it would say 'connected'.

I have ticked the 'Connect Automatically' box in Network Connections/Mobile Broadband/Vodafone Postpaid.

Terminal output from a lsusb command is:

john@john-Satellite-Pro-L650:/$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 10f1:1a2a Importek
Bus 002 Device 003: ID 0930:0214 Toshiba Corp.
Bus 002 Device 006: ID 12d1:1464 Huawei Technologies Co., Ltd.
Bus 002 Device 007: ID 05ac:1301 Apple, Inc. iPod Shuffle 2.Gen
john@john-Satellite-Pro-L650:/$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 10f1:1a2a Importek
Bus 002 Device 003: ID 0930:0214 Toshiba Corp.
Bus 002 Device 006: ID 12d1:1464 Huawei Technologies Co., Ltd.

Bus002 (Huwei Tech) is my Internet dongle.

I hope you can help as I think this is an issue with the new Ubuntu and therefore will be affecting others.

Many many thanks in advance!

John

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Can you give the output of:

lsusb; lsb_release -a

Thanks

Revision history for this message
John Wornham (jwkungfu1) said :
#2

john@john-Satellite-Pro-L650:~$ lsusb;lsb_release -a
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 10f1:1a2a Importek
Bus 002 Device 003: ID 05ac:1301 Apple, Inc. iPod Shuffle 2.Gen
Bus 002 Device 004: ID 0930:0214 Toshiba Corp.
Bus 002 Device 007: ID 12d1:1464 Huawei Technologies Co., Ltd.
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

Revision history for this message
delance (olivier-delance) said :
#3

https://bugs.launchpad.net/modemmanager/+bug/772577
Could you check you have same issue. If the case, please subscribe the bug.

Revision history for this message
John Wornham (jwkungfu1) said :
#4

Thanks for the reply.
I had a good look at that bug and my issue may be similar, however, I could not see anything that would help solve my problem?

Revision history for this message
delance (olivier-delance) said :
#5

At boot, do you have the choice between many kernels ? You can display boot menu if you press <shift> key at start of boot.
If yes, try previous kernel (third entry).

Revision history for this message
John Wornham (jwkungfu1) said :
#6

I couldn't see any...
Just the main one and a recovery...

Revision history for this message
John Wornham (jwkungfu1) said :
#7

Hi there,

I am still experiencing this issue.

Can anybody help please?

Many thanks in advance,

John

Revision history for this message
John Wornham (jwkungfu1) said :
#8

ps. I tried using a previous linux kernal by pressing shift on boot and then plugged in my USB dongle and I noticed that the graphic moved to indicate that my computer was making the connection; which I don't think happened when using the newest kernal..?

I hope this helps!

jw.

Revision history for this message
delance (olivier-delance) said :
#9

I can't help. Please follow progress in the bug thread.

Revision history for this message
John Wornham (jwkungfu1) said :
#10

ok.
Thanks for taking a look.

Revision history for this message
z3r0c007 (kimchloekc) said :
#11

try this command:

sudo modprobe -r bluetooth; sleep 2; sudo modprobe bluetooth

output:

and then reset the usb

Revision history for this message
John Wornham (jwkungfu1) said :
#12

Thanks for the reply!
Much appreciated but before I proceed could you please explain what that command will actually do and why do you think it might help this situation?

By the way... One thing I did notice the other day was that my Bluetooth was activated on boot-up which is something I did not set up?! (and I think that is a bad security issue for Ubuntu). I found a command that seems to have fixed it so that Bluetooth is 'Off' unless "I" tell it to turn on!

Revision history for this message
delance (olivier-delance) said :
#13

On some computers (EEEPC), it is possible to unset Bluetooth via keyboard function key. Check for your PC.

Revision history for this message
John Wornham (jwkungfu1) said :
#14

Hi again,

Thanks for your response and sorry for my delay in replying.
I have a Toshiba and there is no keyboard function to turn the Bluetooth off but I think in general ALL functions should be OFF unless the USER decides to turn them off. That should be the default 100% of the time.

The Bluetooth issue is getting away from my initial problem which is that my computer is not detecting my Internet USB dongle unless I unplug it and plug it back in. Prior to upgrading my Ubuntu when I turn my computer on I could see the graphic in the tool bar that the Internet was being detected and then I would connected...

I ran the command from the previous thread and this is what I got...

john@john-Satellite-Pro-L650:~$ sudo modprobe -r bluetooth; sleep 2; sudo modprobe bluetooth
[sudo] password for john:
FATAL: Module bluetooth is in use.

Thanks for reading all this!

:O)

John

Revision history for this message
John Wornham (jwkungfu1) said :
#15

Hello again!

I think I may have found a solution to this problem...?

sudo aptitude install usb-modeswitch
sudo usb_modeswitch -v 0x12d1 -p 0x1521 -M \ 55534243123456780000000000000011060000000000000000000000000000

You will have to run lsusb in a terminal and check the values (I had to change 0x1521 to 0x1464).

Here is the link I used...

http://www.andrewferrier.com/blog/2010/07/30/huawei-k4505-with-ubuntu-10-04/

Bye for now!

John

Can you help with this problem?

Provide an answer of your own, or ask John Wornham for more information if necessary.

To post a message you must log in.