Natty hangs on AMD E-350 laptop during rsync

Asked by Anton¡o Sch¡fano

I am experiencing a strange problem with my laptop (AMD fusion based, HP Pavilion dm1-3101 - 4GB RAM, CPU AMD E350 dual core), a fresh Natty installation with updates and kernel 2.6.38-9-generic amd64.
When trying to rsync a few GB directories - containing a few big files - from my main PC to the laptop, after a while (random) the laptop hangs. Nothing is displayed on screen and I cannot find any trace in the logs; however, I noticed that the kswapd0 process jumps to >60% cpu before the system hangs.
Kernel 2.6.3-9-server works perfectly though. Any ideas?

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

is your RAM healthy?

Revision history for this message
Anton¡o Sch¡fano (skiantoz) said :
#2

Yes; I ran memtest86 for a few hours and it never complained.

Revision history for this message
Michael Rao (arthy-launchpad) said :
#3

Seems to have the same problem here. I have a HP pavilion DM1 series 3000 (AMD E-350, 4gb) with Natty amd64. The laptop freeze 1 or 2 times/day. Memtest OK (several hours). I tried without non-free drivers (wireless, ATI radeon). I tried to change some settings in bios... I also noticed some strange behavior with kswapd0 just before freeze (I tried with and without swap partition). Nothing is logged just before the freeze.
I will try kernel 2.6.3-9-server tomorrow.

Revision history for this message
Anton¡o Sch¡fano (skiantoz) said :
#4

@Michael: did you eventually try the -server kernel?

Revision history for this message
Michael Rao (arthy-launchpad) said :
#5

Yes. Only one "freeze" still (also with a strange behavior of kswapd0 ans kworker0 just before), but the server kernel seems much stable on my DM1-3135.
I also tried the last bios (F.12), this change nothing with the -generic kernel (and we loose advanced menu in the BIOS).

Revision history for this message
jvgeli (jvgeli) said :
#6

Same issue here. I get constant freezes on an AMD e350 on a lenovo laptop. The strange thing is that I dont get the freezes if im on AC power. Issue could be our APU's. This is a relatively new APU and support might be buggy as of this time. Switch back to Natty it is more stable. Tried it already.

Revision history for this message
Mark Longair (mark-ubuntu) said :
#7

I've had the same problem with a Sony Vaio VPCYB2M1E, which is also E-350 based, and the 64-bit version of natty . We noticed this first with rsync, but can reproduce the problem if you start the following in a terminal:

   dd bs=1000000 count=4000 if=/dev/zero of=delete-me

... and then pressing a key or switching window with the mouse causes the system to freeze to a greater or lesser extent - sometimes you can still move the mouse pointer, and sometimes the clock in the top bar still updates, but sometimes everything freezes. The disk activity light is off once the laptop is in this state, so I assume nothing is actually being written to disk. From top(1) there seems to be some activity from kswapd0 and kworker0 just beforehand the freeze, but there's plenty of real memory free and there seems to be no swapping going on.

This problem notably doesn't appear if you use the 32-bit version of natty on this hardware.

Revision history for this message
Nick Russell (thatnick) said :
#8

This affects me in 11.10. I can reproduce the issue by running

dd bs=1000000 count=4000 if=/dev/zero of=delete-me

as Mark suggests.

What further info can I provide to help get to the bottom of this?

Revision history for this message
Nick Russell (thatnick) said :
#9

Hi, what info can i provide to progress this? Thanks.

Can you help with this problem?

Provide an answer of your own, or ask Anton¡o Sch¡fano for more information if necessary.

To post a message you must log in.