Ubuntu

Can not find kernel image vesamenu C.32

Asked by Jeremy Kuhn on 2011-04-16

Every time that I boot the system off my pen drive i get a message saying that it 'can not find kernel image vesamenu C.32' I have no clue what to do and I have tried suggestions to change the code from 'vesamenu C.32' to 'live' and it goes one step further but then can't find another kernel somewhere else in the code and i get stuck. I have no clue what do any help? I have a sandisk 8g drive and i have it on FAT32, so I don't have any idea what else to do.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-16
Last reply:
2011-06-21

Did you make a persistant install on the USB or did you use a tool to put the installation ISO on the USB?

Jeremy Kuhn (jeremymkuhn) said : #2

I used the link from ubuntu.com that went to http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/ and used that download to get it on the USB. I'm having the same problem with any version of the operating system that I try.

Jeremy Kuhn (jeremymkuhn) said : #3

Ok here is some more information about the problem:

The syslinux folder contains two parts, the syslinux which has this:

# D-I config version 2.0
include menu.cfg
default vesamenu.c32
prompt 0
timeout 50

# If you would like to use the new menu and be presented with the option to install or run from USB at startup, remove # from the following line. This line was commented out (by request of many) to allow the old menu to be presented and to enable booting straight into the Live Environment!
# ui gfxboot bootlogo

and the txt which has this:

default live
label live
  menu label ^Run Ubuntu from this USB
  kernel /casper/vmlinuz
  append noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/casper/initrd.lz splash --
label live-install
  menu label ^Install Ubuntu on a Hard Disk
  kernel /casper/vmlinuz
  append cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz splash --
label memtest
  menu label Test ^memory
  kernel /install/mt86plus
label hd
  menu label ^Boot from first hard disk
  localboot 0x80

If i just try starting the computer and run from my pen drive I get the "Can not find kernel image: vesamenu.c32"
Now if i remove the Information between the timeout 50 and # ui gfxboot bootlogo then it says "Can not find kernel image: gfxboot"
If i remove everything after timeout 50 it goes back to the original "Can not find kernel image: vesamenu.c32"

I have read on other blogs and forums to change the vesamenu.c32 to live but it changes nothing except it says "Can not find kernel image: live" when i change it.

I have the same vesamenu.c32 problem with any version of system that i try to load, but I dont know if i would have the same effects when i change the code other than it changes the kernel error to what i change it to.

I hope this helps and in addition i am running it on a Toshiba a505 with 4g RAM and and i3 processor that runs Windows 7.

Did you MD5 test the ISO you downloaded?

Jeremy Kuhn (jeremymkuhn) said : #5

No, unless it does it automatically, i don't even know what that is.

Instead of stating you don't know, try researching a little based on the direction. You would have quickly come across this guide:

https://help.ubuntu.com/community/HowToMD5SUM

You have failed to check your ISO so you have no way of knowing if it is complete or consistent.

Richard Wonka (richard-wonka) said : #7

I have checked the md5sum and it's consistent with what I found online:

7de611b50c283c1755b4007a4feb0379 ubuntu-11.04-desktop-amd64.iso

yet I still get the same error.

What next?

Devon Richards (devonsrich) said : #8

I'm having this problem too. I've tried using UnetBootin and Usb Creator and both end up with the same error. I am trying to load Linux Mint 11 dvd 32 bit. I have set persistence at max each time and my usb is a 16gb data traveller 101 from Kingston. The md5 on the iso has checked out so I'm not sure what's wrong.

Amedee Van Gasse (amedee) said : #9

I can confirm the problem for 11.04 and 10.10. Pen drives created from 10.04 images or earlier don't have this problem.

The problem is not with what Jeremy did. This is a genuine bug, only it has either not been reported yet or it is very hard to find in Launchpad. It only occurs in a situation that very few users use: creating a pendrive for the alternate installer. I'm not sure about the desktop or server installer.

I will try to copy all files from the root of the pendrive to the boot directory of the pendrive.

Amedee Van Gasse (amedee) said : #10

Copying all files from the root of the pendrive to /boot directory did not help.
I will now copy all files from teh root of the pendrive to the /syslinux directory.

Amedee Van Gasse (amedee) said : #11

CONFIRMED:
* error message= "Could not find kernel image: vesamenu.c32"
* error occurs for 11.04 and 10.10 ISO files. 10.04 or below don't have this problem
* problem also affects all other Ubuntu-based images like Kubuntu, Xubuntu, Mint,...
* Problem occurs with pendrives created with pendrivelinux's universal usb installer as well as with unetbootin. This leads me to the conclusion that the problem may not be in these tools but in the image itself.

STEPS TO REPRODUCE:
* download 11.04 alternate installer iso from ubuntu.com
* check download with md5sum
* create a bootable installer on a pendrive with either universal-usb-installer (Windows) or Unetbootin (Linux)
* boot with the pendrive

WORKAROUND:
* Copy all files (only files, not directories) from the root (/) of the pendrive to the /syslinux directory of the pendrive.
* Do NOT overwrite files that already exist in the /syslinux directory
* Boot from the pendrive: no longer any errors.

Jeremy, please create a bug report and link it to this question.
I'm not entirely sure for which package you should create a bug report, probably either Ubuquity or Unetbootin. If this is not correct, assign it there anyway and ask to reassign it to the correct package. The maintainers will know where your bug report has to go.

Can you help with this problem?

Provide an answer of your own, or ask Jeremy Kuhn for more information if necessary.

To post a message you must log in.