Atheros AR3002 cannot be turned up/is not recognized.

Asked by Marcus Sharp on 2011-02-02

I don't know if I should submit this as a bug to Ubuntu, or to the Bluez development group.

The key is the device by Atheros Communications, Inc, which is their AR3002.

This is the device, apparently, that Dell is putting into this Vostro V130, which Dell ships with Ubuntu 10.04 pre-loaded.

Here is the sales pitch for the device:

http://www.atheros.com/technology/te...49&product=103

Here is where it gets a bit strange. On a separate page, Atheros indicates that:

"As a proponent of open software, Atheros provides its own Bluetooth stack for easy portability and also supports standard Bluetooth stacks such as Blue Z on Linux, Chrome OS, and Android OS. All Bluetooth profiles in Blue Z are supported, including headset and hands-free profiles, A2DP, FTP, DUN, OPP, PAN, SPP and PBAP.."

OK, so they say this device should support Bluez.

So I go to the Bluez page, and search for "atheros," and you find this:

http://www.bluez.org/l2cap-extended-features-on-2-6-36/

Very briefly, it says "Support for the Atheros AR300x chip."

I would hope that "3002" is part of "300x," but I'm not sure. I went ahead and added the natty packages to my repository, so that I could effectively install the bluez 4.87 and related packages.

Well, this ends a lot of errors. Now, when I launch blueman, I get no connection errors, or anything, but still no options to connect any devices.

This still happens:

sudo hciconfig:

hci0: Type: BR/EDR Bus: USB
BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
DOWN
RX bytes:0 acl:0 sco:0 events:0 errors:0
TX bytes:24 acl:0 sco:0 commands:8 errors:0

Which tells me that the AR3002 is still not "seen."

sudo hciconfig hci0 up yields:
Can't init device hci0: Connection timed out (110)

Now, in a very rational sense, I believe I have hit the dead end. The device is simply too new, I guess, to be supported.

Is the proper procedure to turn in a bug request to the ubuntu developers? Or do I turn in a bug notice to the bluez developer?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-02
Last reply:
2011-12-15
Anthony Wong (anthonywong) said : #1

First, make sure you're your machine is using the problematic bluetooth chip.
Type "lsusb", if you got this line you probably are:

Bus 002 Device 003: ID 0cf3:3002 Atheros Communications, Inc.

To make it usable on 11.10 (Oneiric), you can try the following steps:

1. sudo apt-get install linux-headers-generic
2. Download https://bugs.launchpad.net/ubuntu/+source/linux/+bug/714862/+attachment/2090870/+files/dell-laptop-dkms_1.4_all.deb and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/714862/+attachment/1913129/+files/ar3011-dkms_1.1ryu2.3_all.deb
3. sudo dpkg -i ar3011-dkms_1.1ryu2.3_all.deb dell-laptop-dkms_1.4_all.deb
4. Run "dkms status" to see if they're installed correctly. If you got the following output you're good:
  dell-laptop, 1.4, 2.6.38-8-generic, x86_64: installed
  ar3011-dkms, 1.1ryu2.3, 2.6.38-8-generic, x86_64: installed

Can you help with this problem?

Provide an answer of your own, or ask Marcus Sharp for more information if necessary.

To post a message you must log in.