Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0, 0)

Asked by isaac_moller on 2011-01-13

Hello,

I have an HP Slimline s5310y with an AMD processor. My Ubuntu distro is 10.04 x64, and I use dual boot with Windows 7 using BURG.

I was installing the latest rounds of updates while creating a live disc using remastersys (I know I know, bad). After I was done using this program my update manager asked me to reboot so I did. Now every time I reboot Grub kicks in like normal, makes its default selection as normal, and now I get this error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

So I have to hard shut down the unit, and when I try to reboot using "recovery mode" through my Grub I get this error: (where xxxxx represents numbers that I got too tired to write)

[ 0.881860] md: Waiting for all devices to be available before autodetect
[ 0.881924] md: If you don't use raid, use raid=noautodetect
[ 0.882081] md: Autodetecting RAID arrays.
[ xxxxxxxx] md: Scanned 0 and added 0 devices.
[ xxxxxxxx] md: autorun ...
[ xxxxxxxx] md: .... autorun DONE.
[ xxxxxxxx] RAMDISK: gzip image found at block 0
[ xxxxxxxx] usb 1-9: new high speed USB device sing ehci_hcd and address 4
[ xxxxxxxx] usb 1-9: configuration #1 chosen from 1 choice
[ xxxxxxxx] List of all partitions:
[ xxxxxxxx] No filesystem could mount root, tried: ext3 ext2 ext3 fuseblk
[ xxxxxxxx] Kernel panic - not syncing: VFS: Unable to mount root fs on unkown-block(0,0)
[ xxxxxxxx] Pid: 1, comm: swapper Not tainted 2.6.32-26-generic #48-Ubuntu
[ xxxxxxxx] Call Trace:
<<bunch of numbers>> <<letter and numbers>> panic+0x78/137
<<bunch of numbers>> <<letter and numbers>> mount_bloc_root
<<bunch of numbers>> <<letter and numbers>> handle_initrd
<<bunch of numbers>> <<letter and numbers>> initrd_load
<<bunch of numbers>> <<letter and numbers>> prepare_namespace
<<bunch of numbers>> <<letter and numbers>> kernel_init
<<bunch of numbers>> <<letter and numbers>> child_rip
<<bunch of numbers>> <<letter and numbers>> ? kernel _init
<<bunch of numbers>> <<letter and numbers>> ? child_rip

I looked to see if GRUB was actually pointing to the right partition, so this is what GRUB says when pressing the 'e' key.

insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 8a49f5a3-9c16-40ac-ac079-f3681ddd655f
echo 'Loading Linux 2.6.32-26-generic ...'
linux /boot/vmlinuz-2.6.32-26-generic root=UUID=8a49f5a3-9c16-40ac-a079-f3681d
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.32-26-generic

I booted using my Ubuntu live Cd, and I made sure that my Linux partition is actually on (hd0,5) and it is.

So I think Grub is ok?
I am able to access my Windows 7 partition using Grub (BURG) like always, my unit passed memtest and all the hardware seems to be in good shape.

Is there any way to fix my Kernel without having to completely reinstall my Ubuntu partition?

Thanks

HALP!?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2011-01-19
Last query:
2011-01-19
Last reply:
2011-01-17
isaac_moller (isaac-moller) said : #1

no help?

Best Tom (tom6) said : #2

Hi :)

Hmmm, tricky.

Ok, the 1st thing to try is the 3rd option on the grub-menu for booting into Ubuntu. The 2nd option is the same kernel as the "default" but says "recovery mode" at the end of it's line. Hopefully under this 2nd option is a 3rd option, probably the 2.6.32-25 kernel if your top one is the 2.6.35-26 kernel. This 'should' just boot up straight to your familiar desktop. If so then just run updates again to get a better copy of the more recent kernel. The other packages (apps and libraries and stuff) are already updated so you should only get about 6 (or less) packages in this update.

If that doesn't work then please can you boot into a LiveCd session and get to a command-line, go up to the top taskbar to click on
Applications - Accessories - Terminal
and then copy&paste (with the mouse) the output of

sudo fdisk -l

where "-l" is a lower-case "-L". Firefox on the LiveCd should help you navigate into here. If you login to Launchpad and click on your own name you can click on Answers at the right-hand side to get into this thread. I think you already know tricks like that tho! :)

I think the best answer is just to try re-installing grub2 using the guide
https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD
and see if the reinstall can get you into a previous kernel.

If you tend to delete your old unused kernels then we will find another way, don't worry.
Regards from
Tom :)

isaac_moller (isaac-moller) said : #3

Tom you are a genius

After reinstalling GRUB2 using method 3 CHROOT I was able to get back to my desktop and everything is the same way I left it. Method 3 was the only only from the documentation (https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD) that took into account that my Ubuntu is installed on a partition.

I am very happy

Thank you so much

Viva Ubuntu

If you are curious about any of my settings just let me know and I can e-mail you whatever information you are curious about.

isaac_moller (isaac-moller) said : #4

Thanks Tom, that solved my question.

Tom (tom6) said : #5

Hi :)

Brilliant, congrats :)))
Nicely done :)
Regards from
Tom :)

billy (carrollbob30) said : #6

i am not familiar with this can you give me step by step what to do ?
                                                                      thanks billy

Tom (tom6) said : #7

Hi :)

It is better to post a new question rather than add a comment to the end of a solved thread
https://answers.launchpad.net/ubuntu/+addquestion

However, you can always try to boot-up the machine by using one of the older kernels. When you switch the machine on, before you get the Ubuntu splash screen and loading-bar (or dots) do you get a menu of white writing on a black background? If so then use the keyboard arrow to move down 2 places and then press enter.

Are you getting the kernel panic error message tho? There are other possible errors that can be fixed at around the same point. It wont hurt to try this answer even if it is a completely different error so don't worry. Do you have an Ubuntu Cd? or can you get hold of one?

Regards from
Tom :)