After upgrade to 10.10 Maverick i get modprobe: FATAL: Could not load: /lib/module/2.6.35-22-generic/modules.dep

Asked by John Wilson on 2010-11-05

Just upgraded to Maverick and did the system restart.
The boot up went normally but stalled at my screensaver, none of the desktop icons appeared.
Tried to start up in recovery mode but could not get past my desktop login.
What is my desktop log in in recovery? Not my password which is the next prompt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux Edit question
Assignee:
No assignee Edit question
Solved by:
John Wilson
Solved:
2010-12-13
Last query:
2010-12-13
Last reply:
2010-11-06
John Wilson (jwilsondmartin) said : #1

When I boot up with kernel 2.6.35-22 generic I get the following error message:
"Modprobe: FATAL: Could not load: /lib/module/2.6.35-22-generic/modules.dep No such file or directory"
I am booting up with kernel 2.6.31-21-generic
Any suggestions how to repair 35-22?

Seems you are experiencing this bug https://bugs.launchpad.net/ubuntu/+bug/642421

From the bug thread, please try the

durlo wrote on 2010-10-09:

solution

John Wilson (jwilsondmartin) said : #3

Working in kernel 2.6.31-21 and dug out dulo's post of 2010-10-19
Using gksudo gedit edited MODULES=most to MODULES=dep. which I saved and then closed gedit.
Now when I boot up on kernel 2.6.35-22 my boot freezes at my screensaver.
When I boot up on kernel 2.6.31-21 I get the following error message:
chroot: cannot execute /etc/initramfs-tools no such file exists
Obviously I missed something when dulo 'reinstalled' the file

John Wilson (jwilsondmartin) said : #4

Have reinstalled all the initramfs-tools-bin, initramfs-tools and other marked packages with synaptic and still get the same error message when I boot up using kernel 2.6.31-21-generic:
chroot: cannot execute /etc/initramfs-tools no such file exists
Is this an important bug?
Why can't I boot up with newer builds of the kernel?

John Wilson (jwilsondmartin) said : #5

Got hopelessly frozen and messed up.
Reinstalled windows and then Maverick and have problems with the boot up.