No Sound -- Acer TravelMate 6292 -- HDA Intel

Asked by Guido on 2008-01-06

I just purchased this Acer laptop. I loaded Ubuntu a few days ago with the goal of never using Windows again. First problem: I don't have any sound. Please help. Thanks.

Glenn

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux-source-2.6.22 Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-10
Last reply:
2008-12-03
Robert Di Gioia (digioiar) said : #1

Hi.

First, check to see if you are using the Alsa mixer. To do this, double click on the volume control applet (looks like two speakers near the clock). Once it is open, choose File->Change Device and see if Alsa Mixer is selected. If not, select it.

Second, check that the PCM control in Alsa mixer is turned up and is NOT muted. Most programs use PCM for audio.

If these don't help, then try checking out these links:

https://help.ubuntu.com/community/Sound
https://help.ubuntu.com/community/SoundTroubleshooting
http://alsa.opensrc.org/index.php?page=DmixPlugin

Good luck

Guido (bondjamesbond) said : #2

1. Alsa mixer is being used.
2. PCM control is NOT muted.

I worked through the first link last night (no luck). I am about half way through the second link now (no luck).

I guess I am on the right track.

Thanks

MupKoo (mupkoo) said : #3

I had the same problem.. check this link https://answers.launchpad.net/ubuntu/+question/21574

Fred (frederic-lespez) said : #4

For the Acer TravelMate 6292, follow the instruction given here :
https://wiki.ubuntu.com/LaptopTestingTeam/AcerTravelmate6292

Basically, install the linux backports modules package and modify your /etc/modprobe.d/alsa-base so that it contains the following line :
options snd-hda-intel model=acer

PS : Mic (external or internal) doesn't work for now.

Guido (bondjamesbond) said : #5

Fred..thanks for the help. I started the process described in the wiki. I don't understand this part:
    *

      Replace the following line in /etc/modprobe.d/alsa-base:

options snd-hda-intel

with:

options snd-hda-intel model=acer

    *

      Reboot

Can you help? Sorry for my questions.

Fred (frederic-lespez) said : #6

In a terminal, run this command :
sudo gedit /etc/modprobe.d/alsa-base

A windows will open showing you the content of /etc/modprobe.d/alsa-base file.
Search the line :
options snd-hda-intel
and modify it so that it looks like that :
options snd-hda-intel model=acer

If the line doesn't exist, add it at the end of the file.

Save the file and then reboot.

Gavin Meiklejohn (gavin834) said : #7

As a footnote, I had the same problem with my Acer Aspire 7720G laptop.
The solution pointed to by Fred for the Acer Travelmate6292 also works for the Aspire 7720G.

Gavin Meiklejohn (gavin834) said : #8

Having just upgraded to Hardy Heron on my Acer Aspire 7720G, it's all gone quiet again.
The solution for 7.10 does not work as the backport modules required are not available for Hardy Heron. Making the edit to /etc/modprobe.d/alsa-base does not in itself enable audio on this Acer.

Currently I have no solution.

Anyone got any suggestions on how to resolve this issue on 8.04?

Carl-Erik Kopseng (kopseng) said : #9

It's not working anymore ... Can you believe this is happening for *every* new version of Ubuntu!?

7.04: Does not work
7.10: Doesn't work, then fix is released, works again
8.04: Doesn't work, then fix is released, works again
8.10 (pre-release): works (!), then doesn't work. Fix is released when ? ;)

I have left Ubuntu untouched for a week (fully updated a week ago), then updating it today, and after that sound disappeared. Everything *seems* to work, the mixer is unmuted, no program is complaining about sound trouble, but all that is heard is some scraping sound when running the "Test" in gnome-sound-properties.

It probably has nothing to do with the kernel, since the modules are working, and all seems okay, so perhaps the sound server?, but all I know is that it worked with 2.6.27-4, and does not work with 2.6.27-7.

Carl-Erik Kopseng (kopseng) said : #10

Sound is still missing. All I get is some scraping sound when turning the volume way up. In alsamixer the only mixer is PulseAudio, unlike in Hardy/8.04 where there were different sound levels for PCM, Master, ...

Anyway, running the latest updated 8.10/Intrepid (today is Nov 30 2008), using a 64 bit kernel (linux-kernel 2.6.27-10-generic) on the AMD64 platform. alsactl --version gives me 1.0.17, so that's probably the alsa version.

Carl-Erik Kopseng (kopseng) said : #11

I FINALLY found out what caused this - at least on my system. These two screen dumps should prove explanatory:
1. http://folk.ntnu.no/kopseng/upload/linux/Skjermdump-Terminal-PulseAudio.png
2. http://folk.ntnu.no/kopseng/upload/linux/Skjermdump-Terminal.png

Basically (1) is the first thing I noticed when 8.10 came along. Where did all the mixers go? Suddenly I had only PulseAudio in Alsamixer - not Master, PCM, etc. Nevermind, I thought. Turns out, I should have (thought). It turns out that PCM was muted, but I had no way of seeing that, since the PCM mixer never showed up anywhere.

But after killing PulseAudio (killall pulseaudio), and then starting alsamixer, I could see the pretty picture in (2). PCM was set to zero. No idea why, and how I can change this when PulseAudio is enabled/started up, but anyway, that was the answer.

So to anyone else who has a recognized sound card, has the volume at 100%, and still can't get sound. Try to kill the pulseaudio server (killall pulseaudio) and then check your mixer.

Can you help with this problem?

Provide an answer of your own, or ask Guido for more information if necessary.

To post a message you must log in.