No sound with Realtek High Definition Audio

Asked by MupKoo on 2008-01-06

I am with Acer Aspire 5520G laptop, it has a Realtek high definition audio card, but there is no sound.... nothing at all... No sound from movies, music....
i have installed the Realtek drivers for ubuntu, but still there is no reasult
Some suggestions ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-source-2.6.22 Edit question
Assignee:
No assignee Edit question
Solved by:
MupKoo
Solved:
2008-01-06
Last query:
2008-01-06
Last reply:
MupKoo (mupkoo) said : #1

https://help.ubuntu.com/community/HdaIntelSoundHowto
Look at the Update to the Latest Version of ALSA part... this solved my problem, Sorry for disturbing, but i hope this is gonna help someone else :)

Paps (contact-epaps) said : #2

I've read somewhere that for some get it working by installing linux-backports-modules

In a terminal:

sudo apt-get linux-backports-modules

But before doing that try to play with the options in /etc/modprobe.d/alsa-base and reboot.

At the end of the file try to add this:

options snd-hda-intel probe_mask=8 model=acer

There is more options than that but this seems to be the most relevant in this case.

If it doesn't work try to provide the outputs of these commands:

$ aplay -l

$ dmesg

and what you tried already

My 2 cents hope they'll help...

++ Paps