no sounds on web or inside applications. intel card.

Asked by lakshmun on 2008-01-03

i cant play any sound applications. they seem to be running but i dont hear any. i can play videos on web and from CD. i can also play radio. but only the visual is running.
I have set all the volume levels high and everything in the preferences and the volume control are on.
the sound card is of intel.

but when i connect a USB headphones, i can here the beep sound during test in the sound preferences window and still cant here application sounds.

lakshman@lakshman-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

hope this gives some idea of the sound hardware in the system. Please do help me. i am desperate to use ubuntu.
Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux-source-2.6.22 Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-13
Last reply:
2008-01-16
Fred (frederic-lespez) said : #1

Could you run the following command in a terminal and post the output please ?
grep Codec /proc/asound/card0/codec#*

You should get something like this :
$ grep Codec /proc/asound/card0/codec#*
/proc/asound/card0/codec#0:Codec: Realtek ALC268
/proc/asound/card0/codec#1:Codec: Generic 11c1 Si3054

Could you also give the brand and model of your computer ?

lakshmun (lakshmun) said : #2

hello

I am very thankful to you for your concern. I just logged in to my linux,
ubuntu and my sound seems to be working. I dont know what would not work
but finally it is fine.

Anyways here is what oyu asked for, and it does not look the same as u
expected it to be,

lakshman@lakshman-laptop:~$ grep Codec /proc/asound/card0/codec#*
Codec: Conexant CX20549 (Venice)
lakshman@lakshman-laptop:~$

Thanks lakshman

On Jan 6, 2008 5:33 PM, Fred <email address hidden> wrote:

> Your question #21306 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/21306
>
> Status: Open => Needs information
>
> Fred requested for more information:
> Could you run the following command in a terminal and post the output
> please ?
> grep Codec /proc/asound/card0/codec#*
>
> You should get something like this :
> $ grep Codec /proc/asound/card0/codec#*
> /proc/asound/card0/codec#0:Codec: Realtek ALC268
> /proc/asound/card0/codec#1:Codec: Generic 11c1 Si3054
>
> Could you also give the brand and model of your computer ?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/21306
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Fred (frederic-lespez) said : #3

You just need to install alsa drivers 1.0.15rc3 (Gutsy shipped with alsa driver 1.0.14 by default).
It's really simple to do : You just need to install the linux backports module packages by running in a terminal the following command :
sudo apt-get install linux-backports-modules-generic
And then reboot.

Keep me posted.

lakshmun (lakshmun) said : #4

hi,
now again my sound disappeared.
i have run that command u told me in the last post.

again i am giving you the status of my system running the command you have
suggested

lakshman@lakshman-laptop:~$ grep Codec /proc/asound/card0/codec#*
Codec: Conexant CX20549 (Venice)
lakshman@lakshman-laptop:~$

the results is same as last time i have sent you when they started working
all by themselves.
my system is compaq presario v3000, sound card is intel.

i have dual booted ubuntu on vista home basic.

Thank you

On Jan 9, 2008 10:21 PM, Fred <email address hidden> wrote:

> Your question #21306 on linux-source-2.6.22 in ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/linux-source-2.6.22/+question/21306
>
> Status: Open => Answered
>
> Fred proposed the following answer:
> You just need to install alsa drivers 1.0.15rc3 (Gutsy shipped with alsa
> driver 1.0.14 by default).
> It's really simple to do : You just need to install the linux backports
> module packages by running in a terminal the following command :
> sudo apt-get install linux-backports-modules-generic
> And then reboot.
>
> Keep me posted.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/linux-source-2.6.22/+question/21306/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/linux-source-2.6.22/+question/21306
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Fred (frederic-lespez) said : #5

Hi,

The command "grep Codec /proc/asound/card0/codec#*" gives you the real name of the sound card.
You have a Conexant CX20549 (Venice). I have a Realtek ALC268.

Could you confirm me that you have upgraded your alsa drivers by running sudo apt-get install linux-backports-modules-generic and rebooting ?

After that could you try this :
In a terminal, run this command to edit the file /etc/modprobe.d/alsa-base:
sudo gedit /etc/modprobe.d/alsa-base
and search the following line :
options snd-hda-intel
And modifiy it (or add it) so that it looks like :
options snd-hda-intel disable_msi=1
Then reboot and test if sound works.

Keep me posted.

Can you help with this problem?

Provide an answer of your own, or ask lakshmun for more information if necessary.

To post a message you must log in.