touchpad not detected acer A317-33

Asked by Yves Guilloux on 2021-04-04

My touchpad is not detected and doesn't appear on the 'xinput list'.

The solution presented here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1668106/comments/2

doesn't work : in my Bios, the option Touchpad doesn't exist

$ inxi -M
Machine:
  Type: Laptop System: Acer product: Aspire A317-33 v: V1.02
  serial: <superuser/root required>
  Mobo: JSL model: Lilac_JL v: V1.02 serial: <superuser/root required>
  UEFI: Insyde v: 1.02 date: 12/30/2020

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-5.8.0-48-generic 5.8.0-48.54~20.04.1
ProcVersionSignature: Ubuntu 5.8.0-48.54~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-48-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Apr 4 15:55:43 2021
InstallationDate: Installed on 2021-04-04 (0 days ago)
InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 (20210209.1)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-signed-hwe-5.8
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu linux-signed-hwe-5.8 Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-07
Last reply:
2021-04-06

This question was originally filed as bug #1922491.

Yves Guilloux (yvig) said : #1

Try Fn+F7 on the keyboard. Does this help?

Yves Guilloux (yvig) said : #3

I tried it but it doesn't work. My touchpad doesn't appear in Parameters -> Mouse and Touchpad.
Bu it works on windows 10 ( dual boot) and it's a Synaptics.

Manfred Hampl (m-hampl) said : #4

Is there anything shown for the trackpad in the output of the commands

lsusb
sudo lspci
dmesg | grep synapt
dmesg | grep pad

If you boot to Windows and shut down the OS. Then power back on into Ubuntu is it OK then? Windows can "hold" hardware sometimes.

Yves Guilloux (yvig) said : #6

@m-hampl nothing for the touchpad for the 2 first commands and nothing at all for the 2 last ones.

@actionparsnip i tried but it didn't work

Manfred Hampl (m-hampl) said : #7

Is there any unidentified device shown with lsusb or lspci?

Yves Guilloux (yvig) said : #8

I think nothing comes from the touchpad :

~$ lsusb
Bus 002 Device 002: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102/2.0 / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04ca:3015 Lite-On Technology Corp.
Bus 001 Device 003: ID 0408:a031 Quanta Computer, Inc. VGA WebCam
Bus 001 Device 002: ID 03f0:2141 HP, Inc HP Wireless Mouse 220
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

~$ sudo lspci
[sudo] Mot de passe de yves :
00:00.0 Host bridge: Intel Corporation Device 4e22
00:02.0 VGA compatible controller: Intel Corporation Device 4e55 (rev 01)
00:14.0 USB controller: Intel Corporation Device 4ded (rev 01)
00:14.2 RAM memory: Intel Corporation Device 4def (rev 01)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 4de8 (rev 01)
00:15.3 Serial bus controller [0c80]: Intel Corporation Device 4deb (rev 01)
00:16.0 Communication controller: Intel Corporation Device 4de0 (rev 01)
00:17.0 SATA controller: Intel Corporation Device 4dd3 (rev 01)
00:19.0 Serial bus controller [0c80]: Intel Corporation Device 4dc5 (rev 01)
00:19.1 Serial bus controller [0c80]: Intel Corporation Device 4dc6 (rev 01)
00:1a.0 SD Host controller: Intel Corporation Device 4dc4 (rev 01)
00:1c.0 PCI bridge: Intel Corporation Device 4db8 (rev 01)
00:1c.1 PCI bridge: Intel Corporation Device 4db9 (rev 01)
00:1e.0 Communication controller: Intel Corporation Device 4da8 (rev 01)
00:1e.3 Serial bus controller [0c80]: Intel Corporation Device 4dab (rev 01)
00:1f.0 ISA bridge: Intel Corporation Device 4d87 (rev 01)
00:1f.3 Audio device: Intel Corporation Device 4dc8 (rev 01)
00:1f.4 SMBus: Intel Corporation Device 4da3 (rev 01)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 4da4 (rev 01)
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Can you help with this problem?

Provide an answer of your own, or ask Yves Guilloux for more information if necessary.

To post a message you must log in.