How to enable tickless mode (dynamic tics)?

Asked by Mikko Rantalainen

According to changelog ( the tickless kernel (dyntics or dynamic tics) was off by default in linux-rt (2.6.31-8.12) karmic.

(1) Why was this done? If I enable dynamic ticks, is there some known problem?

(2) What does "by default" mean? Do I need to re-compile the kernel to enable the dynamic ticks, use some kernel flag at boot or can I change the mode runtime (e.g. via /proc or /sys)?

I'm currently running linux-rt in karmic and it works fine and has much lower latency than the generic kernel. However, I would want to lower the power usage with dynamic ticks if possible.

Question information

English Edit question
Ubuntu linux-rt Edit question
No assignee Edit question
Solved by:
Alessio Igor Bogani
Last query:
Last reply:
Revision history for this message
Best Alessio Igor Bogani (abogani) said :

1) At the moment linux-rt (PREEMPT_RT) isn't a 100% compatible tickless kernel. So enable it can introduce big latencies and could broke hibernation/suspend features.

2) No you don't need to recompile kernel. It is enough add on grub menu the parameter nohz=on (you can add it permanently in /etc/default/grub).

Revision history for this message
Mikko Rantalainen (mira) said :

Thanks Alessio Igor Bogani, that solved my question.