3D activated with nforce2 (geforcemx4) w/ nvidia-glx but games are not functioning

Asked by Harley on 2008-04-30

I succeded to get 3D/ opengl in Ubuntu 8.04.01 on a system with nforce2 chipset by installing "nvidia-glx" driver only (the recommended "nvidia-glx-legacy" do not install higher resolution than 800x600), as reported by the system (glxgears and nvidia control panel are properly working, displays 3d/opengl settings)

The problem is that all 3D games (extremepenguin, foobilliard, flightgear etc) are not functional (displaysdark shadows).
Are there some options/checks to be marked in the nvidia control panel for opengl?
No splashscreen with nvidia at booting (is necessary?).

Need help.
Thanks in advance,

Florian

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-restricted-modules-2.6.24 Edit question
Assignee:
No assignee Edit question
Solved by:
Harley
Solved:
2008-05-03
Last query:
2008-05-03
Last reply:
Harley (hbdoyle) said : #1

I managed to solve my problem. I needed to install libgl1-mesa-dri and libglide3.