Is it possible to get Visual Effects on a Radeon Xpress 1100 (Dell inspiron 1501)

Asked by harrydb on 2008-01-11

I am running hardy alpha3 on a Dell inspriron 1501 laptop that has a radeon Xpress 1100 graphics card [RS485]. Now that the fglrx driver supports compositing I installed it and tried to enable visual effects, which failed. It turns out that it cannot find the 'GLX_EXT_texture_from_pixmap' in 'glxinfo ' in the 'GLX extensions' section (it is there in server and client glx extensions).

My question is now, is it possible to get visual effects in this way, and why is GLX_EXT_texture_from_pixmap not there?

harrydb (harrydeboer) said : #1

When using the 'radeon' driver (selected by 'ati' setting in xorg), GLX_EXT_texture_from _pixmap is found but then I get the following error

Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

Wrwrwr (wrwrwr) said : #2

Do you have default depth set to 24 in you /etc/X11/xorg.conf?. Try changing if not.

harrydb (harrydeboer) said : #3

Thanks for you response!
Because of the new Xorg version this is no longer set in xorg.conf, however manually adding this section does not help (using the radeon driver, It still returns the same error.

harrydb (harrydeboer) said : #4

(Using radeon driver)
Sorry, for some reason I did not properly restart X, your suggestion (as logical as it is) does something, now my screen turns completely white... I'll file a bug report for the depth issue and the white screen.

harrydb (harrydeboer) said : #5

(using fglrx)
when staring compiz this now hangs at "Checking for texture_from_pixmap: "
with cpu: Xorg 66%, glxinfo 34%
which is strange because when i start glxinfo manually it does finish properly. Guess I'll have to file a bug for that too.

Harry

Wrwrwr (wrwrwr) said : #6

You'll probably need at least a proper monitor, screen, device and server layout sections. Some debug info can be found in /var/log/Xorg.0.log.

I'm not sure but using displayconfig-gtk (System-->Administration-->Screens and Graphics) should cause a full xorg.conf to be written out, so you can just modify it. Probably reconfiguring xserver would write a complete file too, or there used to be aticonfig for fglrx: "sudo aticonfig --initial" would write whatever is needed for your card.

Could you please post graphics related portions of your xorg.conf, and Xorg.0.log, so i can have some more insight.

harrydb (harrydeboer) said : #7

I don't think it is in the xorg configuration, but hey never say never. You can find the two files in the bug reports I posted (see related bugs in the side panel).

harrydb (harrydeboer) said : #8

Btw, displayconfig-gtk is not functioning properly in hardy alpha 3 and aticonfig segfaults, there are already existing bugreports for that.

harrydb (harrydeboer) said : #9

From the responses in my bug report (see sidebar) I know that for the radeon driver, DRI support is experimental on this chipset. Dri support can be enabled by adding 'Option "DRI"' to xorg.conf (driver section). This gives me another error (again, see bug report).

For the fglrx driver, still nothing.

Works superbly on my Inspiron 1501 under Gutsy. Maybe a comparison of this to Hardy alpha 3 lspci and glxinfo outputs could narrow it down? Hope this is helpful.

bmf@dellbuntu:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]
05:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
08:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
08:01.0 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
08:01.1 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)

bmf@dellbuntu:~$ glxinfo
name of display: :1.0
Xlib: extension "XFree86-DRI" missing on display ":1.0".
display: :1 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon Xpress Series
OpenGL version string: 1.2 (2.0.6473 (8.37.6))
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr,
    GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias

   visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
 id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon

harrydb (harrydeboer) said : #11

Ah yes. this was in very early alpha. it has worked now for a while. thanks for your response!

No problem, Hardy will be on this machine when it hits final... Great to see it's solved. I use my 1501 more than all my other machines and don't have the wear-with-all to put the beta on it, I have a test machine running it now, instead. Rock!