Ubuntu suddenly reboot: a problem about Clocksource tsc unstable?

Asked by gabry78 on 2010-02-20

Hi all..
I've this configuration
I've already posted a similar problem (See my question :"NVIDIA crash&reboot.."), but now I've understand my real problem.
My configuration

Ubuntu 9.10 64 bit
Video: GeForce 8600GT
Monitor: ASUS LCD ACI VH226
Motherboard&CPU: Asus with AMD 64 Athlox X2
RAM: 2 Gb
Propretary drivers 185 installed by ubuntu menu

THE PROBLEM:

Sometimes (often when I use 3d application or "hard" applications) and doing antithing special, the system suddendly reboots without any explanation. In the kern.log I find: "Clocksource tsc unstable (delta = -116657500 ns)". So I've search in google and I've found that the problem is linked to frequency scaling of my CPU: so I've added to my menu.lst (grub) the line "clocksource=acpi_pm".

After that, the system still crashes, but only after a time longer and when an application seems to question an "high charge" (es cairodock).
Now I'll try to disable ACPI cpu (frequency scaling) in BIOS.... but there is another way to solve this problem ?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux-restricted-modules-2.6.22 Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-20
Last reply:
2010-03-20
Uwe Geuder (ubuntulp-ugeuder) said : #1

I don't really have much experience in this area.

Linux controls frequency scaling via the files in /sys/devices/system/cpu/cpu0/cpufreq/

Normally scaling_governor is "ondemand", i.e. frequency scaling is active.

You can write to this file (using sudo). Possible values can be found from file scaling_available_governors. "Performance"
means the machine is running at full speed all the time.

I guess your machine is dual core. Not sure whether you have to do the same thing for cpu1, too. There are files "related_cpus" and "affected_cpus", but I don't know how they work. I'm writing this on my old laptop, only one core in there.

I have know idea how this is related to ACPI frequency scaling and/or BIOS.

Good louck!

I have a very similar problem. Ubuntu 9.10 32 bit, Asus VH226H monitor, Nvidia geforce 6200 Turbocache, driver nvidia 185 and 173 (I have tried both), asus a8n-sli se motherboard with Athlon CPU. In my case the system freeze and I see your same message in kern.log.

I have similar, even worse problem, also with Windows XP, with the latest nvidia driver (19something).

I haven't had any crash in many years with a Philips CRT 109b5 monitor, running at 1280x1024. and the problem has appeared only immediately after buiyng this LCD Asus monitor, which runs 1920x1080. After changing the connection video card - monitor from DVI to VGA freezing happens less often.

I was wondering if it was a problem of my video card, maybe a faulty memory, that was not utilized with the 1280x1024 resolution of my old monitor, but your experience goes against this. It may depend also with that particular Asus monitor

Have you made any further step toward the solution?
Thanks,
Gabriele Bianchi

gabry78 (gabriele-ciuti) said : #3

Hi, Gabriele. I'm Italian too, so if you want,we can talk in our language...
I've discovered and solved the problem. The bug is not related NVIDIA video card, propretary video drivers or ASUS lcd screen.
The real problem is the frequencty scaling of AMD CPU. I believe the bug perhaps is inside the bios asus motherboard which isn't able to well manage cpu frequency scaling (eg "cool and quiet"). As a matter of fact, if you try to install "cool and quiet" driver in Microsoft Windows, also the propretary system can become unstable (blue death screen): try it!
In Ubuntu, when you try to set high screen resolutions or you run an heavy program (as Mozilla FIrefox with java applications, graphic progreams, etc..), the system calls more resources and the motherboard increases cpu frequency... but this is bad managed and this often induces the operating system to crashes (in fact, it's very strange Ubuntu suddendly crashes and restarts without any message, no?),
I've solved my problem going inside bios and disabling "Cool 'n Quiet" function. After that CPU frequency is fixed to higher value and... no more crashes in ubuntu !

I hope my opinion is usefull for you.
Tell me if it works!

gabry78 (gabriele-ciuti) said : #4

Hi, Gabriele. I'm Italian too, so if you want,we can talk in our language...
I've discovered and solved the problem. The bug is not related NVIDIA video card, propretary video drivers or ASUS lcd screen.
The real problem is the frequencty scaling of AMD CPU. I believe the bug perhaps is inside the bios asus motherboard which isn't able to well manage cpu frequency scaling (eg "cool and quiet"). As a matter of fact, if you try to install "cool and quiet" driver in Microsoft Windows, also the propretary system can become unstable (blue death screen): try it!
In Ubuntu, when you try to set high screen resolutions or you run an heavy program (as Mozilla FIrefox with java applications, graphic progreams, etc..), the system calls more resources and the motherboard increases cpu frequency... but this is bad managed and this often induces the operating system to crashes (in fact, it's very strange Ubuntu suddendly crashes and restarts without any message, no?),
I've solved my problem going inside bios and disabling "Cool 'n Quiet" function. After that CPU frequency is fixed to higher value and... no more crashes in ubuntu !

After that,
about your video card, try to set resolution to "auto" in NVIDIA Server setting. LCD have a very different configuration respect CRT. Another trick: video card is connected with digital port? if no, try to switch from analogic to digital VGA.

I hope my opinions are usefull for you.
Tell me if it works!

Thanks a lot, I have changed the bios setting and I will see if the problem is solved.

I too am convinced that the behaviour is not related to drivers or to operating system: a couple of times my system is frozen even before arriving at the screen where the user chooses which OS to boot.

What It is not clear to me is why this behaviour has never happened during the many years when my PC was connected to my old 1280x1024 CRT screen. Is it only the difficulty of managing a 1920x1080 resolution which makes the difference?

In any case, thanks a lot, and ''incrociamo le dita'' (let's cross fingers).
Gabriele

Can you help with this problem?

Provide an answer of your own, or ask gabry78 for more information if necessary.

To post a message you must log in.