Raspberrypi 4B wireless driver load regulatory.db error caused 5GHz can't be connect

Asked by Wentao Wu on 2019-11-21

Hi

I'm newbie in Raspberrypi model 4B and Ubuntu 19.10
my Raspberrypi 4B is running with Ubuntu 19.10: ubuntu-19.10-preinstalled-server-arm64+raspi3.img.xz
when I enable my wireless to connect my 5GHz wireless AP, it can show or connect to it anymore, just 2.4Ghz can works.

checked with dmesg info, found failed to load regulatory.db error log:

[ 8.378706] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[ 8.413616] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 8.413626] cfg80211: failed to load regulatory.db
[ 8.572316] brcmfmac: F1 signature read @0x18000000=0x15264345
[ 8.581745] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 8.592852] usbcore: registered new interface driver brcmfmac
[ 8.774078] Bluetooth: Core ver 2.22
[ 8.775421] NET: Registered protocol family 31
[ 8.775428] Bluetooth: HCI device and connection manager initialized
[ 8.775471] Bluetooth: HCI socket layer initialized
[ 8.775509] Bluetooth: L2CAP socket layer initialized
[ 8.775585] Bluetooth: SCO socket layer initialized
[ 8.786994] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 8.807902] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4

after searched google, the solution is manual download wireless-regdb from
https://mirrors.edge.kernel.org/pub/software/network/wireless-regdb/
unzip it and copy regulatory.db regulatory.db.p7s to /lib/firmware/

reboot boxes, no any error log and 5Ghz can works for wireless.
I'm not sure it's a BUG or configuration issue, as I'm not familar with wireless-regdb configuration.
current dmesg log as below:

[ 8.374621] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 8.392394] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[ 8.477863] vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.478343] vc_sm_cma: module verification failed: signature and/or required key missing - tainting kernel
[ 8.486828] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.510815] bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.516999] brcmfmac: F1 signature read @0x18000000=0x15264345
[ 8.525808] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 8.535674] usbcore: registered new interface driver brcmfmac
[ 8.739579] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 8.765928] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4

My question is :
1. who can help to confirm it's a bug or configuration issue?

2. how to set the country code for Raspberrypi 4B with ubuntu19.10?

as Ubuntu 19.10 using netplan to setup network, I'm also using this yaml config to connect my wlan0 to AP, but not found any option to enable it.

Thanks
Wentao

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu linux-raspi2 Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-21
Last reply:
2019-12-07
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.