extra modules for 6.8.0 kernel

Asked by henk de hopper

on the newest lts 24.04 i can't install the meta package. linux-modules-extra-raspi which is talked about a lot in a bug i am experiencing with trying to get iscsi too work. installing that should fix it. but the linux-raspi package doesn't seem too contain a extra module. is this package deprecated/unneeded and should i look somewhere else or is this something that is still being worked on?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-raspi Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

what is the output of:

uname -a

Thanks

Revision history for this message
henk de hopper (henkdehopper) said :
#2

the output of uname -a is
Linux rp4-1 6.8.0-1006-raspi #6-Ubuntu SMP PREEMPT_DYNAMIC Mon Jun 17 11:30:51 UTC 2024 aarch64 aarch64 aarch64 GNU/Linux

Revision history for this message
Best Manfred Hampl (m-hampl) said :
#3

Since the 6.7.0 version of the kernel packages, there is no linux-modules-extra package any more and everything has been combined into the linux-modules package.
see Bug #2048862

compare the sizes:
6.5.0-1020.23:
linux-modules-6.5.0-1020-raspi_6.5.0-1020.23_arm64.deb (56.8 MiB)
linux-modules-extra-6.5.0-1020-raspi_6.5.0-1020.23_arm64.deb (27.3 MiB)
6.8.0-1007.7:
linux-modules-6.8.0-1007-raspi_6.8.0-1007.7_arm64.deb (87.1 MiB)
That's approximately the sum of the two

Revision history for this message
henk de hopper (henkdehopper) said :
#4

Thanks Manfred Hampl, that solved my question.