linux-generic meta package depending on old kernel

Asked by Vasya Pupkin on 2009-10-31

There is a linux-image-generic version 2.6.28-16 but linux-generic still depending on 2.6.28.15. This makes it impossible to upgrade smoothly without resolving conflicts. Why is it done so?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Vasya Pupkin
Solved:
2009-11-02
Last query:
2009-11-02
Last reply:
Vasya Pupkin (shadowlmd) said : #1

I'm using Ubuntu 9.04 with default package sources.

Vasya Pupkin (shadowlmd) said : #2

Had to manually modify /etc/apt/sources.list to add following lines:

deb http://security.ubuntu.com/ubuntu jaunty-security main restricted
deb http://security.ubuntu.com/ubuntu jaunty-security universe
deb http://security.ubuntu.com/ubuntu jaunty-security multiverse

After that I got package updated and all problems gone.