linux-restricted-modules question - nvidia driver problem

Asked by Enrico Rosina on 2008-06-11

Hello,

Sorry Linux is not my best skill. I have NVIDIA driver problem (temporarily solved). Before reporting a new bug related to kernel upgrade and legacy drivers, I want to be sure that my problem is not related to this bug report:

Bug #84348 in linux-meta (Ubuntu): “Kernel upgrades need to check for proprietary drivers and upgrade them too if present”

My current configuration
 Ubuntu 8.04 (hardy)
 Kernel Linux 2.6.24-18-generic
 GNOME 2.22.2

 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
 graphic card is NVIDIA Asus Extreme N7300GT
 legacy NVIDIA driver NVIDIA-Linux-x86-100.14.11-pkg1.run
 (cannot tell real driver specs because I could
 not re-install it properly)

My graphic card was never well supported by the Ubuntu installation, so I was forced to install a legacy driver.
(not that I like it, but I cannot work 800 x 600 at a 50 hz rate when I need 75 !!!)

At each kernel upgrade Ubuntu,
 - 2.6.20.15-generic
 - 2.6.20.16-generic
 - 2.6.24.18-generic
... I have the same problems: driver installation disappears, my screen resolution goes down to 800 x 600 with 50 hz (should be 75). Wen I try to launch the legacy program for NVIDIA settings, following error is displayed:

"You don't seem to be using NVIDIA driver..."

If I try to reinstall the NVIDIA driver, I get following message:
*** Linux kernel source not configured - missing config.h

Then I have to go though a long process of
- creating deprecated config.h,
- defining ln -s linux-headers-'uname -r' linux
- sudo apt-get install linux-headers
- and so on.

It needs at least 50 reboots, compiling, hours on the internet to find a solution, and I never really found out what finally was to be done because if finally it somewhat succeeds, I don't know exactly what did have any effect and what was not necessary. (I am not Linux expert, only end-user)

Now I finally have succeeded to have a graphic correct resolution, but the legacy menu is still missing, so I suppose that I don't have graphic acceleration, though I don't really need to because I have dual boot (windows or Ubuntu), and when I want a correct graphic definition I go on Windows. But don't you think it's a pity?

If I search launchpad for bug reports, I find out plenty of references to linux-restricted-modules. How do I know if my problem is related to them? Is my legacy driver a restricted module? What can I do to check that? Should I report my problem as a bug? Or is it related to the above reported bug?

Thank you very much for giving me a response to these questions.
"ero"

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Enrico Rosina
Solved:
2008-06-12
Last query:
2008-06-12
Last reply:
2008-06-12
Bhavani Shankar (bhavi) said : #1

Hello

After doing a bit of research I found this link

http://www.nvnews.net/vbulletin/showthread.php?t=110088

Also download the driver from this link and compile

http://us.download.nvidia.com/XFree86/Linux-x86/173.14.05/NVIDIA-Linux-x86-173.14.05-pkg1.run

Works fine without patches for me

Regards

Bhavani Shankar.

bodhi.zazen (bodhi.zazen) said : #2

I have a similar card and have noticed that nvidia-new-glx is *finally* working in hardy

Try removing the proprietary nvidia driver and :

sudo apt-get install nvidia-glx-new nvidia-settings

Reboot and run

gksu nvidia-settings

Enrico Rosina (e-rosina) said : #3

Ok thank you very much to you both for giving a so quick answer.

First i respond to Bhavani Shankar:

I tried your solution but with no other effect than driving me back to 800x600, at 85 hz, and it really hurts my eyes.

First, when I downloaded and executed NVIDIA-Linux-x86-173.14.05-pkg1.run, I had an error:
ERROR: File '/usr/lib/modules/libwfb.so' is not a symbolic link.

Then after reboot I had Ubuntu executing in low resolution mode. And reboot is very funny, because my name and password must be given in a region outside screen (just have to guess that I am in the login screen)

I tried to launch System tools => NVIDIA X Server Settings
... but I had following error message:

You do not appear to be using the NVIDIA-X driver.
Please edit your X configuration file (just run `nvidia-xconfig`as root), and restart the X server.

Running nvidia-xconfig did not do any good, though the file /etc/X11/X11.conf seems to be ok.

I also followed your link to nvnews.net but their example is not clear for me:

# sh /path/to/NVIDIA-Linux-x86_64-169.12-pkg2.run \
--apply-patch /path/to/NVIDIA_kernel-169.12-2286310.diff.txt
# sh NVIDIA-Linux-x86_64-169.12-pkg2-custom.run

I can execute the pkg2.run, since I know where I placed it, but where does the diff.txt come from? or the pkg2-custom.run?

Can you please give me the correct syntax to execute this pkg1.run?
Thank you very much for any hint
ero

Enrico Rosina (e-rosina) said : #4

and now my response to bodhi.zazen.
Thank you, but I need some more hints:
- how do I remove a driver that appearently was not installed completely?
- can't I just try
   sudo apt-get install nvidia-glx-new nvidia-settings,
   and run gksu nvidia-settings after reboot?
Would be nice to read your suggestion about it.
Thank you
ero

Enrico Rosina (e-rosina) said : #5

Anyways I tried to uninstall driver with unistall program, then installed nvidia-glx-new, with the same result as above:

You do not appear to be using the NVIDIA-X driver.
Please edit your X configuration file (just run `nvidia-xconfig`as root), and restart the X server.

Bhavani Shankar (bhavi) said : #6

Hello

You have to download the diff.txt from the attachment links and save them onto your folder/directory

Note: What you may want to try is downloading the Linux package from the nvidia site. Then install build-essential, kernel-headers, kernel-package from the Ubuntu package install tools (ie. synaptic, aptitude, apt-get, whatever).

eg. sudo aptitude install build-essential linux-headers kernel-package

Actually the headers part should be specific to your kernel, so for example most default installs it would be linux-headers-generic. To check which kernel you have simply run "uname -r"

Then run "sh NVIDIA-Linux-x86-173.14.05-pkg1.run"

Also "man nvidia-xconfig" might be useful

Regards

Bhavani Shankar.

Enrico Rosina (e-rosina) said : #7

Thank you very much for your help Bhavani Shankar, I appreciate it very much. But the result of the was simply one dozen of log messages, then a dry 'failed to install' with no explanation... I tried and googled to find out more but 2 hours after I am at the same point.

Unfortunately as I said I am not an expert in linux, and linux seems to be for experts only:

The graphical environment is supposed to do all the things automatically, including kernel upgrades. But no kernel was installed without a failure, each time I spent dozens of hours to complete the process manually (nvidia graphic card and attansic network card altogether not supported).

At each kernel upgrade, my OS was corrupted and I had to guess or learn what went wrong. And do plenty of things without knowing if they brought a solution or would destroy further my environment.

To be short I feel as if I should be more clever than the people who know Linux 100 times better than me and wrote the install scripts...

I will not give up, but for the moment I will return to Windows because I am tired of my 800x600 flashing screen. Sure I will find some tutorials on Linux before coming back...

Thank you again,
Best regards!
ero

Enrico Rosina (e-rosina) said : #8

Problem somewhat solved:

Solution found with a tutorial for nvidia drivers on http://doc.ubuntu-fr.org/nvidia

For graphic card: NVIDIA Asus Extreme N7300GT
This driver is useful: NVIDIA-Linux-x86-100.14.11-pkg1.run

But the automatic kernel compiling of this package fails systematically (probably incompatible with Ubuntu 8.04)
The tutorial explained me how I could extracts the components which were needed, and the driver installation could be made without kernel compilation:

1) cleanup previous drivers
    apt-get remove --purge nvidia*

2) extract from package
    sudo sh NVIDIA-Linux-x86-100.14.11-pkg1.run --extract-only cd NVIDIA-Linux-x86-100.14.11-pkg1

3) install new
    sudo ./nvidia-installer

Here we go :-)