Is it normal that the swapper task causes most timer wakeups?

Asked by PeterPall

I did a

echo 1 >/proc/timer_stats

followed by a

cat /proc/timer_stats

I surrently don't have any swap file or partition. Is it normal that swapper/0 and swapper/2 still cause the majority of timer wakeups?

Am currently running Linux version 4.7.0-040700rc2-lowlatency

Sample period: 724.882 s
Collection: active
 61205, 0 swapper/0 tick_nohz_restart (tick_sched_timer)
 54814, 0 swapper/2 tick_nohz_restart (tick_sched_timer)
 24337, 7 rcu_preempt rcu_gp_kthread (process_timeout)
 9297, 0 swapper/2 __tick_nohz_idle_enter (tick_sched_timer)
  948, 3958 gnome-terminal- schedule_hrtimeout_range_clock (hrtimer_wakeup)
 61256, 0 swapper/3 tick_nohz_restart (tick_sched_timer)
 56990, 0 swapper/1 tick_nohz_restart (tick_sched_timer)
 6351, 2151 compiz schedule_hrtimeout_range_clock (hrtimer_wakeup)
 2299, 112 systemd-udevd gen6_read32 (intel_uncore_fw_release_timer)

Question information

English Edit question
Ubuntu linux-meta Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Then I suggest you report a bug to the guys you downloaded the kernel from. Does the official kernel from your release not run your hardware OK?

Revision history for this message
PeterPall (peterpall) said :

It is good to know you are still around!
Have submitted the bug as - which actually should have been my actual question: Does it make sense to report this bug.

Kernels <4.3 don't support my epson scanner on USB and kernels <4.6 sometimes looses fonts and bitmaps saved in my intel integrated graphics on suspend. but 4.6 is fine and seems to use less battery on my acer aspire s7 than earlier versions => will revert to this kernel.

Revision history for this message
PeterPall (peterpall) said :

Thanks actionparsnip, that solved my question.