Slow & not using all memory in x86_64 maverick htpc

Asked by keepitsimpleengr on 2011-03-18

The computer is an HTPC (Mythbuntu 10.10) upgraded from 10.04. It is kept fully updated.

Motherboard is Foxconn A74ML-K 3.0 with 1Ghz HyperTransport technology
~http://www.foxconnchannel.com/product/Motherboards/detail_overview.aspx?ID=en-us0000491
Memory is Kingston HyperX Blu 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333
~http://www.valueram.com/datasheets/KHX1333C9D3B1_4G.pdf
⋯:~$ uname -a
Linux ⋯ 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64 GNU/Linux

POST reports 4096MB of memory
but htop and others report around 3.2GB
⋯:~$ grep Memory: /var/log/messages
Mar 17 10:04:14 ⋯ kernel: [ 0.000000] Memory: 3205756k/3276352k available (5716k kernel code, 452k absent, 70144k reserved, 5375k data, 912k init)

Hardware lists show one of the two DDR3 not running at 667MHz...
⋯:~$ sudo lshw -short | grep memory
/0/2f memory 4GiB System Memory
/0/2f/0 memory 2GiB DIMM Synchronous 667 MHz (1.5 ns)
/0/2f/1 memory 2GiB DIMM Synchronous 200 MHz (5.0 ns)

Memtest86 v2.11 Reports:
3199M 3085 MB/s
Chipset AMD K8 (ECC disabled)
Settings: RAM 200Mhz (DDR400) CAS: 2.5-1-0-1 DDR-1 (128bits)

This system runs slow and does not use full 4GB memory. Do I have a memory problem or a motherboard problem? How could I test to find out?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-meta Edit question
Assignee:
No assignee Edit question
Solved by:
keepitsimpleengr
Solved:
2011-03-19
Last query:
2011-03-19
Last reply:
2011-03-18
mycae (mycae) said : #1

Hard to say.

Try using only one stick at a time, in the first slot (usually these are numbered). Sometimes the latter slots are limited in what they can do (ie limited address space or frequency).

If the slots are not numbered, just try switching between the two currently occupied slots.

Its a bit of a pain, but it might help work out your problem.

mycae: thanks, this verified it was the mainboard and not the RAM.

SOLUTION:

Review of BIOS settings revealed improper settings for both CPU and RAM.

When these were corrected, the problem was resolved.

The Foxconn A74ML-K 3.0 requires BIOS setting "…Memory hole…" be enabled, among other things.

Help came from foxconn tech support and also hardinfo ("System Profiler and Benchmark" on Ubuntu Software Centre", the benchmarks included were very helpful.)