I get an error message when starting, Modprobe:Fatal:could not load

Asked by Dean-com-pac on 2011-02-06

I am a novice and I'm not sure what a Modprobe is however I do think that it could be something that might be helpful if it were to load? Please give me some kind of direction if possible.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Dean-com-pac
Solved:
2011-02-06
Last query:
2011-02-06
Last reply:
2011-02-06

modprobe is used to load and unload kernel modules.

Dean-com-pac (dean-com-pac) said : #2

The message I get is as follows: Modprobe:Fatal:Could not load/lib/modules/2.6.35-25-generic-pae/modules.dep:no suce file or directory
This is my first linux based operating system and I guess my question is do I need to do something about this issue or do I just let it be? If I need to correct this then how would I go about this? If I don't need to then what effect will this have on Ubuntu.

mycae (mycae) said : #3

modules.dep should not be a kernel module at all; it sounds like your /etc/modprobe.d/SOMETHING is wrong. Its not going to hurt anything, but it is also possible to fix

can you provide the output of (in a terminal, CTRL+ALT+T, or from applications menu) these commands -- you can cut and paste them if need be

cd /etc/modprobe.d/
grep modules.dep *

Dean-com-pac (dean-com-pac) said : #4

Thanks! I'll just let it be.

Scott Allen (signal) said : #5

I'm getting the same error after a minimal 10.10 Maverick install.

There are no results from:
grep modules.dep /etc/modprobe.d/*

Contents of /etc/modprobe.d
-rw-r--r-- 1 root root 325 2010-10-01 08:33 blacklist-ath_pci.conf
-rw-r--r-- 1 root root 1603 2010-10-01 08:33 blacklist.conf
-rw-r--r-- 1 root root 210 2010-10-01 08:33 blacklist-firewire.conf
-rw-r--r-- 1 root root 660 2010-10-01 08:33 blacklist-framebuffer.conf
-rw-r--r-- 1 root root 1077 2010-10-01 08:33 blacklist-watchdog.conf
-rw-r--r-- 1 root root 29 2010-10-01 08:33 intel-5300-iwlagn-disable11n.conf

If you boot to root recovery mode and run:

depmod -a; reboot

Should be ok

@Scott
If you want to implement a workaround for this problem on your system, see https://answers.launchpad.net/ubuntu/+source/linux-meta/+question/144221 (starting with Manfred Hampl's first post). If you want help doing so, please feel free to post a new question.