How do I get the feisty/gutsy kernel viewing 4 GB RAM?

Asked by Paolo Benvenuto on 2007-09-22

How do I get the feisty/gutsy kernel viewing 4 GB RAM?

I have 4 GB ram installed, but:

$ free -m
             total used free shared buffers cached
Mem: 2914 941 1973 0 683 40
-/+ buffers/cache: 217 2697
Swap: 2133 0 2133

i.e. only less than 3 GB are seen by the kernel, which is a server one:

$ cat /proc/version
Linux version 2.6.20-16-server (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Fri Aug 31 01:01:45 UTC 2007

Question information

Rodrigo Donado (frezeeer) said : #1

Hi:

try following this guide:
http://ubuntuforums.org/showthread.php?t=56835
there is a point that talk about "high memory support" it could help you.
one more thing does your BIOS see the 4Gb

Benoit Malet (benoit-malet) said : #2

Hello !

Are you using a 64bit version of Ubuntu ?

Regards,
Benoît

Paolo Benvenuto (donpaolo) said : #3

no, a 32bit one

Bjørn Sandåker (prognatus) said : #4

Got more than a gig of RAM and 32-bit Linux? Here's how to use it: http://www.linux.com/feature/119287 (Linux.com)

Benoit Malet (benoit-malet) said : #5

Hello !

As you can see in the article posted by Bjorn, Ubuntu enables the use of more than 1 Gb. But, the upper limit for a 32bit OS is 4Gb (comes from the number of addresses available in memory). Unfortunately, often the OS can manage less than that. The best thing to do to be sure to use all your memory is to use a 64bits version of Ubuntu. Alternatively, you can try to investigate the way proposed by Bjorn ... 3 Gb seem to me a bit far from the theoretical 4 Gb, so you might be able to shorten the gap.

Regards,
Benoit

Fabián Rodríguez (magicfab) said : #6

Fabián Rodríguez suggests this article as an answer to your question:
FAQ #669: “I have 4GB or more of RAM but can't see it in Ubuntu. How can I enable support for all my RAM ?”.

Can you help with this problem?

Provide an answer of your own, or ask Paolo Benvenuto for more information if necessary.

To post a message you must log in.