Raspi kernel 5.8 doesn't provide wireguard modules

Asked by omni-vi on 2020-10-23

Hello,

I'm trying to install the package wireguard on the Raspi 4B under 20.10 (Groovy). Wireguard wants to install wireguard-dkms which in turn wants to build the kernel modules even though kernel 5.8 comes with the modules prebuild.

In focal the raspi kernel is listed as providing support for wireguard:

~$ curl -s http://ports.ubuntu.com/ubuntu-ports/dists/focal-updates/main/binary-arm64/Packages.xz | unxz | grep -B11 Provides:.*wireguard | grep ^Package:
Package: linux-image-aws
Package: linux-image-generic
Package: linux-image-generic-hwe-20.04
Package: linux-image-generic-hwe-20.04-edge
Package: linux-image-raspi. <-------
Package: linux-image-virtual
Package: linux-image-virtual-hwe-20.04
Package: linux-image-virtual-hwe-20.04-edge

In groovy the raspi kernel is not listed:

~$ curl -s http://ports.ubuntu.com/ubuntu-ports/dists/groovy/main/binary-arm64/Packages.xz | unxz | grep -B11 Provides:.*wireguard | grep ^Package:
Package: linux-image-aws
Package: linux-image-generic
Package: linux-image-generic-64k
Package: linux-image-generic-64k-hwe-20.04
Package: linux-image-generic-64k-hwe-20.04-edge
Package: linux-image-generic-hwe-20.04
Package: linux-image-generic-hwe-20.04-edge
Package: linux-image-virtual
Package: linux-image-virtual-hwe-20.04
Package: linux-image-virtual-hwe-20.04-edge

Is this a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-meta-raspi Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2020-10-26
Last query:
2020-10-26
Last reply:
2020-10-23

I suggest you report a bug

omni-vi (catcher) said : #2

Thanks actionparsnip, that solved my question.