Kernel headers updated but not the kernel itself - why?

Asked by Anthony Kamau

Two recent kernel header updates with no corresponding kernel image - puzzling!

My system:
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily

Here's the kernel currently running on my system:
$ uname -r

Here are the contents of my /boot directory:
$ ls -Al /boot
total 46176
-rw-r--r-- 1 root root 1311978 Oct 9 04:15 abi-4.2.0-16-generic
-rw-r--r-- 1 root root 184809 Oct 9 04:15 config-4.2.0-16-generic
drwxr-xr-x 5 root root 4096 Oct 30 09:11 grub
-rw-r--r-- 1 root root 34668806 Oct 30 09:10 initrd.img-4.2.0-16-generic
-rw-r--r-- 1 root root 182704 Aug 27 23:04 memtest86+.bin
-rw-r--r-- 1 root root 184380 Aug 27 23:04 memtest86+.elf
-rw-r--r-- 1 root root 184840 Aug 27 23:04 memtest86+_multiboot.bin
-rw------- 1 root root 3740437 Oct 9 04:15
-rw-r--r-- 1 root root 6797696 Oct 30 07:09 vmlinuz-4.2.0-16-generic

A partial history (where "linux-" is listed /var/log/apt/history.log file) shows the following:
Start-Date: 2015-11-10 08:09:34
Commandline: aptdaemon role='role-commit-packages' sender=':1.108'
Install: linux-headers-4.2.0-17:amd64 (4.2.0-17.21, automatic), linux-headers-4.2.0-17-generic:amd64 (4.2.0-17.21, automatic)
Upgrade: linux-headers-generic:amd64 (,, libnm0:amd64 (1.0.4-0ubuntu5, 1.0.4-0ubuntu5.1), python3-software-properties:amd64 (0.96.13,, libnm-util2:amd64 (1.0.4-0ubuntu5, 1
.0.4-0ubuntu5.1), libnm-glib-vpn1:amd64 (1.0.4-0ubuntu5, 1.0.4-0ubuntu5.1), unzip:amd64 (6.0-17ubuntu1.1, 6.0-17ubuntu1.2), linux-firmware:amd64 (1.149, 1.149.1), software-properties-common:amd64 (0.96.13,, network-manager:amd64 (1.0.4-0ubuntu5, 1.0.4-0ubuntu5.1), linux-libc-dev:amd64 (4.2.0-16.19, 4.2.0-17.21), software-properties-gtk:amd64 (0.96.13,, libnm-glib4:amd64 (1.0.4-0ubuntu5,
End-Date: 2015-11-10 08:10:37

Start-Date: 2015-11-11 07:41:09
Commandline: aptdaemon role='role-commit-packages' sender=':1.103'
Install: linux-headers-4.2.0-18-generic:amd64 (4.2.0-18.22, automatic), linux-headers-4.2.0-18:amd64 (4.2.0-18.22, automatic)
Upgrade: linux-headers-generic:amd64 (,, flashplugin-installer:amd64 (,, youtube-dl:amd64 (2015.11.02-1~webupd8~wily1, 2015.11.10-1~webupd8~wily1), wpasupplicant:amd64 (2.4-0ubuntu3, 2.4-0ubuntu3.2), linux-libc-dev:amd64 (4.2.0-17.21, 4.2.0-18.22)
End-Date: 2015-11-11 07:42:29

DKMS indicates that modules are being built for the corresponding kernel header version installed:
$ dkms status
bbswitch, 0.7, 4.2.0-16-generic, x86_64: installed
bbswitch, 0.7, 4.2.0-17-generic, x86_64: installed
bbswitch, 0.7, 4.2.0-18-generic, x86_64: installed
nvidia-352, 352.41, 4.2.0-16-generic, x86_64: installed
nvidia-352, 352.41, 4.2.0-17-generic, x86_64: installed
nvidia-352, 352.41, 4.2.0-18-generic, x86_64: installed
virtualbox, 5.0.4, 4.2.0-16-generic, x86_64: installed
virtualbox, 5.0.4, 4.2.0-17-generic, x86_64: installed
virtualbox, 5.0.4, 4.2.0-18-generic, x86_64: installed

I have not held back any packages:
$ dpkg --get-selections | egrep -v "\<install\>"
libcuda1-304 deinstall
nvidia-304 deinstall
nvidia-opencl-icd-304 deinstall
thermald deinstall

Why isn't the kernel itself being updated?

Kiind regards,

Question information

English Edit question
Ubuntu linux-lts-wily Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Is your hardware working OK with the current kernel?

Revision history for this message
Manfred Hampl (m-hampl) said :

Maybe you are missing the meta package that cares for installing the newest kernel version

What is the output of the commands

dpkg -l | grep ' linux-'
apt-get --simulate install linux-generic

Revision history for this message
Anthony Kamau (ak-launchpad) said :

Yes, the system is running fine but wondering what I could missing out on - :(!

@Manfred Hampl:
As requested:

$ dpkg -l | grep ' linux-'
ii ladspa-sdk 1.13-2 amd64 sample tools for linux-audio-dev plugin architecture
ii linux-firmware 1.149.1 all Firmware for Linux kernel drivers
ii linux-headers-4.2.0-16 4.2.0-16.19 all Header files related to Linux kernel version 4.2.0
ii linux-headers-4.2.0-16-generic 4.2.0-16.19 amd64 Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii linux-headers-4.2.0-18 4.2.0-18.22 all Header files related to Linux kernel version 4.2.0
ii linux-headers-4.2.0-18-generic 4.2.0-18.22 amd64 Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii linux-headers-generic amd64 Generic Linux kernel headers
ii linux-image-4.2.0-16-generic 4.2.0-16.19 amd64 Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii linux-image-extra-4.2.0-16-generic 4.2.0-16.19 amd64 Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii linux-libc-dev:amd64 4.2.0-18.22 amd64 Linux Kernel Headers for development
ii linux-sound-base 1.0.25+dfsg-0ubuntu5 all base package for ALSA and OSS sound systems

$ apt-get --simulate install linux-generic
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgsoap7 libvncserver1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  linux-image-4.2.0-18-generic linux-image-extra-4.2.0-18-generic linux-image-generic thermald
Suggested packages:
  fdutils linux-doc-4.2.0 linux-source-4.2.0 linux-tools
The following NEW packages will be installed:
  linux-generic linux-image-4.2.0-18-generic linux-image-extra-4.2.0-18-generic linux-image-generic thermald
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-4.2.0-18-generic (4.2.0-18.22 Ubuntu:15.10/wily-updates [amd64])
Inst linux-image-extra-4.2.0-18-generic (4.2.0-18.22 Ubuntu:15.10/wily-updates [amd64])
Inst linux-image-generic ( Ubuntu:15.10/wily-updates [amd64])
Inst linux-generic ( Ubuntu:15.10/wily-updates [amd64])
Inst thermald (1.4.3-5 Ubuntu:15.10/wily [amd64])
Conf linux-image-4.2.0-18-generic (4.2.0-18.22 Ubuntu:15.10/wily-updates [amd64])
Conf linux-image-extra-4.2.0-18-generic (4.2.0-18.22 Ubuntu:15.10/wily-updates [amd64])
Conf linux-image-generic ( Ubuntu:15.10/wily-updates [amd64])
Conf linux-generic ( Ubuntu:15.10/wily-updates [amd64])
Conf thermald (1.4.3-5 Ubuntu:15.10/wily [amd64])


Revision history for this message
Anthony Kamau (ak-launchpad) said :

That's awful formatting - tried using <pre>...</pre> but that did nothing as seen here!

Maybe better to post at and provide link here - no/yes?


Revision history for this message
Best Manfred Hampl (m-hampl) said :

(We are used to read bad-formatted output.)

My assumption seems to be confirmed:

You have the meta-package linux-headers-generic installed, but not linux-image-generic. This is why you get new header files installed, but not the new kernels.

sudo apt-get install linux-generic

should solve the problem.

(One word of caution: If you let the system automatically install new kernels, you have to do regular housekeeping to limit the number of installed kernel versions to avoid running out of space. This is especially true if you have a separate /boot partition.))

Revision history for this message
Anthony Kamau (ak-launchpad) said :

Thanks for explanation, Manfred.

However, this is a fresh install of Ubuntu 15.10 and barring all the heartache in getting the Nvidia drivers to drive my optimus enabled laptop, I've not changed a thing directly to do with the kernel.

So, if it's just me having this issue, then I've obviously done something inadvertently while sorting out optimus issues; I'd really like to know what but being that you've provided a viable option, I'll take the road most travelled.

Thanks again,

Revision history for this message
Anthony Kamau (ak-launchpad) said :

I've just gone through the 2 apt history files and there's no mention of linux-image-generic, only linux-generic. I now wonder if I'm really the only one having this issue!

Revision history for this message
Anthony Kamau (ak-launchpad) said :

Thanks Manfred Hampl, that solved my question.