ACPI conflict causes complete freeze (13.10)

Asked by peter smout on 2014-01-09

Hi,
I have been experiencing frequent system freezes (complete lock-out from mouse, keyboard even <sysrq> R,E,I,S,U,B doesnt work)
this only occurs if I leave a window open, if I close and exit all progs prior to shutting the lid of laptop this does not happen!
In /var/log/syslog I get:

Jan 9 18:50:01 petes-lappy kernel: [ 0.180146] ACPI: (supports S0 S3 S4 S5)
Jan 9 18:50:01 petes-lappy kernel: [ 0.180149] ACPI: Using IOAPIC for interrupt routing
Jan 9 18:50:01 petes-lappy kernel: [ 0.180183] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
Jan 9 18:50:01 petes-lappy kernel: [ 0.180387] ACPI: No dock devices found.
Jan 9 18:50:01 petes-lappy kernel: [ 0.298476] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
Jan 9 18:50:01 petes-lappy kernel: [ 0.298488] ACPI BIOS Error (bug): \_SB_.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20130517/nsarguments-189)
Jan 9 18:50:01 petes-lappy kernel: [ 0.298573] \_SB_.PCI0:_OSC evaluation returned wrong type
Jan 9 18:50:01 petes-lappy kernel: [ 0.298576] _OSC request data:1 8 0
Jan 9 18:50:01 petes-lappy kernel: [ 0.298587] ACPI BIOS Error (bug): \_SB_.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20130517/nsarguments-189)
Jan 9 18:50:01 petes-lappy kernel: [ 0.298665] \_SB_.PCI0:_OSC evaluation returned wrong type
Jan 9 18:50:01 petes-lappy kernel: [ 0.298668] _OSC request data:1 1f 0
Jan 9 18:50:01 petes-lappy kernel: [ 0.298675] acpi PNP0A08:00: ACPI _OSC support notification failed, disabling PCIe ASPM
Jan 9 18:50:01 petes-lappy kernel: [ 0.298679] acpi PNP0A08:00: Unable to request _OSC control (_OSC support mask: 0x08)
Jan 9 18:50:01 petes-lappy kernel: [ 0.299464] acpi PNP0A08:00: host bridge window [io 0x0000-0x0cf7] (ignored)
Jan 9 18:50:01 petes-lappy kernel: [ 0.299469] acpi PNP0A08:00: host bridge window [io 0x0d00-0xffff] (ignored)
Jan 9 18:50:01 petes-lappy kernel: [ 0.299473] acpi PNP0A08:00: host bridge window [mem 0x000a0000-0x000bffff] (ignored)
Jan 9 18:50:01 petes-lappy kernel: [ 0.299478] acpi PNP0A08:00: host bridge window [mem 0xc0000000-0xfebfffff] (ignored)
Jan 9 18:50:01 petes-lappy kernel: [ 0.299481] PCI: root bus 00: using default resources
Jan 9 18:50:01 petes-lappy kernel: [ 0.299665] PCI host bridge to bus 0000:00
Jan 9 18:50:01 petes-lappy kernel: [ 0.299670] pci_bus 0000:00: root bus resource [bus 00-ff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.299674] pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.299677] pci_bus 0000:00: root bus resource [mem 0x00000000-0xfffffffff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.299693] pci 0000:00:00.0: [8086:2a00] type 00 class 0x060000
Jan 9 18:50:01 petes-lappy kernel: [ 0.299851] pci 0000:00:02.0: [8086:2a02] type 00 class 0x030000
Jan 9 18:50:01 petes-lappy kernel: [ 0.299872] pci 0000:00:02.0: reg 0x10: [mem 0xd4000000-0xd40fffff 64bit]
Jan 9 18:50:01 petes-lappy kernel: [ 0.299885] pci 0000:00:02.0: reg 0x18: [mem 0xc0000000-0xcfffffff 64bit pref]
Jan 9 18:50:01 petes-lappy kernel: [ 0.299894] pci 0000:00:02.0: reg 0x20: [io 0x5110-0x5117]
Jan 9 18:50:01 petes-lappy kernel: [ 0.300047] pci 0000:00:02.1: [8086:2a03] type 00 class 0x038000
Jan 9 18:50:01 petes-lappy kernel: [ 0.300065] pci 0000:00:02.1: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
Jan 9 18:50:01 petes-lappy kernel: [ 0.300267] pci 0000:00:1a.0: [8086:2834] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.300335] pci 0000:00:1a.0: reg 0x20: [io 0x50c0-0x50df]
Jan 9 18:50:01 petes-lappy kernel: [ 0.300465] pci 0000:00:1a.0: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.300520] pci 0000:00:1a.1: [8086:2835] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.300589] pci 0000:00:1a.1: reg 0x20: [io 0x50a0-0x50bf]
Jan 9 18:50:01 petes-lappy kernel: [ 0.300716] pci 0000:00:1a.1: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.300788] pci 0000:00:1a.7: [8086:283a] type 00 class 0x0c0320
Jan 9 18:50:01 petes-lappy kernel: [ 0.300818] pci 0000:00:1a.7: reg 0x10: [mem 0xd8404c00-0xd8404fff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.300947] pci 0000:00:1a.7: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301030] pci 0000:00:1a.7: System wakeup disabled by ACPI
 Jan 9 18:50:01 petes-lappy kernel: [ 0.300947] pci 0000:00:1a.7: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301030] pci 0000:00:1a.7: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.301099] pci 0000:00:1b.0: [8086:284b] type 00 class 0x040300
Jan 9 18:50:01 petes-lappy kernel: [ 0.301127] pci 0000:00:1b.0: reg 0x10: [mem 0xd8400000-0xd8403fff 64bit]
Jan 9 18:50:01 petes-lappy kernel: [ 0.301251] pci 0000:00:1b.0: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301335] pci 0000:00:1b.0: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.301393] pci 0000:00:1c.0: [8086:283f] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.301525] pci 0000:00:1c.0: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301664] pci 0000:00:1c.1: [8086:2841] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.301795] pci 0000:00:1c.1: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301932] pci 0000:00:1c.2: [8086:2843] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.302062] pci 0000:00:1c.2: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.302149] pci 0000:00:1c.2: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302208] pci 0000:00:1c.3: [8086:2845] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.302338] pci 0000:00:1c.3: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.302481] pci 0000:00:1d.0: [8086:2830] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.302550] pci 0000:00:1d.0: reg 0x20: [io 0x5080-0x509f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.302677] pci 0000:00:1d.0: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302731] pci 0000:00:1d.1: [8086:2831] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.302798] pci 0000:00:1d.1: reg 0x20: [io 0x5060-0x507f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.302926] pci 0000:00:1d.1: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302979] pci 0000:00:1d.2: [8086:2832] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.303048] pci 0000:00:1d.2: reg 0x20: [io 0x5040-0x505f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.303175] pci 0000:00:1d.2: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.303245] pci 0000:00:1d.7: [8086:2836] type 00 class 0x0c0320
Jan 9 18:50:01 petes-lappy kernel: [ 0.303276] pci 0000:00:1d.7: reg 0x10: [mem 0xd8404800-0xd8404bff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.303404] pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.303482] pci 0000:00:1d.7: System wakeup disabled by ACPIJan 9 18:50:01 petes-lappy kernel: [ 0.300947] pci 0000:00:1a.7: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301030] pci 0000:00:1a.7: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.301099] pci 0000:00:1b.0: [8086:284b] type 00 class 0x040300
Jan 9 18:50:01 petes-lappy kernel: [ 0.301127] pci 0000:00:1b.0: reg 0x10: [mem 0xd8400000-0xd8403fff 64bit]
Jan 9 18:50:01 petes-lappy kernel: [ 0.301251] pci 0000:00:1b.0: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301335] pci 0000:00:1b.0: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.301393] pci 0000:00:1c.0: [8086:283f] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.301525] pci 0000:00:1c.0: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301664] pci 0000:00:1c.1: [8086:2841] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.301795] pci 0000:00:1c.1: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.301932] pci 0000:00:1c.2: [8086:2843] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.302062] pci 0000:00:1c.2: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.302149] pci 0000:00:1c.2: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302208] pci 0000:00:1c.3: [8086:2845] type 01 class 0x060400
Jan 9 18:50:01 petes-lappy kernel: [ 0.302338] pci 0000:00:1c.3: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.302481] pci 0000:00:1d.0: [8086:2830] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.302550] pci 0000:00:1d.0: reg 0x20: [io 0x5080-0x509f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.302677] pci 0000:00:1d.0: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302731] pci 0000:00:1d.1: [8086:2831] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.302798] pci 0000:00:1d.1: reg 0x20: [io 0x5060-0x507f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.302926] pci 0000:00:1d.1: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.302979] pci 0000:00:1d.2: [8086:2832] type 00 class 0x0c0300
Jan 9 18:50:01 petes-lappy kernel: [ 0.303048] pci 0000:00:1d.2: reg 0x20: [io 0x5040-0x505f]
Jan 9 18:50:01 petes-lappy kernel: [ 0.303175] pci 0000:00:1d.2: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.303245] pci 0000:00:1d.7: [8086:2836] type 00 class 0x0c0320
Jan 9 18:50:01 petes-lappy kernel: [ 0.303276] pci 0000:00:1d.7: reg 0x10: [mem 0xd8404800-0xd8404bff]
Jan 9 18:50:01 petes-lappy kernel: [ 0.303404] pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
Jan 9 18:50:01 petes-lappy kernel: [ 0.303482] pci 0000:00:1d.7: System wakeup disabled by ACPI
Jan 9 18:50:01 petes-lappy kernel: [ 0.303548] pci 0000:00:1e.0: [8086:2448] type 01 class 0x060401
Jan 9 18:50:01 petes-lappy kernel: [ 0.303755] pci 0000:00:1f.0: [8086:2815] type 00 class 0x060100
Jan 9 18:50:01 petes-lappy kernel: [ 0.303887] pci 0000:00:1f.0: address space collision: [io 0x0400-0x047f] conflicts with ACPI CPU throttle [??? 0x00000410-0x00000415 flags 0x80000000]

Which leads me to belive that ACPI is disabling System wake up due to a conflict!

Please advise on how to prevent this or if further info is needed

Thanks

Peter Smout

Jan 9 18:50:01 petes-lappy kernel: [ 0.303548] pci 0000:00:1e.0: [8086:2448] type 01 class 0x060401
Jan 9 18:50:01 petes-lappy kernel: [ 0.303755] pci 0000:00:1f.0: [8086:2815] type 00 class 0x060100
Jan 9 18:50:01 petes-lappy kernel: [ 0.303887] pci 0000:00:1f.0: address space collision: [io 0x0400-0x047f] conflicts with ACPI CPU throttle [??? 0x00000410-0x00000415 flags 0x80000000]

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-lowlatency Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2014-01-23
Last query:
2014-01-23
Last reply:
2014-01-17

I suggest you run Memtest86+ from Grub. See if your RAM is ok.

peter smout (psmouty) said : #2

thanks for the reply will leave memtest running overnight and report back

peter smout (psmouty) said : #3

Hi,

I've left memtes86+ running until complete with 0 errors! So that rules out mem issue!

Do you have the latest BIOS if the system uses one?

peter smout (psmouty) said : #5

latest dont know, it was updated about feb last year (2013) old machine now so i doubt any more BIOS updates

peter smout (psmouty) said : #6

Can confirm ive got the latest available BIOS for the machine, Had to re-install windoze 7 onto old HDD to run the BIOS check program..... what a pain!!

Still getting freezes with the same error:

ACPI BIOS Error (bug): \_SB_.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4

Best Manfred Hampl (m-hampl) said : #7

A potential workaround might be trying the boot parameter acpi=off
https://help.ubuntu.com/community/BootOptions

peter smout (psmouty) said : #8

Thanks for the link, it sort of worked!

I have not had a system freeze since I used the info in the link, but after using boot-repair I had to purge and reinstall grub (it sent my resolution all wrong, making the GUI look really ugly!)

I will report back here if I experience the same problem, but for now ill mark as solved as it has not happened since!

peter smout (psmouty) said : #9

Thanks Manfred Hampl, that solved my question.