ath10k wifi low bandwich after upgrade Ubuntu to 19.10

Asked by Bernard on 2019-11-08

Hi,
I have an issue with low wifi bandwidth (max 3 Mbs) after upgrade from Ubuntu 19.04 to 19.10. I use mpcie Compex WLE900VX (atheros QCA9880) in AP mode (Ubuntu server x64 machine). My AP works in 2,4 GHZ/N band.
Before upgrade I had 20~25Mbs.
dmesg shows me:
[ 7.653739] ath10k_pci 0000:04:00.0: enabling device (0000 -> 0002)
[ 7.654099] ath10k_pci 0000:04:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 7.870406] ath10k_pci 0000:04:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 7.870408] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 7.870604] ath10k_pci 0000:04:00.0: firmware ver 10.2.4-1.0-00045 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 ccbd5104
[ 7.903827] ath10k_pci 0000:04:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 9.021020] ath10k_pci 0000:04:00.0: UART prints enabled
[ 9.076034] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 9.324102] ath10k_pci 0000:04:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[ 9.441662] ath: EEPROM regdomain: 0x0
[ 9.441663] ath: EEPROM indicates default country code should be used
[ 9.441664] ath: doing EEPROM country->regdmn map search
[ 9.441665] ath: country maps to regdmn code: 0x3a
[ 9.441665] ath: Country alpha2 being used: US
[ 9.441666] ath: Regpair used: 0x3a
[ 9.457577] ath10k_pci 0000:04:00.0 wlp4s0: renamed from wlan0
[ 10.759645] ath10k_pci 0000:04:00.0: UART prints enabled
[ 10.827668] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 11.075795] ath10k_pci 0000:04:00.0: pdev param 0 not supported by firmware
[ 13.156219] ath10k_pci 0000:04:00.0: UART prints enabled
[ 13.224285] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 13.509785] ath10k_pci 0000:04:00.0: pdev param 0 not supported by firmware
[ 13.761722] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 13.765796] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 13.911832] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 13.915880] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.061887] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.211931] ath10k_warn: 1 callbacks suppressed
[ 14.211937] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.215941] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.361987] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.365992] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.512042] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.516053] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.662095] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.666088] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.812136] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.816139] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
Is there any way to fix this? Could I do it by myself (e.g changing configuration) or I should wait for kernel/firmware update.
Anyway temporary I changed mpcie card to AR9380 (ath9k).

My current system:
ela@akacja:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 06
       serial: 50:3e:aa:04:5a:62
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=10.10.10.1 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:23 ioport:d000(size=256) memory:a1404000-a1404fff memory:a1400000-a1403fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 0c
       serial: 70:85:c2:f7:da:ab
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168g-2_0.0.1 02/06/13 ip=192.168.15.244 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:20 ioport:c000(size=256) memory:a1304000-a1304fff memory:a1300000-a1303fff
  *-network
       description: Wireless interface
       product: QCA986x/988x 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 00
       serial: b4:82:c5:60:69:d0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=5.3.0-19-generic firmware=10.2.4-1.0-00045 ip=10.10.11.1 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:133 memory:a1000000-a11fffff memory:a1200000-a120ffff
ela@akacja:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan
ela@akacja:~$ uname -a
Linux akacja 5.3.0-19-generic #20-Ubuntu SMP Fri Oct 18 09:04:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-12
Last reply:
2019-11-12

What is the output of:

sudo lshw -C network; lsb_release -a; uname -a

Thanks

Try:

echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k_fix.conf > /dev/null

Reboot to test

If it is no good then run:

sudo rm /etc/modprobe.d/ath10k_fix.conf

Then reboot to revert the chnage.

Bernard (bern1) said : #3

Unfortunately I haven't got 'ath10k_fix.conf' file in the /etc/modprobe.d directory:
ela@akacja:~$ cd /etc/modprobe.d
ela@akacja:/etc/modprobe.d$ ls -h
amd64-microcode-blacklist.conf blacklist.conf blacklist-framebuffer.conf intel-microcode-blacklist.conf mdadm.conf
blacklist-ath_pci.conf blacklist-firewire.conf blacklist-rare-network.conf iwlwifi.conf

I know...... The command creates the file......

Bernard (bern1) said : #5

Sorry. I didn't looked carefully at the command.
After adding this new file with "options ath10k_core skip_otp=y" nothing has changed. There is still low bandwidth and the same massages in the dmesg.

OK I assume you removed the file and rebooted. If you then run:

sudo modprobe -rfv ath10k_pci
sudo modprobe -v ath10k_pci nohwcrypt=1

Does this help? If so, we can make this stick

Bernard (bern1) said : #7

After applying these two command the wifi network dosn't work.

ela@akacja:~$ sudo modprobe -rfv ath10k_pci
rmmod ath10k_pci
rmmod ath10k_core
rmmod mac80211
rmmod libarc4
rmmod ath
rmmod cfg80211
ela@akacja:~$ sudo modprobe -v ath10k_pci nohwcrypt=1
insmod /lib/modules/5.3.0-19-generic/kernel/lib/crypto/libarc4.ko
insmod /lib/modules/5.3.0-19-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/5.3.0-19-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/5.3.0-19-generic/kernel/drivers/net/wireless/ath/ath.ko
insmod /lib/modules/5.3.0-19-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko
insmod /lib/modules/5.3.0-19-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko nohwcrypt=1
ela@akacja:~$ sudo dmesg | grep ath
[ 7.630574] ath10k_pci 0000:04:00.0: enabling device (0000 -> 0002)
[ 7.630953] ath10k_pci 0000:04:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 7.797965] ath10k_pci 0000:04:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 7.797968] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 7.798192] ath10k_pci 0000:04:00.0: firmware ver 10.2.4-1.0-00045 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 ccbd5104
[ 7.831128] ath10k_pci 0000:04:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 8.947558] ath10k_pci 0000:04:00.0: UART prints enabled
[ 9.002591] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 9.250642] ath10k_pci 0000:04:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[ 9.366644] ath: EEPROM regdomain: 0x0
[ 9.366646] ath: EEPROM indicates default country code should be used
[ 9.366646] ath: doing EEPROM country->regdmn map search
[ 9.366647] ath: country maps to regdmn code: 0x3a
[ 9.366648] ath: Country alpha2 being used: US
[ 9.366649] ath: Regpair used: 0x3a
[ 9.373569] ath10k_pci 0000:04:00.0 wlp4s0: renamed from wlan0
[ 10.676558] ath10k_pci 0000:04:00.0: UART prints enabled
[ 10.745211] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 10.993322] ath10k_pci 0000:04:00.0: pdev param 0 not supported by firmware
[ 13.540511] ath10k_pci 0000:04:00.0: UART prints enabled
[ 13.608498] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 13.894536] ath10k_pci 0000:04:00.0: pdev param 0 not supported by firmware
[ 14.146094] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.150220] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.296202] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.300214] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.446255] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.450253] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.596306] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.600312] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.746389] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 14.750353] ath10k_pci 0000:04:00.0: failed to parse chan info event: -71
[ 345.450352] ath10k_warn: 13 callbacks suppressed
[ 345.450374] ath10k_pci 0000:04:00.0: could not get mac80211 beacon
[ 345.544597] ath10k_pci 0000:04:00.0: could not get mac80211 beacon
[ 360.656378] ath10k_pci: unknown parameter 'nohwcrypt' ignored
[ 360.657098] ath10k_pci 0000:04:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 360.817120] ath10k_pci 0000:04:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 360.817123] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 360.817346] ath10k_pci 0000:04:00.0: firmware ver 10.2.4-1.0-00045 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 ccbd5104
[ 360.858098] ath10k_pci 0000:04:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 362.040728] ath10k_pci 0000:04:00.0: UART prints enabled
[ 362.108898] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 362.357018] ath10k_pci 0000:04:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[ 362.474896] ath: EEPROM regdomain: 0x0
[ 362.474899] ath: EEPROM indicates default country code should be used
[ 362.474899] ath: doing EEPROM country->regdmn map search
[ 362.474900] ath: country maps to regdmn code: 0x3a
[ 362.474901] ath: Country alpha2 being used: US
[ 362.474902] ath: Regpair used: 0x3a
[ 362.479452] ath10k_pci 0000:04:00.0 wlp4s0: renamed from wlan0
[ 363.791726] ath10k_pci 0000:04:00.0: UART prints enabled
[ 363.859921] ath10k_pci 0000:04:00.0: unsupported HTC service id: 1536
[ 364.145488] ath10k_pci 0000:04:00.0: pdev param 0 not supported by firmware

Is it now OK?

Bernard (bern1) said : #9

As I wrote applying these two commands cause wifi net stop. Unfortunately after reboot the situation is the same = low bandwidth.

After the reboot the configuration reverts back because none of the settings we are changing are permanent yet.

Bernard (bern1) said : #11

What else can I check to diagnose/fix the issue?

bernard stafford (bernard010) said : #14

Did you check the software updater for additional drivers? Some times the needed driver upgrade will show up here for installation (If there are any additional drivers available).

bernard stafford (bernard010) said : #15

This may help Troubleshoot the wireless problem: Doctumentation for Ubuntu.
     https://help.ubuntu.com/stable/ubuntu-help/net-wireless-troubleshooting-hardware-check.html
Hope this is some help.

Could also reboot your router. It is a computer after all and can help

Bernard (bern1) said : #17

Yes I update the system frequently.
In fact my Ubuntu server 19.10 is a router/firewall and reboot from time to time.
I have tree network interfaces (see the first Post):
WAN
LAN
WLAN

Only on WLAN I have an issue with new UBUNTU (low bandwidth with ath10k). When I switch to 'old' atheros mpcie card (ath9k) everything is OK.
see my hostapd.conf:

driver=nl80211
######################### basic hostapd configuration ##########################
#
interface=wlp4s0
country_code=XX
ieee80211d=1
ieee80211h=1
channel=1
hw_mode=g
ieee80211n=1
wmm_enabled=1
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]
logger_syslog=-1
logger_syslog_level=0
logger_stdout=-1
logger_stdout_level=4
auth_algs=1
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=XXXXX
ignore_broadcast_ssid=0
######################### wpa hostapd configuration ############################
#
wpa=3
wpa_passphrase=XXXXXXX
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

Can you help with this problem?

Provide an answer of your own, or ask Bernard for more information if necessary.

To post a message you must log in.