DELL Precision M4800 I have Instructions how to get linux-firmware for bluetooth chip.

Asked by Roland Schwarz on 2017-11-20

dmesg | grep blue shows error that BCM20702A1-413c-8143.hcd is not loaded.
The following procedure restores operation of bluetooth:

Download

M6800_M4800_A05.fish.tar.gz

from
http://www.dell.com/support/home/at/de/atbsdt1/product-support/product/precision-m4800-workstation/drivers

extract:
bt-dw1550-firmware_0.1_all.deb

and from there extract /lib/firmware/fw-413c_8143.hcd

mv the file to
/lib/firmware/brcm/BCM20702A1-413c-8143.hcd

Reboot

I hope the file will make it to the linux-firmware driver package.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-20
Last reply:
2017-11-20

If you run:

ubuntu-bug linux-firmware

It will start the process.

Thank you for having answerded but: Sorry, I proceeded as suggested, but I ended on an empty page, without any prompts to input information. If you carefully read my question you will find that I already posted the solution to my problem. In lack of having found an option to just report the solution I chose to post it at a question.

Hmm, if you need a question: How shall I proceed to post the solution to a problem I had? A solution that I would like see to be fixed upstream.

Usually it opens a bug report.

You can use Launchpad directly to report an issue.

Ok, I just plain do not understand the whole process. So I tried to help, but obviously either no one cares, or I am a complete idiot. What shall I do with "the" Launchpad? Will I need to go through tons of documentation to be "allowed" to share my findings?

The bluetooth firmware files are in package linux-firmware, so I went to linux-firmware and reported what I found.

So if no one here cares, I won't either.

Bye.

(I will not close the issue, since I see the problem not solved for any user of a Dell Precision M4800, and I guess similar models. It just works for me.)

How do you figure "no one cares" when I replied to you an hour ago?
How can you intelligently come to that conclusion?
It's absolute nonsense.

Can you help with this problem?

Provide an answer of your own, or ask Roland Schwarz for more information if necessary.

To post a message you must log in.