Bluetooth not working on Asus X751LA

Asked by Luca Manunta on 2014-11-08

I'm running a fresh install of Ubuntu 14.04.
The Notebook is equipped with a Qualcomm Atheros, the wifi is working fine, while the bluetooth does not find any device, and does not send any signal, although the icon on the panel is active.

Below are the dump of relevant commands:

$ lspci -v
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
 Subsystem: AzureWave Device 2130
 Flags: bus master, fast devsel, latency 0, IRQ 19
 Memory at f7c00000 (64-bit, non-prefetchable) [size=512K]
 Expansion ROM at f7c80000 [disabled] [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: ath9k

$ lsb_release -a; uname -a; dmesg | grep -i blue
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
Linux bojanasus 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[ 14.134991] Bluetooth: Core ver 2.17
[ 14.135014] Bluetooth: HCI device and connection manager initialized
[ 14.135938] Bluetooth: HCI socket layer initialized
[ 14.135942] Bluetooth: L2CAP socket layer initialized
[ 14.135947] Bluetooth: SCO socket layer initialized
[ 18.778828] Bluetooth: RFCOMM TTY layer initialized
[ 18.778839] Bluetooth: RFCOMM socket layer initialized
[ 18.778843] Bluetooth: RFCOMM ver 1.11
[ 18.844005] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 18.844008] Bluetooth: BNEP filters: protocol multicast
[ 18.844017] Bluetooth: BNEP socket layer initialized
[ 72.616337] Bluetooth: hci0 command 0x0401 tx timeout

$ grep [[:alnum:]] /sys/module/ath*/parameters/*/sys/module/ath9k/parameters/blink:0
/sys/module/ath9k/parameters/bt_ant_diversity:0
/sys/module/ath9k/parameters/btcoex_enable:0
/sys/module/ath9k/parameters/nohwcrypt:0
/sys/module/ath9k/parameters/ps_enable:0

Any help would really be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Last query:
2014-11-10
Last reply:
2015-04-14

What is the output of :

sudo rfkill list; sudo hcitool dev; cat /etc/issue

Thanks

Luca Manunta (manunta) said : #3

It's me thanking you!
Here they are:

$ sudo rfkill list
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
3: asus-bluetooth: Bluetooth
 Soft blocked: yes
 Hard blocked: no

$ sudo hcitool dev
Devices:

$ cat /etc/issue
Ubuntu 14.04.1 LTS \n \l

Luca Manunta (manunta) said : #4

Ops, of course, since I wasn't using it, I had switched off the bluetooth. I switched it on and repeated the rfkill and hcitools commands:

$ sudo rfkill list
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
3: asus-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
4: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

$ sudo hcitool dev
Devices:
 hci0 54:27:1E:51:63:DE

Ok great. Set a device to discoverable and run:

sudo hcitool scan

Is it found?

Luca Manunta (manunta) said : #6

Nope, I tried with my phone and with a bluetooth mouse, to no avail.
Moreover, although the notebook's bluetooth is set as visible (on the icon in the panel), nothing is detected by the phone (which instead can see the mouse).

Install blueman and try that

Luca Manunta (manunta) said : #8

Ok, done. I installed blueman, and tried to search devices with bluewho, bluetooth manager, bluetooth assistant, with no positive result. Bluewho is able to find the local device, and provides the same macaddress as hcitool dev.

Luca Manunta (manunta) said : #9

Following the request I received with regards to Bug #1390857 I updated the system BIOS to the latest available version.
However the behaviour of the bluetooth did not change, I still cannot detect any device with any of the available softwares.

Jeremy (wa113y3s) said : #10

This should be fixed in the latest utopic kernel from what I have seen in the source code

Can you help with this problem?

Provide an answer of your own, or ask Luca Manunta for more information if necessary.

To post a message you must log in.