Bluetooth is not working in Acer Aspire E1-432

Asked by Dinh Quoc Han on 2014-09-27

I got a new Acer Aspire E1-432 laptop with preinstalled Ubuntu 14.04,
the Bluetooth is not working.
Qualcomm Atheros is the chipset in the laptop which supports both wifi and bluetooth.
Wifi is working but bluetooth is not even recognized in the system.

dinhquochan@TiLovePo-PC:~$ lsusb | grep Bluetooth
dinhquochan@TiLovePo-PC:~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 04ca:300b Lite-On Technology Corp.
Bus 002 Device 003: ID 1bcf:2c17 Sunplus Innovation Technology Inc.
Bus 002 Device 002: ID 0458:0152 KYE Systems Corp. (Mouse Systems)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Need help to solve this. Thank you !

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-09-28
Last query:
2014-09-28
Last reply:
2014-09-27

This question was reopened

What is the output of:

sudo hcitool dev; lsb_release -a; dmesg | grep -i blue

Thanks

Devices:
 hci0 A4:DB:30:CA:D8:50
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
[ 10.159667] Bluetooth: Core ver 2.17
[ 10.159689] Bluetooth: HCI device and connection manager initialized
[ 10.159697] Bluetooth: HCI socket layer initialized
[ 10.159700] Bluetooth: L2CAP socket layer initialized
[ 10.159705] Bluetooth: SCO socket layer initialized
[ 13.897795] Bluetooth: RFCOMM TTY layer initialized
[ 13.897809] Bluetooth: RFCOMM socket layer initialized
[ 13.897856] Bluetooth: RFCOMM ver 1.11
[ 13.917356] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 13.917375] Bluetooth: BNEP filters: protocol multicast
[ 13.917424] Bluetooth: BNEP socket layer initialized

Looks like its working fully. If you set a device to discoverable then run:

sudo hcitool scan

Do the device get detected?

Not detected. i used to fedora gnome 3.12 it's working. But now i used ubuntu it not find my device

I suggest you report a bug

Thanks actionparsnip, that solved my question.

Can you help me how to report that?

You can start the process with:

ubuntu-bug bluetooth

You may also want to try the 3.17 kernel from the kernel PPA after you report the issue

Thank you very much.