Bluetooth is not working in Dell inspiron 3437

Asked by Swamy on 2014-01-02

I got a new Dell Inspiron 3437 laptop with preinstalled Ubuntu 12.04,
the Bluetooth is not working.
"Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)" is the chipset in the laptop which supports both wifi and bluetooth.
Wifi is working but bluetooth is not even recognized in the system.

swamydkv@swamydkv-Inspiron-3437:~$ lsusb | grep Bluetooth
swamydkv@swamydkv-Inspiron-3437:~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 002: ID 0cf3:0036 Atheros Communications, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0c45:64af Microdia
swamydkv@swamydkv-Inspiron-3437:~$

Need help to solve this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2014-01-02
Last query:
2014-01-02
Last reply:
2014-01-02

What is the output of:

lsb_release -a; uname -a; dmesg | grep -i blue

Thanks

Swamy (swamydkv) said : #2

The output is

swamydkv@swamydkv-Inspiron-3437:~$ lsb_release -a; uname -a; dmesg | grep -i blue
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
Linux swamydkv-Inspiron-3437 3.5.0-44-generic #67~precise1-Ubuntu SMP Wed Nov 13 16:16:57 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[ 10.778541] Bluetooth: Core ver 2.16
[ 10.778564] Bluetooth: HCI device and connection manager initialized
[ 10.778566] Bluetooth: HCI socket layer initialized
[ 10.778568] Bluetooth: L2CAP socket layer initialized
[ 10.778572] Bluetooth: SCO socket layer initialized
[ 12.644951] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 12.644955] Bluetooth: BNEP filters: protocol multicast
[ 12.687673] Bluetooth: RFCOMM TTY layer initialized
[ 12.687679] Bluetooth: RFCOMM socket layer initialized
[ 12.687681] Bluetooth: RFCOMM ver 1.11
[ 13.955605] Bluetooth: Error in firmware loading err = -110,len = 448, size = 1906
[ 13.955615] Bluetooth: Loading sysconfig file failed

Try running these commands in a Terminal:

sudo apt-get update

sudo apt-get install linux-firmware

sudo apt-get install dell-dup

sudo apt-get install firmware-addon-dell

sudo apt-get install linux-firmware-nonfree

sudo apt-get install btscanner

Then reboot your PC and retest.

If this does not help, then I suggest upgrading the BIOS of your PC to Dell System BIOS 3437A02 which you can get here:

http://www.dell.com/support/drivers/us/en/19/driverdetails?driverid=0392V

Here are instructions on creating a bootable USB-stick which allows you to boot DOS and perform a BIOS upgrade after booting a USB stick:

http://www.biosflash.com/e/bios-boot-usb-stick.htm

Swamy (swamydkv) said : #6

     *-firmware
          description: BIOS
          vendor: Winbond Electronics
          physical id: 0
          version: A06
          date: 10/28/2013
          size: 64KiB
          capacity: 1984KiB
          capabilities: mca pci upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb zipboot biosbootspecification

The BIOS is the latest in my system.

I don't think that is a reliable way to check if you have the newest BIOS version.

I suggest booting into the BIOS and checking the release version and release date in the BIOS itself.

The BIOS should show the following release date, if it is the newest version:

Release Date: 11/21/2013

October 28 is not the same as November 21....

Did you execute the steps in post #3?

Did post #3 help?

Correction: here is the newest BIOS release for the Inspiron 14 3437 :

Dell inspiron 3437 System BIOS

File Name: 3437A07.EXE

Compatibility
Systems
Inspiron 14 3437
Inspiron 14R 5437

Release Date: 12/3/2013

Download location:

http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=KC0JW&fileId=3325826052

Here are the enhancements in BIOS File Name: 3437A07.EXE

Fixes & Enhancements
Fixes
- Not Applicable.

Enhancements
- Enhance Bluetooth use experience

Swamy (swamydkv) said : #10

I executed the commands from post #3, but didn't help..

I will try BIOS A07

I didn't understand how to make a bootable falsh drive.

And the Bios file is .exe so how can I create a bootable usb using that file.

See post #5

Swamy (swamydkv) said : #12

Thanks Mark Rijckenberg, that solved my question.

Which post solved the issue?

Did the BIOS upgrade to A07 solve the issue?

Or the firmware packages you installed?