dpkg: error processing /var/cache/apt/archives/linux-firmware_1.79.9_all.deb (--unpack): trying to overwrite '/lib/firmware/ar3k/ramps_0x31010000_40.dfu', which is also in package bt-dw1705-firmware 0.1

Asked by Swamy on 2014-01-01

New Dell 3437 preinstalled Ubuntu laptop not working

I got a new Dell 3437 laptop, when ONed the laptop ubuntu started to install intself. But at the end some packages didn't installed properly like "Update Manager". After that I am not able to update or upgrade and the laptop came with 12.04 version. Meanwhile the wireless driver got updated, now I am not able to use Wifi also. I tried to reboot the system and install again, but it is not working or I don't know how to do it.

I checked with Dell Support they are not understanding, the support guy told to install Windows, then they will help, I told I dont't want windows and purposefully taken Ubuntu the guy didn't understand at all.

Now I planned to download a ubuntu 12.04.03 LTS and then install again in the laptop.

What is the suggestion. This is a brand new Laptop bought yesterday only.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu linux-firmware Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2014-01-02
Last query:
2014-01-02
Last reply:
2014-01-02

$ apt-get install git

Swamy (swamydkv) said : #2

why do you want me to install git?

https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

Please post full Terminal output from step 5 and step 9 here:

https://answers.launchpad.net/ubuntu/+question/241521

If you cannot execute steps 1 and 2, please skip those steps and execute steps 3 to 9.

Swamy (swamydkv) said : #4

Step 5 Terminal Output

swamydkv@swamydkv-Inspiron-3437:~$ ubuntu-support-status
Support status summary of 'swamydkv-Inspiron-3437':

You have 8 packages (0.5%) supported until October 2013 (18m)
You have 60 packages (3.9%) supported until June 2015 (18m)
You have 1432 packages (93.2%) supported until April 2017 (5y)
You have 5 packages (0.3%) supported until December 2018 (5y)

You have 19 packages (1.2%) that can not/no-longer be downloaded
You have 12 packages (0.8%) that are unsupported

Run with --show-unsupported, --show-supported or --show-all to see more details

swamydkv@swamydkv-Inspiron-3437:~$ sudo grep -R proxy /etc/apt/*
[sudo] password for swamydkv:
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ grep proxy /etc/environment
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ echo $http_proxy

swamydkv@swamydkv-Inspiron-3437:~$ echo $ftp_proxy

swamydkv@swamydkv-Inspiron-3437:~$ grep proxy /etc/bash.bashrc
swamydkv@swamydkv-Inspiron-3437:~$ grep proxy ~/.bashrc

swamydkv@swamydkv-Inspiron-3437:~$ cat /etc/apt/apt.conf
cat: /etc/apt/apt.conf: No such file or directory

swamydkv@swamydkv-Inspiron-3437:~$ sudo fuser -vvv /var/lib/dpkg/lock
swamydkv@swamydkv-Inspiron-3437:~$ sudo fuser -vvv /var/cache/apt/archives/lock
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.3 LTS"
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ uname -a
Linux swamydkv-Inspiron-3437 3.5.0-44-generic #67~precise1-Ubuntu SMP Wed Nov 13 16:16:57 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

swamydkv@swamydkv-Inspiron-3437:~$ sudo rm /var/lib/apt/lists/lock
swamydkv@swamydkv-Inspiron-3437:~$ sudo rm /var/cache/apt/archives/lock
swamydkv@swamydkv-Inspiron-3437:~$ sudo rm /var/lib/dpkg/lock
swamydkv@swamydkv-Inspiron-3437:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
swamydkv@swamydkv-Inspiron-3437:~$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
swamydkv@swamydkv-Inspiron-3437:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status || sudo cp /var/backups/apt.extended_states.0 /var/lib/dpkg/status
swamydkv@swamydkv-Inspiron-3437:~$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
swamydkv@swamydkv-Inspiron-3437:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
swamydkv@swamydkv-Inspiron-3437:~$ sudo rm -rf /var/lib/dpkg/updates/*
swamydkv@swamydkv-Inspiron-3437:~$ sudo rm -rf /var/lib/apt/lists
swamydkv@swamydkv-Inspiron-3437:~$ sudo rm /var/cache/apt/*.bin
swamydkv@swamydkv-Inspiron-3437:~$ sudo mkdir /var/lib/apt/lists
swamydkv@swamydkv-Inspiron-3437:~$ sudo mkdir /var/lib/apt/lists/partial

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get clean
swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get --fix-missing update -o APT::Cache-Limit=100000000
Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]
Get:3 http://oem.archive.canonical.com precise-oem-sp1 Release.gpg [287 B]
Get:4 http://dell.archive.canonical.com precise-dell Release.gpg [287 B]
Get:5 http://in.archive.ubuntu.com precise Release.gpg [198 B]
Get:6 http://in.archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:7 http://in.archive.ubuntu.com precise-backports Release.gpg [198 B]
Get:8 http://oem.archive.canonical.com precise-oem-sp1 Release [4181 B]
Get:9 http://in.archive.ubuntu.com precise Release [49.6 kB]
Get:10 http://dell.archive.canonical.com precise-dell Release [4238 B]
Get:11 http://security.ubuntu.com precise-security/main Sources [95.0 kB]
Get:12 http://oem.archive.canonical.com precise-oem-sp1/public Sources [14 B]
Get:13 http://dell.archive.canonical.com precise-dell/public Sources [2443 B]
Get:14 http://in.archive.ubuntu.com precise-updates Release [49.6 kB]
Get:15 http://oem.archive.canonical.com precise-oem-sp1/public amd64 Packages [14 B]
Get:16 http://oem.archive.canonical.com precise-oem-sp1/public i386 Packages [14 B]
Get:17 http://dell.archive.canonical.com precise-dell/public amd64 Packages [2947 B]
Get:18 http://dell.archive.canonical.com precise-dell/public i386 Packages [2947 B]
Ign http://oem.archive.canonical.com precise-oem-sp1/public TranslationIndex
Ign http://dell.archive.canonical.com precise-dell/public TranslationIndex
Get:19 http://in.archive.ubuntu.com precise-backports Release [49.6 kB]
Ign http://oem.archive.canonical.com precise-oem-sp1/public Translation-en
Get:20 http://security.ubuntu.com precise-security/restricted Sources [2494 B]
Get:21 http://security.ubuntu.com precise-security/universe Sources [29.9 kB]
Get:22 http://in.archive.ubuntu.com precise/main Sources [934 kB]
Ign http://dell.archive.canonical.com precise-dell/public Translation-en
Get:23 http://security.ubuntu.com precise-security/multiverse Sources [1792 B]
Get:24 http://security.ubuntu.com precise-security/main amd64 Packages [349 kB]
Get:25 http://security.ubuntu.com precise-security/restricted amd64 Packages [4627 B]
Get:26 http://security.ubuntu.com precise-security/universe amd64 Packages [86.5 kB]
Get:27 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2446 B]
Get:28 http://security.ubuntu.com precise-security/main i386 Packages [369 kB]
Get:29 http://security.ubuntu.com precise-security/restricted i386 Packages [4620 B]
Get:30 http://security.ubuntu.com precise-security/universe i386 Packages [90.7 kB]
Get:31 http://security.ubuntu.com precise-security/multiverse i386 Packages [2642 B]
Get:32 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:33 http://security.ubuntu.com precise-security/multiverse TranslationIndex [72 B]
Get:34 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]
Get:35 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Get:36 http://security.ubuntu.com precise-security/main Translation-en [164 kB]
Get:37 http://security.ubuntu.com precise-security/multiverse Translation-en [1299 B]
Get:38 http://security.ubuntu.com precise-security/restricted Translation-en [1253 B]
Get:39 http://security.ubuntu.com precise-security/universe Translation-en [54.8 kB]
Get:40 http://in.archive.ubuntu.com precise/restricted Sources [5470 B]
Get:41 http://in.archive.ubuntu.com precise/universe Sources [5019 kB]
Get:42 http://in.archive.ubuntu.com precise/multiverse Sources [155 kB]
Get:43 http://in.archive.ubuntu.com precise/main amd64 Packages [1273 kB]
Get:44 http://in.archive.ubuntu.com precise/restricted amd64 Packages [8452 B]
Get:45 http://in.archive.ubuntu.com precise/universe amd64 Packages [4786 kB]
Get:46 http://in.archive.ubuntu.com precise/multiverse amd64 Packages [119 kB]
Get:47 http://in.archive.ubuntu.com precise/main i386 Packages [1274 kB]
Get:48 http://in.archive.ubuntu.com precise/restricted i386 Packages [8431 B]
Get:49 http://in.archive.ubuntu.com precise/universe i386 Packages [4796 kB]
Get:50 http://in.archive.ubuntu.com precise/multiverse i386 Packages [121 kB]
Get:51 http://in.archive.ubuntu.com precise/main TranslationIndex [3706 B]
Get:52 http://in.archive.ubuntu.com precise/multiverse TranslationIndex [2676 B]
Get:53 http://in.archive.ubuntu.com precise/restricted TranslationIndex [2596 B]
Get:54 http://in.archive.ubuntu.com precise/universe TranslationIndex [2922 B]
Get:55 http://in.archive.ubuntu.com precise-updates/main Sources [430 kB]
Get:56 http://in.archive.ubuntu.com precise-updates/restricted Sources [7039 B]
Get:57 http://in.archive.ubuntu.com precise-updates/universe Sources [101 kB]
Get:58 http://in.archive.ubuntu.com precise-updates/multiverse Sources [8468 B]
Get:59 http://in.archive.ubuntu.com precise-updates/main amd64 Packages [719 kB]
Get:60 http://in.archive.ubuntu.com precise-updates/restricted amd64 Packages [11.4 kB]
Get:61 http://in.archive.ubuntu.com precise-updates/universe amd64 Packages [226 kB]
Get:62 http://in.archive.ubuntu.com precise-updates/multiverse amd64 Packages [14.2 kB]
Get:63 http://in.archive.ubuntu.com precise-updates/main i386 Packages [741 kB]
Get:64 http://in.archive.ubuntu.com precise-updates/restricted i386 Packages [11.5 kB]
Get:65 http://in.archive.ubuntu.com precise-updates/universe i386 Packages [230 kB]
Get:66 http://in.archive.ubuntu.com precise-updates/multiverse i386 Packages [14.4 kB]
Get:67 http://in.archive.ubuntu.com precise-updates/main TranslationIndex [3564 B]
Get:68 http://in.archive.ubuntu.com precise-updates/multiverse TranslationIndex [2605 B]
Get:69 http://in.archive.ubuntu.com precise-updates/restricted TranslationIndex [2461 B]
Get:70 http://in.archive.ubuntu.com precise-updates/universe TranslationIndex [2850 B]
Get:71 http://in.archive.ubuntu.com precise-backports/main Sources [4225 B]
Get:72 http://in.archive.ubuntu.com precise-backports/restricted Sources [14 B]
Get:73 http://in.archive.ubuntu.com precise-backports/universe Sources [36.4 kB]
Get:74 http://in.archive.ubuntu.com precise-backports/multiverse Sources [5311 B]
Get:75 http://in.archive.ubuntu.com precise-backports/main amd64 Packages [4800 B]
Get:76 http://in.archive.ubuntu.com precise-backports/restricted amd64 Packages [14 B]
Get:77 http://in.archive.ubuntu.com precise-backports/universe amd64 Packages [37.9 kB]
Get:78 http://in.archive.ubuntu.com precise-backports/multiverse amd64 Packages [5206 B]
Get:79 http://in.archive.ubuntu.com precise-backports/main i386 Packages [4809 B]
Get:80 http://in.archive.ubuntu.com precise-backports/restricted i386 Packages [14 B]
Get:81 http://in.archive.ubuntu.com precise-backports/universe i386 Packages [37.7 kB]
Get:82 http://in.archive.ubuntu.com precise-backports/multiverse i386 Packages [5178 B]
Get:83 http://in.archive.ubuntu.com precise-backports/main TranslationIndex [72 B]
Get:84 http://in.archive.ubuntu.com precise-backports/multiverse TranslationIndex [72 B]
Get:85 http://in.archive.ubuntu.com precise-backports/restricted TranslationIndex [70 B]
Get:86 http://in.archive.ubuntu.com precise-backports/universe TranslationIndex [73 B]
Get:87 http://in.archive.ubuntu.com precise/main Translation-en [726 kB]
Get:88 http://in.archive.ubuntu.com precise/multiverse Translation-en [93.4 kB]
Get:89 http://in.archive.ubuntu.com precise/restricted Translation-en [2395 B]
Get:90 http://in.archive.ubuntu.com precise/universe Translation-en [3341 kB]
Get:91 http://in.archive.ubuntu.com precise-updates/main Translation-en [325 kB]
Get:92 http://in.archive.ubuntu.com precise-updates/multiverse Translation-en [8293 B]
Get:93 http://in.archive.ubuntu.com precise-updates/restricted Translation-en [2663 B]
Get:94 http://in.archive.ubuntu.com precise-updates/universe Translation-en [132 kB]
Get:95 http://in.archive.ubuntu.com precise-backports/main Translation-en [4235 B]
Get:96 http://in.archive.ubuntu.com precise-backports/multiverse Translation-en [4610 B]
Get:97 http://in.archive.ubuntu.com precise-backports/restricted Translation-en [14 B]
Get:98 http://in.archive.ubuntu.com precise-backports/universe Translation-en [27.6 kB]
Fetched 27.3 MB in 10min 55s (41.6 kB/s)
Reading package lists... Done

swamydkv@swamydkv-Inspiron-3437:~$ sudo dpkg --configure -a
swamydkv@swamydkv-Inspiron-3437:~$ sudo dpkg --clear-avail

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

swamydkv@swamydkv-Inspiron-3437:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade
Hit http://in.archive.ubuntu.com precise Release.gpg
Hit http://in.archive.ubuntu.com precise-updates Release.gpg
Hit http://oem.archive.canonical.com precise-oem-sp1 Release.gpg
Hit http://dell.archive.canonical.com precise-dell Release.gpg
Hit http://oem.archive.canonical.com precise-oem-sp1 Release
Hit http://dell.archive.canonical.com precise-dell Release
Hit http://oem.archive.canonical.com precise-oem-sp1/public Sources
Hit http://dell.archive.canonical.com precise-dell/public Sources
Hit http://security.ubuntu.com precise-security Release.gpg
Hit http://oem.archive.canonical.com precise-oem-sp1/public amd64 Packages
Hit http://oem.archive.canonical.com precise-oem-sp1/public i386 Packages
Ign http://oem.archive.canonical.com precise-oem-sp1/public TranslationIndex
Hit http://dell.archive.canonical.com precise-dell/public amd64 Packages
Hit http://dell.archive.canonical.com precise-dell/public i386 Packages
Ign http://dell.archive.canonical.com precise-dell/public TranslationIndex
Hit http://security.ubuntu.com precise-security Release
Hit http://security.ubuntu.com precise-security/main Sources
Hit http://in.archive.ubuntu.com precise-backports Release.gpg
Hit http://in.archive.ubuntu.com precise Release
Hit http://security.ubuntu.com precise-security/restricted Sources
Hit http://security.ubuntu.com precise-security/universe Sources
Hit http://security.ubuntu.com precise-security/multiverse Sources
Hit http://security.ubuntu.com precise-security/main amd64 Packages
Hit http://in.archive.ubuntu.com precise-updates Release
Hit http://in.archive.ubuntu.com precise-backports Release
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages
Hit http://security.ubuntu.com precise-security/universe amd64 Packages
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages
Hit http://security.ubuntu.com precise-security/main i386 Packages
Hit http://security.ubuntu.com precise-security/restricted i386 Packages
Hit http://security.ubuntu.com precise-security/universe i386 Packages
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://in.archive.ubuntu.com precise/main Sources
Hit http://in.archive.ubuntu.com precise/restricted Sources
Hit http://in.archive.ubuntu.com precise/universe Sources
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Hit http://in.archive.ubuntu.com precise/multiverse Sources
Hit http://in.archive.ubuntu.com precise/main amd64 Packages
Hit http://in.archive.ubuntu.com precise/restricted amd64 Packages
Hit http://in.archive.ubuntu.com precise/universe amd64 Packages
Hit http://in.archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://in.archive.ubuntu.com precise/main i386 Packages
Hit http://in.archive.ubuntu.com precise/restricted i386 Packages
Ign http://oem.archive.canonical.com precise-oem-sp1/public Translation-en
Ign http://dell.archive.canonical.com precise-dell/public Translation-en
Hit http://security.ubuntu.com precise-security/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://in.archive.ubuntu.com precise/universe i386 Packages
Hit http://in.archive.ubuntu.com precise/multiverse i386 Packages
Hit http://in.archive.ubuntu.com precise/main TranslationIndex
Hit http://in.archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://in.archive.ubuntu.com precise/universe TranslationIndex
Hit http://in.archive.ubuntu.com precise-updates/main Sources
Hit http://in.archive.ubuntu.com precise-updates/restricted Sources
Hit http://in.archive.ubuntu.com precise-updates/universe Sources
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Hit http://in.archive.ubuntu.com precise-updates/multiverse Sources
Hit http://in.archive.ubuntu.com precise-updates/main amd64 Packages
Hit http://in.archive.ubuntu.com precise-updates/restricted amd64 Packages
Hit http://in.archive.ubuntu.com precise-updates/universe amd64 Packages
Hit http://security.ubuntu.com precise-security/universe Translation-en
Hit http://in.archive.ubuntu.com precise-updates/multiverse amd64 Packages
Hit http://in.archive.ubuntu.com precise-updates/main i386 Packages
Hit http://in.archive.ubuntu.com precise-updates/restricted i386 Packages
Hit http://in.archive.ubuntu.com precise-updates/universe i386 Packages
Hit http://in.archive.ubuntu.com precise-updates/multiverse i386 Packages
Hit http://in.archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://in.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://in.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://in.archive.ubuntu.com precise-backports/main Sources
Hit http://in.archive.ubuntu.com precise-backports/restricted Sources
Hit http://in.archive.ubuntu.com precise-backports/universe Sources
Hit http://in.archive.ubuntu.com precise-backports/multiverse Sources
Hit http://in.archive.ubuntu.com precise-backports/main amd64 Packages
Hit http://in.archive.ubuntu.com precise-backports/restricted amd64 Packages
Hit http://in.archive.ubuntu.com precise-backports/universe amd64 Packages
Hit http://in.archive.ubuntu.com precise-backports/multiverse amd64 Packages
Hit http://in.archive.ubuntu.com precise-backports/main i386 Packages
Hit http://in.archive.ubuntu.com precise-backports/restricted i386 Packages
Hit http://in.archive.ubuntu.com precise-backports/universe i386 Packages
Hit http://in.archive.ubuntu.com precise-backports/multiverse i386 Packages
Hit http://in.archive.ubuntu.com precise-backports/main TranslationIndex
Hit http://in.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com precise-backports/restricted TranslationIndex
Hit http://in.archive.ubuntu.com precise-backports/universe TranslationIndex
Hit http://in.archive.ubuntu.com precise/main Translation-en
Hit http://in.archive.ubuntu.com precise/multiverse Translation-en
Hit http://in.archive.ubuntu.com precise/restricted Translation-en
Hit http://in.archive.ubuntu.com precise/universe Translation-en
Hit http://in.archive.ubuntu.com precise-updates/main Translation-en
Hit http://in.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://in.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://in.archive.ubuntu.com precise-updates/universe Translation-en
Hit http://in.archive.ubuntu.com precise-backports/main Translation-en
Hit http://in.archive.ubuntu.com precise-backports/multiverse Translation-en
Hit http://in.archive.ubuntu.com precise-backports/restricted Translation-en
Hit http://in.archive.ubuntu.com precise-backports/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  linux-firmware
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 23.3 MB of archives.
After this operation, 347 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main linux-firmware all 1.79.9 [23.3 MB]
Fetched 23.3 MB in 12min 9s (31.9 kB/s)
(Reading database ... 177430 files and directories currently installed.)
Preparing to replace linux-firmware 1.79.1 (using .../linux-firmware_1.79.9_all.deb) ...
Unpacking replacement linux-firmware ...
dpkg: error processing /var/cache/apt/archives/linux-firmware_1.79.9_all.deb (--unpack):
 trying to overwrite '/lib/firmware/ar3k/ramps_0x31010000_40.dfu', which is also in package bt-dw1705-firmware 0.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/linux-firmware_1.79.9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
swamydkv@swamydkv-Inspiron-3437:~$

swamydkv@swamydkv-Inspiron-3437:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

/etc/apt/sources.list.d/precise-dell.list

     1 deb http://dell.archive.canonical.com/updates/ precise-dell public
     2 deb-src http://dell.archive.canonical.com/updates/ precise-dell public

/etc/apt/sources.list.d/precise-oem-sp1.list

     1 deb http://oem.archive.canonical.com/updates/ precise-oem-sp1 public
     2 deb-src http://oem.archive.canonical.com/updates/ precise-oem-sp1 public

/etc/apt/sources.list

     1 #deb cdrom:[Ubuntu 12.04 _Precise_ - Build amd64 LIVE Binary 20130203-13:50]/ precise main
     2
     3 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4 # newer versions of the distribution.
     5 deb http://in.archive.ubuntu.com/ubuntu/ precise main restricted
     6 deb-src http://in.archive.ubuntu.com/ubuntu/ precise main restricted
     7
     8 ## Major bug fix updates produced after the final release of the
     9 ## distribution.
    10 deb http://in.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    11 deb-src http://in.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    12
    13 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14 ## team. Also, please note that software in universe WILL NOT receive any
    15 ## review or updates from the Ubuntu security team.
    16 deb http://in.archive.ubuntu.com/ubuntu/ precise universe
    17 deb-src http://in.archive.ubuntu.com/ubuntu/ precise universe
    18 deb http://in.archive.ubuntu.com/ubuntu/ precise-updates universe
    19 deb-src http://in.archive.ubuntu.com/ubuntu/ precise-updates universe
    20
    21 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    22 ## team, and may not be under a free licence. Please satisfy yourself as to
    23 ## your rights to use the software. Also, please note that software in
    24 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    25 ## security team.
    26 deb http://in.archive.ubuntu.com/ubuntu/ precise multiverse
    27 deb-src http://in.archive.ubuntu.com/ubuntu/ precise multiverse
    28 deb http://in.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    29 deb-src http://in.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    30
    31 ## N.B. software from this repository may not have been tested as
    32 ## extensively as that contained in the main release, although it includes
    33 ## newer versions of some applications which may provide useful features.
    34 ## Also, please note that software in backports WILL NOT receive any review
    35 ## or updates from the Ubuntu security team.
    36 deb http://in.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    37 deb-src http://in.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    38
    39 deb http://security.ubuntu.com/ubuntu precise-security main restricted
    40 deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    41 deb http://security.ubuntu.com/ubuntu precise-security universe
    42 deb-src http://security.ubuntu.com/ubuntu precise-security universe
    43 deb http://security.ubuntu.com/ubuntu precise-security multiverse
    44 deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
    45
    46 ## Uncomment the following two lines to add software from Canonical's
    47 ## 'partner' repository.
    48 ## This software is not part of Ubuntu, but is offered by Canonical and the
    49 ## respective vendors as a service to Ubuntu users.
    50 # deb http://archive.canonical.com/ubuntu precise partner
    51 # deb-src http://archive.canonical.com/ubuntu precise partner
    52
    53 ## Uncomment the following two lines to add software from Ubuntu's
    54 ## 'extras' repository.
    55 ## This software is not part of Ubuntu, but is offered by third-party
    56 ## developers who want to ship their latest software.
    57 # deb http://extras.ubuntu.com/ubuntu precise main
    58 # deb-src http://extras.ubuntu.com/ubuntu precise main
swamydkv@swamydkv-Inspiron-3437:~$

Swamy (swamydkv) said : #5

The Ubuntu Software Centre is working but I am not able to install linux-firmware, the error is seen in the above output

Actually, after a little more research, I found out that the package bt-dw1705-firmware is NOT an Ubuntu package at all.

linux-firmware is an official package, but bt-dw1705-firmware is not.

So you need to uninstall the bt-dw1705-firmware package as explained in post #6.

You can do the package comparison here:

http://packages.ubuntu.com/search?suite=all&section=all&arch=any&keywords=bt-dw1705-firmware&searchon=names

and here:

http://packages.ubuntu.com/search?suite=all&section=all&arch=any&keywords=linux-firmware&searchon=names

Please create a separate question/thread for the wireless issue using this link:

https://answers.launchpad.net/ubuntu/+addquestion

Swamy (swamydkv) said : #10

Is this a bt-dw1705-firmware not required?

Swamy (swamydkv) said : #11

Thanks Mark Rijckenberg, that solved my question.