i want to compile linphone android android project in ubuntu 12.04, i am new user, can anyone guide me step by step instructions to follow.

Asked by Adnan Qureshi

i am a basic level ubuntu user.. i want to to compile the source code of linphone android project in ubuntu 12.04..
can any one please guide me step by step instructions of how to download the project source code and compile it.. and finally import the linphone project in eclipse..

Question information

English Edit question
Ubuntu linphone Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

linphone android project can be downloaded from: http://www.linphone.org/eng/download/git.html

if anyone has compiled the source code of this project on ubuntu or windows, please contact me..
i can also give a small reward of 5$ if anyone guide me in this regard.

Revision history for this message
Manfred Hampl (m-hampl) said :

Have you read http://www.linphone.org/eng/documentation/guide/compiling.html and have you installed the packages that are shown there as required?
What Ubuntu release are you running?

You might be interested in the PPA https://launchpad.net/~rayanayar/+archive/linphone which seems to be just working on that application.

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

@Manfred Hampl
thanx for the prompt responce.

yes i 've downloaded and installed all packages from: http://www.linphone.org/eng/documentation/guide/compiling.html
i am using ubuntu 12.04 (precise).
I had also seen : https://launchpad.net/~rayanayar/+archive/linphone , but problem is that linphone is available for different platforms i.e android,iphone,blackberry,desktop etc.. i need linphone package for android phones..!! Is this linphone package ready for android phones..?

Revision history for this message
Manfred Hampl (m-hampl) said :

If you try compiling (I guess the commands should be ./configure && make && sudo make install) what happens?

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

this is what i have done so far;

1) i successfully downloaded the android linphone project from http://www.linphone.org/eng/download/git.html using git.
2) installed all the android sdk tools, ndk and jdk in the ubuntu 12.04 system
3) set the path variables of sdk tools and ndk
4) then finally from the command prompt of project folder, run the 'make' command. the run command executes successfully and start compiling the code.. but after sometime in the middle of compiling there is following ilbc error

" cd /Users/grahambriggs/Source/TPC_LithiumLinphone/linphone-android/submodules/libilbc-rfc3951/downloads && make \
    || ( echo "iLBC prepare stage failed" ; exit 1 )"

and due to this error i am unable to compile the project successfully.
please let me know what should i do to fix this issue.

Revision history for this message
Manfred Hampl (m-hampl) said :

Have you executed ./configure ?

What is the full output of
cd /Users/grahambriggs/Source/TPC_LithiumLinphone/linphone-android/submodules/libilbc-rfc3951/downloads

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

in the project directory, when i run the ./configure command on terminal, i get the following error message;

bash: ./configure: No such file or directory

what might be the problem for this..?

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

when i run the make command on terminal i get the following ;

adnan@adnan-HP-Spectre-XT-TouchSmart-PC:~/Desktop/linphone-android$ make
make: execvp: ./check_tools.sh: Permission denied
/home/adnan/Desktop/adt-bundle-linux-x86_64-20140321/sdk/tools/android update project --path . --target android-19
Updated project.properties
Updated local.properties
build.xml: Found version-tag: custom. File will not be updated.
Updated file ./proguard-project.txt
It seems that there are sub-projects. If you want to update them
please use the --subprojects parameter.
/home/adnan/Desktop/adt-bundle-linux-x86_64-20140321/sdk/tools/android update project --path liblinphone_tester --target android-19
Updated project.properties
Updated local.properties
Updated file liblinphone_tester/proguard-project.txt
(Stripping trailing CRs from patch; use --binary to disable.)
patching file submodules/externals/ffmpeg/library.mak
Hunk #1 FAILED at 54 (different line endings).
1 out of 1 hunk FAILED -- saving rejects to file submodules/externals/ffmpeg/library.mak.rej
make: *** [/home/adnan/Desktop/linphone-android/submodules/externals/ffmpeg/non_versioned_soname_patch_applied.txt] Error 1

Revision history for this message
Manfred Hampl (m-hampl) said :

Your output is contradictory.

In different posts the project directory seems to be
Post #5: /Users/grahambriggs/Source/TPC_LithiumLinphone/linphone-android
Post #8: /home/adnan/Desktop/linphone-android/

I do not understand what there is going on, so I do not know how to help further. Sorry.
Maybe you find answers by carefully reading all documentation (readme files) that come with the linphone source.

By the way: why are you trying to compile the package yourself? There should be a package for installation available in the Google play store https://play.google.com/store/apps/details?id=org.linphone&hl=en

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

dear first of all many thanx for your kind help and being very co-operative.

actually i forgot to mention that initially i was talking of my university computer having ubuntu 12.04.. in this case i i was stuck on ilbc error... so post5 was related. Post #5: /Users/grahambriggs/Source/TPC_LithiumLinphone/linphone-android

but now i posted the output from my home computer having latest distribution of ubuntu 14.04.
Post #8: /home/adnan/Desktop/linphone-android/

from google play store only the final application can be downloaded.. i can only install and use the app... but i need the source code of the app to modify it and use it according to my own needs.. thats why i need to download the source code and compile it.

hope now everything is clear :)

Revision history for this message
Adnan Qureshi (ad-qureshi-06) said :

if you have compiled the source of linphone-android project then please guide me.. or if you can figure out the issue and can help me.. then it would really be a great help for me.

Revision history for this message
Manfred Hampl (m-hampl) said :

I have not compiled linphone myself (and I am not planning to). I can only make suggestions based on documentation and/or messages in your logs.

I propose you read all documentation, make sure to have all dependencies installed, and try the build commands as given in the documentation. On one of the web pages that is a "configure" script mentioned. Can you search if you find that somewhere in the source directories?

Revision history for this message
mohsin (jmi-mohsin) said :

I have successfully compiled and run linphone android project and also customized as well. I posted whole process here: http://www.coders-hub.com/2015/04/start-working-on-linphone-android-part-1.html

Must read and share.

Can you help with this problem?

Provide an answer of your own, or ask Adnan Qureshi for more information if necessary.

To post a message you must log in.