Newer lilypond can't be built from sources "the Ubuntu way"

Asked by Emmanuel Charpentier on 2008-07-04

Binary package hint: lilypond

Running Hardy, following -security, -updates, -proposed and -backports.

I'm trying to build lilypond 2.11.50 to test new features (2.10.33 looks *antique* to lilypond-users mailing list readers, who seem reluctant to chase bugs on an antiquated version).

I was used to the Debian system (debian/rules build ; fakeroot debian/rules binary ). Not very familiar with the Ubuntu tools, I'm following https://wiki.ubuntu.com/PackagingGuide/Recipes/PackageUpdate literally (and a bit asininely).

Dependencies : I had a bit of picnic installing python2.5-dev : the current -updates python2.5 package is a bit newer that the regular one, but there is not (yet !) a corresponding -dev package in -updates. I had to manually dpkg -i the intrepid package, which happens to be the same version level than -updates python2.5. Minor boboo...

All goes well up to the pbuilder stage, which reveals pseudo-unsatisfied build dependences on virtual packages. The full log is at the end of this mail ; the crucial part seems to be :

The following packages have unmet dependencies:
  pbuilder-satisfydepends-dummy: Depends: guile-1.8-dev which is a virtual package.
                                 Depends: mftrace (>= 1.1.19) which is a virtual package.
                                 Depends: emacs-intl-fonts which is a virtual package.
                                 Depends: xfonts-intl-arabic which is a virtual package.
                                 Depends: xfonts-intl-asian which is a virtual package.
                                 Depends: xfonts-intl-chinese which is a virtual package.
                                 Depends: xfonts-intl-chinese-big which is a virtual package.
                                 Depends: xfonts-intl-european which is a virtual package.
                                 Depends: xfonts-intl-japanese which is a virtual package.
                                 Depends: xfonts-intl-japanese-big which is a virtual package.
                                 Depends: xfonts-intl-phonetic which is a virtual package.

Of course, all these packages *are* installed :

charpent@yod:~/Developpements/lilypond$ sudo apt-get build-dep -s lilypond
[sudo] password for charpent:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

The problem might be with pbuilder, which seems to have problems accepting virtual packages.

Should I :
   - replace dependencies on virtual packages by dependencies on the real ones in debian/rules ?
   - try to build "the Debian way" ?
   - file a bug against pbuilder ?
   - run in circles, scream and shout ?
   - pout ?

I have to admit that I have trouble understanding the "pbuilder way" and the necessity of such a huge chroot jail to build a package ... (140 MB for the "base" pbuilder archive (compressed !) alone ...).

                                                                                Emmanuel Charpentier

Here is the pbuilder execution output :

charpent@yod:~/Developpements/lilypond$ sudo pbuilder build lilypond_2.11.50-0ubuntu1.dsc
[sudo] password for charpent:
W: /home/charpent/.pbuilderrc does not exist
I: using fakeroot in build.
Current time: Fri Jul 4 21:40:33 CEST 2008
pbuilder-time-stamp: 1215200433
Building the build Environment
 -> extracting base tarball [/var/cache/pbuilder/base.tgz]
 -> creating local configuration
 -> copying local configuration
 -> mounting /proc filesystem
 -> mounting /dev/pts filesystem
 -> policy-rc.d already exists
Obtaining the cached apt archive contents
Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: i386
Maintainer: Debian Pbuilder Team <email address hidden>
Description: Dummy package to satisfy dependencies with aptitude - created by pbuilder
 This package was created automatically by pbuilder and should
Depends: bison (<< 1:1.50) | bison (>> 1:1.75-1), debhelper (>= 5), flex (>= 2.5.4a-14) | flex-old, fontforge, gettext (>= 0.10.36-1), ghostscript, groff, guile-1.8-dev, libfontconfig1-dev (>= 2.4.1-1), libfreetype6-dev, libgmp3-dev, libltdl3-dev, libpango1.0-dev, m4, mftrace (>= 1.1.19), pkg-config (>= 0.9.0), python-dev (>= 2.4), python-support (>= 0.4), texinfo (>= 4.8.dfsg.1-1), texlive-generic-recommended, texlive-latex-base, emacs-intl-fonts, gsfonts | gsfonts-x11, imagemagick, netpbm (>= 2:9.10-1), rsync, ttf-dejavu, ttf-freefont, ttf-kochi-gothic, ttf-kochi-mincho, xfonts-intl-arabic, xfonts-intl-asian, xfonts-intl-chinese, xfonts-intl-chinese-big, xfonts-intl-european, xfonts-intl-japanese, xfonts-intl-japanese-big, xfonts-intl-phonetic
Conflicts: guile-1.8-dev (= 1.8.2+1-2), gs-gpl (= 8.01-1), gs-gpl (= 8.01-2), gs-gpl (= 8.01-3), gs-gpl (= 8.01-4)
dpkg-deb: building package `pbuilder-satisfydepends-dummy' in `/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Reading package lists... Done
Building dependency tree
Reading state information... Done
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Selecting previously deselected package pbuilder-satisfydepends-dummy.
(Reading database ... 12190 files and directories currently installed.)
Unpacking pbuilder-satisfydepends-dummy (from .../pbuilder-satisfydepends-dummy.deb) ...
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on bison (<< 1:1.50) | bison (>> 1:1.75-1); however:
  Package bison is not installed.
  Package bison is not installed.
 pbuilder-satisfydepends-dummy depends on debhelper (>= 5); however:
  Package debhelper is not installed.
 pbuilder-satisfydepends-dummy depends on flex (>= 2.5.4a-14) | flex-old; however:
  Package flex is not installed.
  Package flex-old is not installed.
 pbuilder-satisfydepends-dummy depends on fontforge; however:
  Package fontforge is not installed.
 pbuilder-satisfydepends-dummy depends on gettext (>= 0.10.36-1); however:
  Package gettext is not installed.
 pbuilder-satisfydepends-dummy depends on ghostscript; however:
  Package ghostscript is not installed.
 pbuilder-satisfydepends-dummy depends on groff; however:
  Package groff is not installed.
 pbuilder-satisfydepends-dummy depends on guile-1.8-dev; however:
  Package guile-1.8-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libfontconfig1-dev (>= 2.4.1-1); however:
  Package libfontconfig1-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libfreetype6-dev; however:
  Package libfreetype6-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libgmp3-dev; however:
  Package libgmp3-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libltdl3-dev; however:
  Package libltdl3-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libpango1.0-dev; however:
  Package libpango1.0-dev is not installed.
 pbuilder-satisfydepends-dummy depends on m4; however:
  Package m4 is not installed.
 pbuilder-satisfydepends-dummy depends on mftrace (>= 1.1.19); however:
  Package mftrace is not installed.
 pbuilder-satisfydepends-dummy depends on pkg-config (>= 0.9.0); however:
  Package pkg-config is not installed.
 pbuilder-satisfydepends-dummy depends on python-dev (>= 2.4); however:
  Package python-dev is not installed.
 pbuilder-satisfydepends-dummy depends on python-support (>= 0.4); however:
  Package python-support is not installed.
 pbuilder-satisfydepends-dummy depends on texinfo (>= 4.8.dfsg.1-1); however:
  Package texinfo is not installed.
 pbuilder-satisfydepends-dummy depends on texlive-generic-recommended; however:
  Package texlive-generic-recommended is not installed.
 pbuilder-satisfydepends-dummy depends on texlive-latex-base; however:
  Package texlive-latex-base is not installed.
 pbuilder-satisfydepends-dummy depends on emacs-intl-fonts; however:
  Package emacs-intl-fonts is not installed.
 pbuilder-satisfydepends-dummy depends on gsfonts | gsfonts-x11; however:
  Package gsfonts is not installed.
  Package gsfonts-x11 is not installed.
 pbuilder-satisfydepends-dummy depends on imagemagick; however:
  Package imagemagick is not installed.
 pbuilder-satisfydepends-dummy depends on netpbm (>= 2:9.10-1); however:
  Package netpbm is not installed.
 pbuilder-satisfydepends-dummy depends on rsync; however:
  Package rsync is not installed.
 pbuilder-satisfydepends-dummy depends on ttf-dejavu; however:
  Package ttf-dejavu is not installed.
 pbuilder-satisfydepends-dummy depends on ttf-freefont; however:
  Package ttf-freefont is not installed.
 pbuilder-satisfydepends-dummy depends on ttf-kochi-gothic; however:
  Package ttf-kochi-gothic is not installed.
 pbuilder-satisfydepends-dummy depends on ttf-kochi-mincho; however:
  Package ttf-kochi-mincho is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-arabic; however:
  Package xfonts-intl-arabic is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-asian; however:
  Package xfonts-intl-asian is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-chinese; however:
  Package xfonts-intl-chinese is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-chinese-big; however:
  Package xfonts-intl-chinese-big is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-european; however:
  Package xfonts-intl-european is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-japanese; however:
  Package xfonts-intl-japanese is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-japanese-big; however:
  Package xfonts-intl-japanese-big is not installed.
 pbuilder-satisfydepends-dummy depends on xfonts-intl-phonetic; however:
  Package xfonts-intl-phonetic is not installed.
dpkg: error processing pbuilder-satisfydepends-dummy (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pbuilder-satisfydepends-dummy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
The following packages are BROKEN:
  pbuilder-satisfydepends-dummy
The following NEW packages will be automatically installed:
  bison debhelper defoma ed file flex fontconfig fontconfig-config
  fontforge gettext ghostscript groff groff-base gsfonts html2text
  imagemagick intltool-debian libatk1.0-0 libcairo2 libcairo2-dev libcroco3
  libcupsimage2 libcupsys2 libdatrie0 libdjvulibre15 libexpat1
  libexpat1-dev libfontconfig1 libfontconfig1-dev libfreetype6
  libfreetype6-dev libgd2-noxpm libgif4 libglib2.0-0 libglib2.0-dev
  libgmp3-dev libgmp3c2 libgmpxx4ldbl libgraphviz4 libgs8 libgsf-1-114
  libgsf-1-common libgtk2.0-0 libgtk2.0-common libice-dev libice6
  libjasper1 libjpeg62 libkpathsea4 liblcms1 libltdl3 libltdl3-dev
  libmagic1 libmagick10 libnetpbm10 libopenexr2ldbl libpango1.0-0
  libpango1.0-common libpango1.0-dev libpaper1 libpcre3 libpixman-1-0
  libpixman-1-dev libpng12-0 libpng12-dev libpoppler2 libpthread-stubs0
  libpthread-stubs0-dev librsvg2-2 libsm-dev libsm6 libspiro0 libthai-data
  libthai0 libtiff4 libuninameslist0 libwmf0.2-7 libx11-6 libx11-data
  libx11-dev libxau-dev libxau6 libxaw7 libxcb-xlib0 libxcb-xlib0-dev
  libxcb1 libxcb1-dev libxcomposite1 libxcursor1 libxdamage1 libxdmcp-dev
  libxdmcp6 libxext6 libxfixes3 libxft-dev libxft2 libxi6 libxinerama1
  libxml2 libxmu6 libxpm4 libxrandr2 libxrender-dev libxrender1 libxt6 m4
  netpbm pkg-config po-debconf python-dev python-support python2.5-dev
  rsync tex-common texinfo texlive-base texlive-base-bin texlive-common
  texlive-doc-base texlive-generic-recommended texlive-latex-base
  ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-freefont ttf-kochi-gothic
  ttf-kochi-mincho ucf x11-common x11proto-core-dev x11proto-input-dev
  x11proto-kb-dev x11proto-render-dev xdg-utils xtrans-dev zlib1g-dev
The following NEW packages will be installed:
  bison debhelper defoma ed file flex fontconfig fontconfig-config
  fontforge gettext ghostscript groff groff-base gsfonts html2text
  imagemagick intltool-debian libatk1.0-0 libcairo2 libcairo2-dev libcroco3
  libcupsimage2 libcupsys2 libdatrie0 libdjvulibre15 libexpat1
  libexpat1-dev libfontconfig1 libfontconfig1-dev libfreetype6
  libfreetype6-dev libgd2-noxpm libgif4 libglib2.0-0 libglib2.0-dev
  libgmp3-dev libgmp3c2 libgmpxx4ldbl libgraphviz4 libgs8 libgsf-1-114
  libgsf-1-common libgtk2.0-0 libgtk2.0-common libice-dev libice6
  libjasper1 libjpeg62 libkpathsea4 liblcms1 libltdl3 libltdl3-dev
  libmagic1 libmagick10 libnetpbm10 libopenexr2ldbl libpango1.0-0
  libpango1.0-common libpango1.0-dev libpaper1 libpcre3 libpixman-1-0
  libpixman-1-dev libpng12-0 libpng12-dev libpoppler2 libpthread-stubs0
  libpthread-stubs0-dev librsvg2-2 libsm-dev libsm6 libspiro0 libthai-data
  libthai0 libtiff4 libuninameslist0 libwmf0.2-7 libx11-6 libx11-data
  libx11-dev libxau-dev libxau6 libxaw7 libxcb-xlib0 libxcb-xlib0-dev
  libxcb1 libxcb1-dev libxcomposite1 libxcursor1 libxdamage1 libxdmcp-dev
  libxdmcp6 libxext6 libxfixes3 libxft-dev libxft2 libxi6 libxinerama1
  libxml2 libxmu6 libxpm4 libxrandr2 libxrender-dev libxrender1 libxt6 m4
  netpbm pkg-config po-debconf python-dev python-support python2.5-dev
  rsync tex-common texinfo texlive-base texlive-base-bin texlive-common
  texlive-doc-base texlive-generic-recommended texlive-latex-base
  ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-freefont ttf-kochi-gothic
  ttf-kochi-mincho ucf x11-common x11proto-core-dev x11proto-input-dev
  x11proto-kb-dev x11proto-render-dev xdg-utils xtrans-dev zlib1g-dev
0 packages upgraded, 136 newly installed, 0 to remove and 0 not upgraded.
Need to get 72.3MB/72.9MB of archives. After unpacking 225MB will be used.
The following packages have unmet dependencies:
  pbuilder-satisfydepends-dummy: Depends: guile-1.8-dev which is a virtual package.
                                 Depends: mftrace (>= 1.1.19) which is a virtual package.
                                 Depends: emacs-intl-fonts which is a virtual package.
                                 Depends: xfonts-intl-arabic which is a virtual package.
                                 Depends: xfonts-intl-asian which is a virtual package.
                                 Depends: xfonts-intl-chinese which is a virtual package.
                                 Depends: xfonts-intl-chinese-big which is a virtual package.
                                 Depends: xfonts-intl-european which is a virtual package.
                                 Depends: xfonts-intl-japanese which is a virtual package.
                                 Depends: xfonts-intl-japanese-big which is a virtual package.
                                 Depends: xfonts-intl-phonetic which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
pbuilder-satisfydepends-dummy

Score is -9850

The following NEW packages will be automatically installed:
  file libmagic1 libpng12-0
The following packages will be automatically REMOVED:
  pbuilder-satisfydepends-dummy
The following NEW packages will be installed:
  file libmagic1 libpng12-0
The following packages will be REMOVED:
  pbuilder-satisfydepends-dummy
0 packages upgraded, 3 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B/561kB of archives. After unpacking 2318kB will be used.
Writing extended state information... Done
(Reading database ... 12190 files and directories currently installed.)
Removing pbuilder-satisfydepends-dummy ...
Selecting previously deselected package libmagic1.
(Reading database ... 12190 files and directories currently installed.)
Unpacking libmagic1 (from .../libmagic1_4.21-3_i386.deb) ...
Selecting previously deselected package file.
Unpacking file (from .../archives/file_4.21-3_i386.deb) ...
Selecting previously deselected package libpng12-0.
Unpacking libpng12-0 (from .../libpng12-0_1.2.15~beta5-3_i386.deb) ...
Setting up libmagic1 (4.21-3) ...

Setting up file (4.21-3) ...
Setting up libpng12-0 (1.2.15~beta5-3) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
Aptitude couldn't satisfy the build dependencies
E: pbuilder-satisfydepends failed.
Copying back the cached apt archive contents
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> cleaning the build env
    -> removing directory /var/cache/pbuilder/build//14192 and its subdirectories

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lilypond Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-04
Last reply:
2008-10-12
Ralph Janke (txwikinger) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Ralph Janke (txwikinger) said : #2

Thanks for this question.

In order to allow us to try to help you with this problem, please provide more information about your pbuilder configuration files and your pbuilder commandline arguments.

Thanks

Gauvain Pocentek (gpocentek) said : #3

Building the 'debian way' will work, you don't have to use pbuilder.
Debian and Ubuntu packages are the same, use the same tools to be built, etc...

It happens cuz it's a package which is virtual for packages that are in universe. You have to enable universe repositories. Do this:

sudo pbuilder update --components "main restricted universe multiverse" --override-config

And it will work.

Can you help with this problem?

Provide an answer of your own, or ask Emmanuel Charpentier for more information if necessary.

To post a message you must log in.