Update Package to Latest

Asked by Robert M Campbell on 2011-07-05

Is it possible for someone to release the latest stable version of lilypond(2.14.1)? Currently, the repository contains version 2.12.3 which was from two years ago.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lilypond Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-05
Last reply:
2011-12-19
Mathilda Young (gtrsdk) said : #1

Which version of Ubuntu are you using?

Mathilda Young (gtrsdk) said : #2

I have found information about Lilypond, and 2.14.1 came out in June 2011, so there might not be an update for it in Natty, but it could be in Oneiric. To get 2.14.1, you would have to get it from a PPA or compile it on Natty.

Could log a bug stating the security fixes in the new version, if they are significant it will be fast tracked. Having the latest packages are not the norm as there needs to be testing so that new users to Linux (The intended audience of Ubuntu) get a solid experience rather than pushing for the latest packages just to keep up. The most solid version will be used in the releases.

Could log a bug stating the security fixes in the new version, if they are significant it will be fast tracked. Having the latest packages are not the norm as there needs to be testing so that new users to Linux (The intended audience of Ubuntu) get a solid experience rather than pushing for the latest packages just to keep up. The most solid version will be used in the releases.

I am currently using Natty (Ubuntu 11.04). I will work on filling a bug report if there are any major security fixes. We really are just looking to have the latest stable version of Lilypond, not a testing or experimental version. What would it take to get the latest stable in Oneiric?

For a listing of all fixes for 2.14 since 2.12 you can see them at http://lilypond.org/doc/v2.14/Documentation/changes/index.html

Not sure what changed from 2.13 to 2.14, but am sure there area few...

AmateurDev (guitrguy595) said : #6

The Lilypond package has been updated to 2.14.2 for 12.04, would it be safe to go ahead and update it for Oneiric?

AmateurDev (guitrguy595) said : #7

Oops, the above post was supposed to be a comment, not an answer.

If you are using Oneiric you can run:

sudo add-apt-repository ppa:doko/toolchain ; sudo apt-get update; sudo apt-get install lilypond

https://launchpad.net/~doko/+archive/toolchain?field.series_filter=natty

The build failed last but when it passes you will get updated.

Can you help with this problem?

Provide an answer of your own, or ask Robert M Campbell for more information if necessary.

To post a message you must log in.