Segmentation faults when not running with root privileges

Asked by Deapesh

I am running Ubuntu 8.04 (2.6.24-22.45-generic) on an aging test machine.

I am not too sure as to what is the cause of this problem. I keep triggering segmentation faults when running userland programs. Strangely, if I run them via sudo, these programs do not crash.

Eg.: running gimp, then trying to open a file results in seg fault with the following message:
(script-fu:13269): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Segmentation fault
but doing the same action via 'sudo gimp' does not cause the crash.

Similarly for the package revelation. ( I opened Bug #302695 for it, but perhaps will have to close it).

How can I ascertain the cause?


Question information

English Edit question
Ubuntu lighttpd Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Deapesh (deapesh) said :

hmm...wrong place to ask!

Revision history for this message
Waldir Leoncio (wleoncio) said :

I can confirm this problem. It is affecting Gimp, GThumb and OpenOffice here.

Revision history for this message
Hackbert (paul-kremser) said :

This is not solved who marked it? It affects all gtk apps, and is mentioned in Bug #287601:

Sry, but this bug is still present.

If you upgrade inteprid to 'stable', many of changers may get this problem...