A Dell Optiplex will not reboot after a fresh install of Ubuntu 18.04.

Asked by Rex Bouwense on 2018-08-22

Installed Ubuntu 18.04 on a Dell Optiplex but after the withdrawal of the flash drive and pressing enter to reboot the computer, the computer screen froze just before the login appeared. After some research, it was discovered that the LightDM has been replaced as the default login display manager by GDM3 which apparently is a lot heavier. Although the Dell Optiplex is over ten years old it still meets the minimum requirements for the installation of Ubuntu. It will install and reboot after installation of all of the Ubuntu "flavors" [Kubuntu, Ubuntu Mate, Ubuntu Budgie, Xubuntu, and Lubuntu] as well as Ubuntu 16.04.4. If a computer meets the minimum install requirements it should be able to install Ubuntu. As a work around the LightDM was installed and made the default login display manager. That works as expected. Is the new default login display manager to heavy for some computers to load?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu lightdm Edit question
Assignee:
No assignee Edit question
Last query:
2018-08-22
Last reply:
2018-08-25
Rex Bouwense (rexbouwense) said : #1

Should this be filed as a bug report even though there is a work around?

I suggest you report a bug. State that LightDM works fine and so on.

A Raghuram (araghuramindia) said : #3

See if the following steps help you:

1) Choose recovery mode from the GRUB menu
2) Choose resume normal boot from the recovery menu
3) If you are able to get the login screen,
    after logging in, uncomment the line "WaylandEnable=False" statement in the "/etc/gdm3/custom.conf" file and save it
4) Then restart for a normal reboot.

I had the same problem with a non-Dell desktop computer and the above steps solved it.

Rex Bouwense (rexbouwense) said : #4

These steps also produce a system that will boot just as the work around with making the LightDM the default described in the initial question. A bug report has been filed, #1788440

A Raghuram (araghuramindia) said : #5

In my opinion, the cause of ths bug could be in how Wayland is being handled in Ubuntu Bionic Beaver and not the lightdm.

In fact, when I booted through recovery mode (before changing the WaylandEnable statement), my monitor detection and resolution were incorrect i.e. 1280 x 1024 (5:4) instead of 1440 X 900 (16:10).

However, when I booted after changing the WaylandEnable statement, the monitor detection and resolution were correctly picked up.

Rex Bouwense (rexbouwense) said : #6

In the first instance the LightDM had to be installed and made default for the system to boot so you may be correct. It certainly isn't the LightDM that caused the problem. When I installed again using 2nd work around (uncommenting the Wayland statement) the system again booted correctly.

A Raghuram (araghuramindia) said : #7

You may like to refer to bug # 1727356 which has been assigned to Marco Trevisan for this. The interactions between specialists makes an interesting reading. Hopefully, once this bug gets rectified, our issue would vanish.

A Raghuram (araghuramindia) said : #8

The problem is officially solved with update to package ---> mutter 3.28.3-2~ubuntu18.04.2 released yesterday (bug# 1727356). Works fine on my 10-year old Desktop with Intel® Core™2 CPU 6400 @ 2.13GHz × 2 and Intel® G33 Graphics chipset with Wayland enabled.

You may like to try.

Can you help with this problem?

Provide an answer of your own, or ask Rex Bouwense for more information if necessary.

To post a message you must log in.